Jump to content

[Résolu] Transfert du site local chez mon hébergeur - message erreur


Recommended Posts

Bonjour

Je travaille sur la maquette d'un site que je dois présenter avant la fin de la semaine. J'ai installé en local Prestashop et effectué des aménagements visuels. Pour assurer la présentation sur l'ordinateur de mon client, j'ai voulu transférer chez mon hébergeur, tout le travail effectué. La BDD a bien été exporté, ainsi que les fichiers Prestashop.

Mais voilà patatras, quand j'essaie d'ouvrir j'ai le message suivant :

Warning: Smarty::include() [function.include]: Failed opening 'd:\www\"nom de mon site.com"\htdocs\prestashop/tools/smarty/compile\%v^766^7668EB74%%index.tpl.php' for inclusion (include_path='.;C:\php5\pear') in d:\www"nom de mon site.com"\htdocs\prestashop\tools\smarty\Smarty.class.php on line 1259

Déjà je trouve curieux, c'est ce "\" après les www et pas de "."
Puis le message qui suit. J'ai lu sur un autre topic, qu'il fallait supprimer les fichiers dans le dossier compile de smarty en gardant le fichier "index.php". j'ai fait l'essai, mais cela ne fonctionne toujours pas.

Je vous remercie si vous avez une piste pour me sortir du brouillard.
Cap.

Share this post


Link to post
Share on other sites

Et lorsque j'essaie de rentrer dans l'espace Admin, j'ai ce message :

Fatal error: require_once() [function.require]: Failed opening required 'd:\www\"nom de mon site.com"\htdocs\prestashop\admin1962/prestashop/images.inc.php' (include_path='.;C:\php5\pear') in d:\www\"nom de mon site.com\htdocs\prestashop\admin1962\functions.php on line 14

Merci pour votre aide.

Cap.

Share this post


Link to post
Share on other sites

Bonjour,

ça ne me parle pas spécialement ces messages d'erreurs, je vais donc laisser répondre un développeur néanmoins je vous suggère de vérifier vos droits d'écritures sur les fichiers/répertoires de votre FTP ...

Cordialement, Thierry

Share this post


Link to post
Share on other sites

Bonjour et Merci Thierry

Comme je vais reprendre le transfert (n'ayant pas trouvé de solution) de l'ensemble
Je vais en profiter pour vérifier :
- les droits en écriture des fichiers
- si le fichier settings.inc.php est correct
- si tout est bien copié

D'autres solutions trouvé sur différents sujets de discussion :
• Vider le fichier tools/smarty/compile en gardant l'index.php

Pour ma part la solution de vider le fichier compile (que j'ai vu sur un autre topic) n'a pas fonctionné. Ce qui est rigolo, c'est que des fichiers wrp0000.tmp sont créés…
Sur mon local le fichier compile contient des files du style : %
^0AC^0ACA5E60%%contact-form.tpl.php
est-ce normal ?

• Solution créer un fichier .htaccess
Je n'ai pas vraiment essayé, car sur mac impossible de créer un fichier .htaccess. De plus sur la version 1.2.5 PS je n'ai pas le bouton "générer" dans les préférences du BO pour créer ce fichier.

Voilà pour l'instant où j'en suis. Mais bon je continue.
Merci encore

Share this post


Link to post
Share on other sites

^0AC^0ACA5E60%%contact-form.tpl.php > c'est normal oui

Pour le htaccess, pourquoi ne pas en créer un via notepad , l'enregistrer avec une extension .txt et une fois sur le serveur le renommer en .htaccess ?

ne pas oublier de lui donner les droits d'écriture la aussi ...

-----------------------------------------

Mmm c'est quoi ce chemin en fait ?

\www\“nom de mon site.com”\htdocs\prestashop\admin1962/prestashop/images.inc.php

ça devrait être logiquement quelque chose comme ca :

\www\“nom de mon site.com”\prestashop\admin1962/prestashop/images.inc.php

est ce que ça n'est pas le htdocs qui pose problème ?

Share this post


Link to post
Share on other sites

Oui je vais essayer de voir si ce n'est pas ce htdocs qui initialement sur mon dossier local se trouvait dans Xampp,… et qui n'est plus à la racine de mon site. Je vais vérifier cela et posterai le résultat des courses.

Merci Thierry

Cap.

Share this post


Link to post
Share on other sites

Bonjour
Je vous fais le topo d'où j'en suis.

J'arrive maintenant à avoir le BO ; il s'agissait bien d'une histoire htdocs…
Bon, il me reste à chercher autour de la boutique qui reste blanche.

Merci Thierry pour cette piste !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More