Jump to content

Prestashop 1.6, Multiboutique Et Page Cms Bug


Recommended Posts

Bonjour,

 

je rencontre un bug au sein de ma page cms sur l'administration de prestashop.

 

Je ne sais pas si cela est dû à l’activation du multiboutique, c'est ce que je suspecte, mais depuis cela, certaines pages du cms ne s'affiche plus. Enfin c'est plutôt le nom de la page qui ne s'affiche plus car si je clique sur la ligne vide, j'accède bien à la page avec le détail de celle-ci. 

post-366103-0-01983600-1457791042_thumb.png

 

De même en front office par exemple dans le sitemap, j'ai des trous sur certains pages où le titre ne s'affiche pas, mais si je clique sur la petit flêche devant je peux quand même accéder à la page. Il y a juste l'id dans le lien mais pas le titre, mais la page est quand même retrouvée.

post-366103-0-64551000-1457791489_thumb.png

 

 

 

Merci d'avance de votre aide

 

 

Share this post


Link to post
Share on other sites

Il semblerai que quand tu as activé le multi-boutique prestashop n'ait pas pu dupliquer les informations langues.

 

On peut suspecter très probablement le serveur / max_execution_time par contre c'est très inquiétant, car il y a fort à parier qu'il n'y ai pas eu que cette table qui ait raté la duplication et les résultats peuvent être très pernicieux.

Share this post


Link to post
Share on other sites

Merci de votre retour

 

A première vu je n'ai pas constaté d'autres bugs sur d'autres tables mais je vais creuser cela plus en détail.

 

Que me conseillez-vous pour remédier à ce problème ou essayer de le corriger ?

Share this post


Link to post
Share on other sites

SELECT *
from ps_cms c
left join ps_cms_lang cl on cl.id_cms = c.id_cms
order by c.id_cms, cl.id_lang cl.id_shop;

Attention en fonction du nombre de boutique et de langue il peut y avoir pas mal de résultats retournés

Share this post


Link to post
Share on other sites

Ce qui est surprenant aussi c'est que dans le footer du site il y a aussi des pages de cms d'affichées, comme "paiement sécurisée" et d'autres que nous avons ajoutées et là elles s'affichent bien avec le bon lien  :huh: 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More