Jump to content
Manu.O

Modules Et Services Inaccessible

Recommended Posts

Bonjour, 

J'ai un problème de taille avec prestashop 1.6.1.4 et je n'arrive pas à trouver de solution, quand je clic sur "modules et service" de mon back office une page d'erreur s'affiche :

 

[PrestaShop] Fatal error in module file :/home/magicmyszu/www/modules/yousticeresolutionsystem/SDK/Local.php:
Uncaught exception 'InvalidArgumentException' with message 'PDOException was thrown while connecting' in /home/magicmyszu/www/modules/yousticeresolutionsystem/SDK/Local.php:38 Stack trace: #0 /home/magicmyszu/www/modules/yousticeresolutionsystem/SDK/Api.php(693): YousticeLocal->__construct(Array) #1 /home/magicmyszu/www/modules/yousticeresolutionsystem/yousticeresolutionsystem.php(54): YousticeApi->setDbCredentials(Array) #2 /home/magicmyszu/www/modules/yousticeresolutionsystem/yousticeresolutionsystem.php(36): YousticeResolutionSystem->createApi() #3 [internal function]: YousticeResolutionSystem->__construct() #4 /home/magicmyszu/www/Core/Foundation/IoC/Core_Foundation_IoC_Container.php(124): ReflectionClass->newInstance() #5 /home/magicmyszu/www/Core/Foundation/IoC/Core_Foundation_IoC_Container.php(157): Core_Foundation_IoC_Container->makeInstanceFromClassName('yousticeresolut...', Array) #6 /home/magicmyszu/www/Core/Foundation/IoC/Core_Foundation_IoC_Container.php(170): Core_Foundation_IoC_Container->doMak

 

Si une personne a une solution à ce problème, elle seras la bienvenue, merci d'avance. 

Edited by magic-mystic (see edit history)

Share this post


Link to post
Share on other sites

Supprimez le module yousticeresolutionsystem de votre ftp et prévenez le développeur du problème.

  • Like 1

Share this post


Link to post
Share on other sites

Un énorme merci pour ton aide, j'ai suivi tes explications et j'ai de nouveau accès aux modules et services, je peu me remettre au travail.  :)

Share this post


Link to post
Share on other sites

Bonjour,

J'ai le même problème que toi....comment faire pour Supprimez le module yousticeresolutionsystem de votre ftp...et pourquoi prévenir mon developpeur...sachant que je ne suis pas une bête en informatique.

Merci d'avance.

Corinne

Share this post


Link to post
Share on other sites

Bonjour,

J'ai le même problème que toi....comment faire pour Supprimez le module yousticeresolutionsystem de votre ftp...et pourquoi prévenir mon developpeur...sachant que je ne suis pas une bête en informatique.

Merci d'avance.

Corinne

Envoyez-moi un accès ftp par MP on va réparer ça^^

Share this post


Link to post
Share on other sites

Bonjour, j'ai suivi les conseils de Eolia et tout c'est bien passer, avertir le développeur c'est l'informer du bug causé par le module, après il règle le problème ou pas.

Bonne Journée,

magic-mystic.

Share this post


Link to post
Share on other sites

Bonjour,

Meme problème, suite à un clic sur le bouton "install" du module 'Prestashop Checkout' (solution de paiement qui semblait intéressante)

Presta en Version 1.6.1.0, herbergé chez OVH.

J'ai ce message:

[PrestaShop] Fatal error in module file :/home/cosmetiqzt/www/classes/module/Module.php(1331) : eval()'d code:
Arrays are not allowed in class constants

 

Si je comprends bien les conseils plus haut, je me connecte au FTP et je supprime le dossier "module"?

NOTA, je ne maîtrise pas du tout HTML, PHP, CSS... je sais accéder au FTP via Filezilla c'est déjà ça.

 

Share this post


Link to post
Share on other sites
Il y a 1 heure, mobius.cosmetiques a dit :

Si je comprends bien les conseils plus haut, je me connecte au FTP et je supprime le dossier "module"?

SURTOUT PAS ! SINON VOUS ALLEZ PERDRE TOUS VOS MODULES !!!!

 

Uniquement le sous-répertoire /modules/ps_checkout

Share this post


Link to post
Share on other sites
1 hour ago, Eolia said:

SURTOUT PAS ! SINON VOUS ALLEZ PERDRE TOUS VOS MODULES !!!!

 

Uniquement le sous-répertoire /modules/ps_checkout

Ouf!! 

Merci!

ça (Re) fonctionne nickel!

Milles mercis pour votre réponse ultra rapide!!

Share this post


Link to post
Share on other sites

Bonsoir,

Suite à l'effacement du dossier PS-checkout sur les conseills indiqués plus haut par Eolia, je peux de nouveau accéder à "modules et services" dans le BO prestashop 1.6.1.0.

J'ai alors tenté d'installer ce module PS_Checkout comme il est largement conseillé de le faire; j'ai téléchargé le .zip du module, puis je charge le module via le BO et là, encore une fatal error:

[PrestaShop] Fatal error in module file :/home/cosmetiqzt/www/modules/ps_checkout/ps_checkout.php:
Arrays are not allowed in class constants

En cherchant un peu, j'ai peur que ça soit ma version de PHP sur mon serveur ovh qui soit incompatible avec ce module PS_Checkout.

Je ne vois rien dans les caractéristiques du module PS_Checkout indiquant sa compatibilité ou non avec PHP5.5

Deux questions:

-Comment savoir si PS_Checkout est compatible avec PHP5.5 sous presta 1.6.1.0?

-Une idée de comment installer ce module sans avoir le message d'erreur SVP?

merci d'avance pour vos conseils

Share this post


Link to post
Share on other sites

Il est compatible a partir de PHP 5.6, il faut leur dire de le mentionner dans les caractéristiques du module ! C’est important 

Share this post


Link to post
Share on other sites

 

1 hour ago, Janett said:

Il est compatible a partir de PHP 5.6, il faut leur dire de le mentionner dans les caractéristiques du module ! C’est important 

Merci Janett pour l'info!!

J'ai contacté hier le support PS via la page de présentation du module pour mes deux questions plus haut en indiquant bien le plantage systématique du BO dès le chargement du module PS_Checkout.

réponse de l'équipe PS: 

Pour toute demande concernant le module PrestaShop Checkout, nous vous invitons à contacter l'équipe concernée directement depuis la configuration du module, onglet "Aide" puis en cliquant sur "Nous contacter".

Bon bah c'est pas gagné..

Et j'imagine que passer de 5.5 à 5.6 chez mon hébergeur sans maîtrise technique du sujet ni vérifications préalables représente un risque sur la stabilité de mon e-commerce...

Share this post


Link to post
Share on other sites

Non, PS  1.6 est totalement compatible PHP5.6, au contraire c'est même conseillé ;)

 

Share this post


Link to post
Share on other sites

En voilà une bonne nouvelle! J'adore!! 

Donc pour résoudre le PB, sujet de ce topic, dans mon cas il faudrait (avec de très fortes proba de réussite) passer mon hébergeur en PHP 5.6.

Pour cela, je pense: (je rappelle ici que je suis newbie, donc si je me trompe, excusez moi)

1-faire une sauvegarde du code du site (je me connecte à mon FTP et j'enregistre tout en local sur mon DDur)

2- faire une sauvegarde de la base de donnée (C'est forcément un des dossiers de mon site? donc en copiant le site je copie la BDD?)

3- me connecter à mon interface utilisateur chez mon hébergeur (OVH) et passer ce domaine sous PHP 5.6

4- vérifier (attendre) que le domaine est bien passé sous PHP5.6 (ça prend peut être un certain temps chez OVH de faire la manip')

5- Charger le module et confirmer que module PS_Checkout fonctionne

 

C'est tout bon?

Share this post


Link to post
Share on other sites

Non...

il y a 3 minutes, mobius.cosmetiques a dit :

1-faire une sauvegarde du code du site (je me connecte à mon FTP et j'enregistre tout en local sur mon DDur)

2- faire une sauvegarde de la base de donnée (C'est forcément un des dossiers de mon site? donc en copiant le site je copie la BDD?)

C’est inutile, la version PHP ne modifie ni l'un ni l'autre

 

il y a 1 minute, mobius.cosmetiques a dit :

me connecter à mon interface utilisateur chez mon hébergeur (OVH) et passer ce domaine sous PHP 5.6

Oui

 

il y a 2 minutes, mobius.cosmetiques a dit :

4- vérifier (attendre) que le domaine est bien passé sous PHP5.6 (ça prend peut être un certain temps chez OVH de faire la manip')

Non, c'est immédiat et non pas lié au domaine mais à l'hébergement (le serveur recharge Apache dès la modification enregistrée)

Share this post


Link to post
Share on other sites

Bonjour,

j'ai un problème similaire avec la version PS 1.7.6.0 que j'utilise, à savoir que lorsque je clique sur Module Manager, le gestionnaire de module m'indique: 

Administration

Vous n'avez pas de module dans « Administration ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Administration.

Design & Navigation,

Vous n'avez pas de module dans « Design & Navigation ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Design & Navigation.

Promotions & Marketing

Vous n'avez pas de module dans « Promotions & Marketing ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Promotions & Marketing.

Fiche produit

Vous n'avez pas de module dans « Product Page ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Product Page.

Paiement

Vous n'avez pas de module dans « Payment ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Payment.

Livraison & Logistique

Vous n'avez pas de module dans « Shipping & Logistics ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Shipping & Logistics.

Trafic & Marketplaces

Vous n'avez pas de module dans « Traffic & Marketplaces ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Traffic & Marketplaces.

Clients

Vous n'avez pas de module dans « Customers ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Customers.

Facebook & Réseaux Sociaux

Vous n'avez pas de module dans « Facebook & Social Networks ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Facebook & Social Networks.

Bizarrement le Menu autre et module du thème comportent des modules.

Est-ce que la manipulation reprise dans ce topic Supprimer le sous-répertoire /modules/ps_checkout peut résoudre mon problème ?

D'avance merci pour vos conseils.

Share this post


Link to post
Share on other sites

Bonjour à tous,

merci pour tous vos bons conseils!

J'ai MàJ l’hébergeur en PHP 5.6 et j'ai pu intégrer le module PS_checkout.

Merci encore à tous pour vos dispos et réactivités!

😘

 

Share this post


Link to post
Share on other sites
On 4/21/2020 at 11:58 AM, TheRaph said:

Bonjour,

j'ai un problème similaire avec la version PS 1.7.6.0 que j'utilise, à savoir que lorsque je clique sur Module Manager, le gestionnaire de module m'indique: 

Administration

Vous n'avez pas de module dans « Administration ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Administration.

Design & Navigation,

Vous n'avez pas de module dans « Design & Navigation ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Design & Navigation.

Promotions & Marketing

Vous n'avez pas de module dans « Promotions & Marketing ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Promotions & Marketing.

Fiche produit

Vous n'avez pas de module dans « Product Page ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Product Page.

Paiement

Vous n'avez pas de module dans « Payment ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Payment.

Livraison & Logistique

Vous n'avez pas de module dans « Shipping & Logistics ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Shipping & Logistics.

Trafic & Marketplaces

Vous n'avez pas de module dans « Traffic & Marketplaces ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Traffic & Marketplaces.

Clients

Vous n'avez pas de module dans « Customers ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Customers.

Facebook & Réseaux Sociaux

Vous n'avez pas de module dans « Facebook & Social Networks ».
Découvrir les meilleurs ventes de modules de cette catégorie sur la page Facebook & Social Networks.

Bizarrement le Menu autre et module du thème comportent des modules.

Est-ce que la manipulation reprise dans ce topic Supprimer le sous-répertoire /modules/ps_checkout peut résoudre mon problème ?

D'avance merci pour vos conseils.

Non ça c’est lié à l’api addons utilisée pour récupérer la catégorie liée à chaque module qui est dans les choux https://github.com/PrestaShop/PrestaShop/issues/15298

Appremment ils ont corrigé ça dans la prochaine version

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More