Jump to content
Wibleo

Modifier Le Tpl Du Homefeatured Suite Maj 1.6.1.4

Recommended Posts

Bonjour à tous !

 

Suite à la mise à jour de 1.6.1.3 vers 1.6.1.4, je rencontre un petit soucis, j'ai un petit TTC qui apparaît au dessus du prix qui a déjà la mention TTC sur la même ligne.

 

Sur mon product-list.tpl j'ai désactivé cette ligne et conservé uniquement le badge "EN SOLDE", grace aux accolades {**} (si ça intéresse du monde) :

<div itemprop="offers" itemscope itemtype="http://schema.org/Offer" class="content_price-sale">

					<!-- Partage sur fiche produit = Manu Désactivation 29 Février 2016 -->

                            {*{if isset($product.show_price) && $product.show_price && !isset($restricted_country_mode)}

                                <span itemprop="price" class="price product-price{if isset($product.specific_prices) && $product.specific_prices && isset($product.specific_prices.reduction) && $product.specific_prices.reduction > 0} product-price-new{/if}">

                                    {if !$priceDisplay}{convertPrice price=$product.price}{else}{convertPrice price=$product.price_tax_exc}{/if}

                                </span>

                                <meta itemprop="priceCurrency" content="{$currency->iso_code}" />

                                {if isset($product.specific_prices) && $product.specific_prices && isset($product.specific_prices.reduction) && $product.specific_prices.reduction > 0}

                                	{hook h="displayProductPriceBlock" product=$product type="old_price"}

                                    <span class="old-price product-price">

                                        {displayWtPrice p=$product.price_without_reduction}

                                    </span>*}

                                    {if isset($product.on_sale) && $product.on_sale && isset($product.show_price) && $product.show_price && !$PS_CATALOG_MODE}

                                        <a class="sale-price" href="{$product.link|escape:'html':'UTF-8'}">

                                            <span class="sale-label-price">{l s='Sale!'}</span>

                                        </a>

                                    {/if}

                                    {*{hook h="displayProductPriceBlock" id_product=$product.id_product type="old_price"}

                                    {if $product.specific_prices.reduction_type == 'percentage'}

                                        <span class="price-percent-reduction">-{$product.specific_prices.reduction * 100}%</span>

                                    {/if}

                                {/if}

                                {hook h="displayProductPriceBlock" product=$product type="price"}

								{hook h="displayProductPriceBlock" product=$product type="unit_price"}

                            {/if}*}
					<!-- /////////////////////////////////////////////////////////////// -->

                        </div>

Je souhaiterais reproduire la même méthode pour ma page d'accueil, mais dans le fichier homefeatured.tpl, je n'ai pas beaucoup de code et pas du tout la balise que je recherche class"aeuc_tax_label". J'ai bien un fichier product-list.tpl également, mais j'ai eu beau désactivé des portion de code et même le supprimé entièrement, ça n'a rien changé en front (j'ai bien entendu vidé les caches presta et navigateur)

 

Est-ce que quelqu'un aurait une idée de l'endroit où je devrait modifier cette portion de code ?

 

Merci d'avance à tous :)

Edited by Wibleo (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Vous devez vider le cache de la boutique le module HomeFeatured utilise product-list.tpl

 

3pom

Share this post


Link to post
Share on other sites

Bonjour,

 

Vous devez vider le cache de la boutique le module HomeFeatured utilise product-list.tpl

 

3pom

Bonjour,

 

Merci pour votre réponse.

 

Je l'ai fait, depuis Performance et depuis notre module pagecache, plus bien entendu sur mon navigateur. Sur les pages catégories j'ai réussi avec le code posté plus haut à arriver sur le résultat escompté. Mais sur la home page, même sur le product-list du module homefeatured, qui était déjà en override, aucun changement, même en supprimant cet override, rien du tout, il ne bouge pas...

Share this post


Link to post
Share on other sites

Oups désolé, j'ai vraiment pas l'habitude de la 1.6.1.4 je suis encore sur ma 1.6.0.9

 

Dans le module advancedeucompliance décocher : Taxes incluses / exclues

 

Ca doit venir de là.

 

3pom 

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Merci beaucoup pour votre aide, en fait nous souhaitons conserver le TTC après nos prix. Sur la page d'accueil, il est placé deux fois, une fois après le prix et une fois au dessus. Ca doit venir de notre thème qui n'est pas pleinement compatible avec le module advancedeucompliance, je l'avais oublié celui-ci, je l'avais vu sur un site de test que nous avions.

 

Votre post m'a permis en revanche de désactivé cette fonction le temps de trouver une réponse :P) Merci beaucoup.

 

Nous sommes toujours à la recherche d'une solution pour enlever ce TTC supplémentaire, je pense qu'il vient de l'emplacement du TTC sur le survol de la souris, dans le thème bootstrap. Mais comme nous n'avons pas le même fonctionnement sur le notre...

Share this post


Link to post
Share on other sites

Merci beaucoup pour votre aide, en fait nous souhaitons conserver le TTC après nos prix. Sur la page d'accueil, il est placé deux fois, une fois après le prix et une fois au dessus. Ca doit venir de notre thème qui n'est pas pleinement compatible avec le module advancedeucompliance, je l'avais oublié celui-ci, je l'avais vu sur un site de test que nous avions.

 

Votre post m'a permis en revanche de désactivé cette fonction le temps de trouver une réponse :P) Merci beaucoup.

 

Nous sommes toujours à la recherche d'une solution pour enlever ce TTC supplémentaire, je pense qu'il vient de l'emplacement du TTC sur le survol de la souris, dans le thème bootstrap. Mais comme nous n'avons pas le même fonctionnement sur le notre...

 

Bonjour,

 

Finalement pour mon souci, c'était le module blocknewsproducts qu'il fallait modifier, je ne sais pas si c'est normal ou si c'est les dev du thème qui avaient les yeux sur les côté en le codant.

 

Bref c'est donc résolu :)

 

Bonne fin de journée !

Edited by Wibleo (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More