Jump to content
  • 0
booklovers

Problem In Indexing / Rebuilding Search

Question

I an using 1.6.0.14 and have 5000 products. I am unable to Index product to search / Rebuild search index. When I try to Rebuild search even using corn I am able to index 300-600 product and get 500 error.

 

Than I go back try again to add missing products to search index, sometimes it works and sometime not. After sometimes get 503 internal server error.

 

Can any advise what is the problem how to rectify it.

 

Is there any way to rebuild index without problem as I have to add more than 20000 products.

 

OR if we can search in frontend without indexing the products somehow by making some changes in search file.

 

Kindly help

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I'm on 6.0.14 too and I have fixed the problem by replacing the search.php file with another one provided by the kind souls here. You may read this thread for more info:
https://www.prestashop.com/forums/topic/421756-blank-screen-when-adding-missing-products-to-index/

 

That thread attachment has expired so here I upload it again for anyone with the same problem.

Search.php

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More