Jump to content

Modul "Europäische Rechtssicherheit"


Recommended Posts

Ich bin ganz neu dabei und gerade dabei mich einzulesen, deswegen verzeiht mir bitte meine Frage.
Aber wo genau finde ich das Modul: "europäische Rechtssicherheit", in meiner Modulübersicht ist es nicht und auch wenn ich Online in den Modulen suche ist es nicht zu finden.

 

Danke schonmal
LG
Zydie

Share this post


Link to post
Share on other sites

Hallo,

 

das Modul ist wirklich super und nimmt viel Arbeit ab.

 

Hier nur zwei kleine Anmerkungen:

- bei den Artikeln wird der Text eingeblendet "ohne Versandkosten". Das klingt - zumindest für mich - etwas irreführend. Wäre nicht "zzgl. Versandkosten" besser?

- wenn man z. B. auf diesen Versandkostenlink klickt, wird die hinterlegte Seite alleine, also ohne Frame dargestellt. Damit ist die ganze Darstellung der Website weg; wäre es nicht besser, den Link genauso aufrufbar zu machen, als wenn ich z. B. aus dem Footer heraus auf die Seite verlinke?

 

Vielen Dank für die gute Arbeit mit dem Modul.

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

ok, sorry, hätte ich auch selber auf die Übersetzung kommen können.  :wacko:

 

Aber zum zweiten Punkt (öffnen der verlinkten Seite im Vollbild) hat meine Suche im Forum nur ergeben, dass das auch schon jemand anders aufgefallen ist.

Eine Lösung habe ich nicht gefunden.

Vielleicht gibt's ja dazu doch noch 'ne Info?!

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

Na ja, in diesem Fall wäre wirklich ein Blick ins Handbuch (verlinkt in den Benutzerleitfäden des deutschen Forums) angesagt. ;)

Du hast vermutlich schlicht übersehen, in den Voreinstellungen iframes zuzulassen.

Share this post


Link to post
Share on other sites

Hallo eleazar,

 

danke für den Tipp. Iframes sind zugelassen. Habe die Option gerade deaktiviert und wieder aktiviert; kein Erfolg.

 

Für einen Nicht-Experten wie mich, ist es ein bißchen schwierig in Handbüchern etwas zu finden, wenn ich nicht genau weiß, wonach ich suchen soll.  :)

Danke für eure Geduld. 

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

Hallo eleazar,

 

das wars, danke !!!! Hatte ich zwar nach dem Aktivieren der iframes schon gemacht, aber jetzt nach dem zweiten Mal neu kompilieren geht's!!!

 

DANKE

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

doch noch eine kleine Ergänzung.

 

Die Anzeige der eingebetten Seite (z. B. Versandkosten oder AGB) funktioniert nach dem Neukompilieren in allen gängigen Browsern vom PC aus einwandfrei, allerdings nur in der Produktübersicht bzw. in dem kleinen Vorschaufenster.

Direkt auf der Produktseite funktioniert es auch nicht, da wird die Seite wieder direkt im Browser geöffnet.

 

Hab's wirklich ausführlich mit verschiedenen Geräten Browsern probiert; Templates sind frisch neu kompiliert.

Kann das jemand reproduzieren?

 

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

doch noch eine kleine Ergänzung.

 

Die Anzeige der eingebetten Seite (z. B. Versandkosten oder AGB) funktioniert nach dem Neukompilieren in allen gängigen Browsern vom PC aus einwandfrei, allerdings nur in der Produktübersicht bzw. in dem kleinen Vorschaufenster.

Direkt auf der Produktseite funktioniert es auch nicht, da wird die Seite wieder direkt im Browser geöffnet.

 

Hab's wirklich ausführlich mit verschiedenen Geräten Browsern probiert; Templates sind frisch neu kompiliert.

Kann das jemand reproduzieren?

 

Viele Grüße

Andreas

 

Nein,

in beiden Fällen wird bei den Versandkosten-Links, die direkt am Preis stehen  eine "Fancy-Box" über iframes aufgerufen.

 

Die Links aus dem Footer rufen eine Seite auf.

 

Hast du einen Link zu deiner Seite.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Whiley,

 

ok, danke für die schnelle Rückmeldung.

Ist irgendwie seltsam, dass die Fancy-Box bei mir von der Produktseite aus nicht kommt....

Mal sehen, ob ich die Ursache noch finde.

 

Meine Seite: www.woodys.cc

 

Viele Grüße

Andreas

 

PS: das mit den Links aus dem Footer ist mir klar, das war wahrscheinlich eine missverständliche Erklärung von mir.

Edited by woodys (see edit history)

Share this post


Link to post
Share on other sites

Scheint wirklich seltsam auf deiner Seite zu sein. Hast du mal AdvancedEUCompliance aktualisiert auf die Version 2.01?

 

Falls das Problem danach (und anschließendem Löschen von Cache und Browser-Cache) immer noch auftritt, dann lad doch mal den Inhalt der folgenden Zip-Datei hoch nach

/modules/advancedeucompliance/views/templates/hook

hookDisplayProductPriceBlock.zip

 

Damit wird die gleichnamige Hook-Datei, die auch für die Anzeige der Lieferzeit zuständig ist überschrieben. Sie enthält ein zusätzliches Skript zum Aufruf der Fancybox (wie in AEUC 1.5).

  • Like 1

Share this post


Link to post
Share on other sites

Hallo eleazar,

 

Modul war schon in V2.01 installiert.

Nach dem Upload deiner hook-Datei funktioniert nun alles. Getestet auf drei Betriebssystemen mit 3 Browsern und drei Plattformen (PC, Tablet, Smartphone).

 

DANKE!  :D

 

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

so, hier noch 'ne Kleinigkeit....  :wacko:

 

Wenn ich mehrere Artikel zum Vergleichen auswähle, dann:

- ist nicht reproduzierbar manchmal noch der Button "In den Warenkorb " in der Vorschau sichtbar

- kommt die "fancy box" wieder nicht bei den Versandkosten

 

Zu sehen z.B. hier:

http://www.woodys.cc/index.php?controller=products-comparison&compare_product_list=113%7C114%7C123

 

Mach ich noch was falsch?

 

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Das liegt daran dass der 3. Artikel der nicht den "In den Warenkorb" Button hat ein Artikel mit verschiedenen Varianten ist. So muss der Käufer erstmal die Variante wählen. Wenn du möchtest dass Artikel mit Varianten auch aus Übersichtsseiten, ohne vorher die Variante zu wählen, in den Warenkorb gelegt werden können musst du den entsprechenden Schalter auf "Ja" stellen. Das kann man aber in den Einstellungen unter "Voreinstellungen -> Artikel" -> Button "In den Korb" in Listenansicht immer anzeigen. tun.

Share this post


Link to post
Share on other sites

Hallo schibulski,

 

danke für die Erklärung. Was muss ich tun, wenn ich in der Listenansicht NIE möchte, dass der Knopf "in den Warenkorb legen" kommt; das soll gar nicht mehr angezeigt werden...

 

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites

Dann musst du auf jeden Fall die product-list.tpl modifizieren. Wenn du den kompletten Block mit BEIDEN Buttons deaktivieren möchtest, dann muss der ganze <div> Block von Zeile 153 - 169 auskommentiert oder gelöscht werden. Wenn du den "Mehr" Button erhalten möchtest, dann musst du nur die {if} Geschichte von Zeile 154 - 169 auskommentieren oder löschen.

 

Am besten Sicherungen der Originaldateien machen. Danach Cache leeren und unter Leistung "Kompilieren erzwingen" auswählen damit die Ergebnisse sichtbar werden.

Share this post


Link to post
Share on other sites

Also das Problem, mit dem Finden von "advancedeucompliance" habe ich auch. Ich habe den Shop vor ca. 6 Stunden installiert und die Modul Seite immer wieder aktualisiert und neu gesucht, aber es taucht einfach nicht auf. (ach ja andere Module wie zum Beispiel Paypal finde ich auch nicht).

 

Irgendwie wirkt es so als könne er keine Module online finden.

 

Muss ich irgendwo noch was einstellen?

Edited by Laire (see edit history)

Share this post


Link to post
Share on other sites

nein, die Schlafen alle noch :)

möglicherweise verhindert eine zusätzliche Firewall, der Router oder sonst irgendein Kram den "refresh" zu Prestashop

 

oder einfach noch warten

Share this post


Link to post
Share on other sites

Dann musst du auf jeden Fall die product-list.tpl modifizieren. Wenn du den kompletten Block mit BEIDEN Buttons deaktivieren möchtest, dann muss der ganze <div> Block von Zeile 153 - 169 auskommentiert oder gelöscht werden. Wenn du den "Mehr" Button erhalten möchtest, dann musst du nur die {if} Geschichte von Zeile 154 - 169 auskommentieren oder löschen.

 

Am besten Sicherungen der Originaldateien machen. Danach Cache leeren und unter Leistung "Kompilieren erzwingen" auswählen damit die Ergebnisse sichtbar werden.

Hallo schibulski,

 

danke für den Tipp. Werde ich ausprobieren.

Viele Grüße

Andreas

Share this post


Link to post
Share on other sites
  • 2 weeks later...
Hallo,

ich habe mal unter Lieferzeiten für "Lieferzeit (nicht vorrätig)" das Feld leer gelassen. Der Text erscheint auf der Seite nicht, dafür aber das Kästchen dafür immer noch (div class box-info-product). Kann jemand mir sagen, wie ich das weg kriege? Ab besten ohne CSS oder sonst irgendwelche Code zu bearbeiten. Die Seite ist im Katalog Modus. Wenn sie sich im Katalog Modus befindet, hat das erste Feld, "Lieferzeit (auf Lager)" keinen Einfluss, es wird nichts angezeigt. Wenn das Produkt auf 0 ist, erscheint jedoch noch das Kästchen. Es ist mir ein Rätsel wieso. Über Hilfe diesbezüglich wäre ich sehr dankbar.

 

Vielen Dank!

Share this post


Link to post
Share on other sites
  • 3 months later...

Hallo,

 

ich finde in meinem backoffice dieses Modul nicht (1.5.4.1) - kann mir jemand helfen (abgesehen davon, dass es mich mehr als anko....was hier in Deutschland abgeht. Man bräuchte einen hauseigenen Anwalt, der den ganzen Tag nur irgendwelche Änderungen vornimmt, damit auch ja kein Kundlein nachzudenken braucht. Sorry, aber is' doch wahr. Macht keinen Spaß mehr.)?

 

Dankeschön!

Share this post


Link to post
Share on other sites

Das Modul arbeitet mit Prestashop-Versionen >1.6.0.14.

Funktion in PS 1.5 xxx ist definitiv ausgeschlossen.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

aha, dachte ich mir fast. Nun muss ich wohl upgraden (kann ich das überhaupt so einfach?), obwohl mir davor graut, hab so schon so wenig Zeit für meine eigentliche Arbeit.... Danke, Wiley!

Share this post


Link to post
Share on other sites

hab grad nochmal kurz die Anleitung zum Upgrade gelesen und gesehen, dass das für mich nicht machbar ist. Außerdem kann ich nicht riskieren, dass der Shop für längere Zeit ausfällt, weil ich mit dem prozedere nciht klar komme, also muss es auch so gehen. Gibt es irgendwo eine Anleitung, wie ich den Shop ohne Module rechtssicher machen kann? (Bin zwar bei Janolaw, aber die tun ja auch nichts, trotz monatlicher Gebühren).

Share this post


Link to post
Share on other sites

Hallo,

 

ich habe das Problem, dass die Fancybox für die Versandkostenanzeige auf meiner Startseite nicht funktioniert.

 

Die Versandkosten-CMS-Seite wir in einem leeren Browserfenster geöffnet ("content-only=1"). Das Problem hatte ich auch auf der Produktseite, konnte es aber mit dem hier angeboteten hookDisplayProductPriceBlock.tpl lösen. Gibt es einen vergleichbaren Fix auch für die Startseite?

 

Danke im Voraus!

Share this post


Link to post
Share on other sites
  • 4 weeks later...

ich denke mal das hat nichts mit dem AEUC-Modul zu tun.

 

Was hast du den eingestellt im

Backoffice -->Bestellungen -->Status "Email an Kunden senden"

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites
  • 2 months later...

Hallo zusammen!

Mein Thema ist die Anzeige "zzgl. Lieferkosten" beim Artikelpreis, die über das Modul EURS gesteuert wird.

Ich habe sowohl Produkte für die Lieferkosten anfallen, als auch Produkte, bei denen keine Lieferkosten anfallen. Wenn ich die Lieferkostenanzeige im Modul aktiviere wird bei jedem Produkt "zzgl. Lieferkosten" angezeigt. 

Wie kann ich das je nach Produkt steuern bzw. an- und ausschalten. Über die Zuordnung eines kostenfreien Versands habe ich schon vergeblich versucht... Hat jemand einen Hinweis für mich?

Bei Produkten ohne zusätzliche Lieferkosten könnte auch stehen inkl. Lieferkosten.

 

Freue mich, wenn mir jemand weiter helfen kann!

 

Gruß,

Alex

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More