Jump to content

Duplica prodotto non funziona correttamente.... Aiuto ! :-)


Mirka
 Share

Recommended Posts

Ho duplicato due volte un prodotto.
Tutte e due le volte il back Office di PrestaShop mi ha comunicato che era avvenuto un errore nella duplicazione del prodotto.
A questo punto andando nel Front Office mi ritrovo con due prodotti duplicati senza foto. La cosa grave è che questi prodotti non mi compaiono nel back office e non posso quindi modificarli o eliminarli.
Qualche soluzione?
Grazie, Mirka.

Share this post


Link to post
Share on other sites

Ho accesso completo al database via interfaccia web, ma purtroppo non ho un editor sql... consigli su quale scegliere? (magari freeware?)

Quando ho duplicato e mi ha chiesto "Copiare Immagine?" ho premuto annulla..... ma il risultato è quello sopramenzionato nel mio precedente post... :-(

Grazie anticipatamente per i vostri consigli !
A presto, Mirka.

RISOLTO !

Ho scaricato DreamCoder for Mysql (freeware) e ho corretto il database. ora è tutto ok ! grazie per l'aiuto !
;-)

Share this post


Link to post
Share on other sites

Già che ci sei controlla in tutte le tabelle doce c'è un id_product se il prodotto è realmente esistente: mi spiego meglio ...

Prestashop quando elimini un prodotto lo setta eliminato e se ne frega di tutte le relazioni esistenti lasciando traccia del prodotto in tutto il db. Questo di sicuro a lungo andare rallenta di molto le query.

Appena trovo il tempo ho intenzione di scrivere un php "spazzino" che ripulisca le tabelle con riferimenti a prodotti inesistenti ...

Share this post


Link to post
Share on other sites

Se riesci a scrivere un php spazzino fammi sapere.... io purtroppo non mastico bene il php e sto muovendo i miei primi passi con i database mysql... ti sarei infinitamente grata se riuscissi a creare lo spazzino del database..... :-)

  • Like 1

Share this post


Link to post
Share on other sites

  • 6 years later...

Salve a tutti,

anch'io ho lo stesso problema.

Purtroppo non sono riuscito a capire come avete fatto. Cosa correggere e come corregere.

 

Succede che:

quando faccio "Duplica" oggetto, mi comprare un errore di creazione.

Quindi quando clicco sull'icona delle due finestrelle sovrapposte, ho il messaggio:

<<Si è verificato un errore durante la creazione dell'oggetto.>> (evidenziato in rosso).

Sia nel caso gli dico di copiare le immagini che senza !

 

Percorso: 

Catalogo > Prodotti >

edit.gif duplicate.png delete.gif

________________________

Copiare anche le immaagini?

OK  | Annulla

________________________

 

 

Però, ho notato che l'oggetto me lo duplica correttamente.

Ovviamente poi io entro dentro la scheda dell'oggetto per fare le dovute modifiche (modificare titolo, prezzo, ecc), e poi salvo.

A oggetto salvato, ho verificato che viene pubblicato correttamente.

 

Ma non vorrei che poi al momento dell'acquisto, ci siano dei problemi in Front Office, e il cliente non riesca a concludere la transazione.

Oltre che leggere e vedere questa scritta rossa di allerta, mette sempre preoccupazione.

La mia versione di Prestashop è 1.5.4.1

 

****

A cosa è dovuto questo errore? Come posso rimediare?

E' dovuto a qualche file mancante e che quindi devo trasferire tramite FTP?

In questo caso quale sono i file e in quale cartella devono essere trasferiti?

 

è dovuto al database? a qualche modulo installato?

 

 

Spero che qualcuno mi possa aiutare.

grazie mille a tutti.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More