Jump to content
repairmedia-shop

Modul Hinzufügen

Recommended Posts

Hallo Leute, ich bin grad am Verzweifeln :(

 

In allen Tutorials die ich mir ansehe, wird dargestellt wie einfach man einen Modul hinzufügen kann.

Moduls -> Modul hinzufügen -> die heruntergeladene (Zip) Datei auswählen.

 

Doch mein Problem ist:

 

Wenn ich auf Moduls -> Modul hinzufügen gehe , kann ich NUR im Marktplatz nach Modulen suchen. Das heißt: Ich kann keine lokal heruntergeladene Module hinzufügen.

 

Dann habe ich eben die heruntergeladene Datei in mein FTP Server hochgeladen und zwar unter : html / moduls

 

Jedoch rührt sich nichts. Ich kann das gewünschte Modul niergendswo finden :((

 

Bitte hilft mir mal. Zur Info: Meine Version ist die 1.6.0.14

 

 

Danke schonmal 

post-1017614-0-63923200-1455833380_thumb.png

Share this post


Link to post
Share on other sites

Hallo das finde ich ja toll das so schnell jemand antwortet.

Nein der Shop wurde heruntergeladen und läuft über FTP Server und nicht über cloud.

Share this post


Link to post
Share on other sites

Vielleicht läuft dein Shop dann sogar unter einen http-Server <_<

 

Du entpackst die zip-Moduldatei als erstes.

Bein Entpacken enteht ein Ordner der so wie dein Modul heißt.

Diesen Ordner schiebst du via FTP auf deinen Server in den Ordner /modules  (nicht /moduls)

 

Dann gibst du diesem Ordner und den enthaltenen Dateien noch erweiterte Rechte (777).

 

Als nächstes gehst du in den Ordner /cache und löscht dort die Datei class_index.php  (die wird von allein neu angelegt)

 

Dann wechselst du ins Backoffice, dort müßte dein neues Modul dann in der Modul-Liste angezeigt werden.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hey nochmal danke für deine Mühe finde ich wirklich toll das es noch so hilfsbereite Menschen gibt :)

 

Also ich habe das Modul "Autoupgrade" heruntergeladen. Unter Downloads sehe ich die Zip Datei.

Diese Zip Datei habe ich per Rechte Maus Taste 7zip -> Entpacken nach "Autoupgrade..." entzipt.

 

Nun habe ich den ganzen Ordner "Autoupgrade" direkt in meinem FTP Server unter

 

/html/modules/Autoupgrade

 

reingezogen.

 

Daraufhin habe ich den Ordner "Autoupgrade" im FTP Server per Rechte Maustaste --> Dateiattribute die Rechte 777 vergeben.

 

Anschließend habe ich die Datei class_index.php der unter  /html/cache.. war gelöscht.

 

Nach Beeneden und erneut öffnen und vielen Versuchen sehe ich dieses Modul immer noch nicht in der Modul-Liste

 

Bin wirklich am Verzweifeln :(

 

In youtube Tutorials etc. sieht alles so einfach aus, die gehen einfach unter Moduls -> Modul hinzufügen -> und können es hochladen. Jedoch habe ich nicht die Möglichkeit irgendetwas lokal auszuwählen.

Und über den FTP ...  /modules manuell hinzufügen klappt auch nicht. :((

 

Was kann ich denn noch tun?

 

 

Liebe Grüße und guten Umsatz allen die das lesen :)

post-1017614-0-29767300-1455914076_thumb.png

post-1017614-0-19274600-1455914077_thumb.png

Share this post


Link to post
Share on other sites

Hast du im Modul-Suchfeld schon "1-click " eingegeben?

 

Generell müßte das Modul-Hinzufügen eigentlich auch so funktionieren, wie du es gelesen hast. Also muß wohl bei der Shop-Installation einiges schiefgegangen sein.

Wäre es nicht am einfachsten den Shop in der neuesten Version neu aufzubauen, zumal du den Shop ja so wie er im Moment aussieht wohl kaum rechtssicher betreiben könntest (keine Bestellzusammenfassung, keine Angaben zu den Versandkosten, keine Angaben zu den Lieferzeiten etc)

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Ja im suchfeld habe ich 1-click schon eingegeben auch autoupgrafe eingegeben leider sieht man nichts :/

Okay und wie genau installiere ich erneut die neuste Version?

Ich bin ein ziemlicher amateuer :(

Und allgemein die Installation von diesem shop habe ich per Zufall hingekriegt damals

 

Die Artikel gehen aber nicht verloren oder? Wenn ich den shop neu installiere

 

Lg

Share this post


Link to post
Share on other sites

Bei einer Neu-Installation kannst du ganz intuitiv vorgehen oder dich an die Handbücher u. Installationsanleitungen halten:

http://doc.prestashop.com/pages/viewpage.action?pageId=27459596

Zuerst auf jeden Fall mal prüfen ob dein Web-Space die PS-Anforderungen erfüllt.

 

Allerdings werden dann in der Tat alle deine bisherigen Daten (auch die Artikel) überschrieben!

 

Wenn du das verhindern willst wird es komplizierter, Du mußt aus Sicherheitsgründen erstmal ein Gesamt-Backup anlegen (auch Datenbank), dann deine Artikel als csv exportieren (im Forum beschrieben), deine Bilddaten sichern , Shop neu installieren und Bilddaten und Artikel wieder einlesen (ebenfalls schon häufiger beschrieben)

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More