Jump to content
Eva Martin

Another Fatal Error: Uncaught --> Smarty Compiler: Syntax Error In Template

Recommended Posts

I've got a problem strangely similar to that very recent topic https://www.prestashop.com/forums/topic/436440-fatal-error-uncaught-smarty-compiler-syntax-error-in-template-v1609/

but it's not exactly the same, and I'm quite noob with this ...

hope you can help cause my website just got completely down ...

 

I was doing nothing special, and all the sudden the whole site goes to 500 error pages.

the complete error is :

Fatal error: Uncaught --> Smarty Compiler: Syntax error in template "/var/www/themes/gift/header.tpl" on line 92 "{plugin module='blocklanguages' hook='displayNav'}" unknown tag "plugin" <-- thrown in /var/www/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 92

in the header.tpl, the 92 line is :

{plugin module='blocklanguages' hook='displayNav'}

it is included in a larger text that is :

<!-- Secondary menu mobile -->
<div class="navbar-secondary-menu pull-right compact-hidden visible-xs">
{assign var='blocklanguages_style' value="mobile" scope="global"}
{plugin module='blocklanguages' hook='displayNav'}
{assign var='blocklanguages_style' value="default" scope="global"}
{assign var='blockcurrencies_style' value="mobile" scope="global"}
{plugin module='blockcurrencies' hook='displayNav'}
{assign var='blockcurrencies_style' value="default" scope="global"}
</div>

I can't find where the problem is, I tried to replace the header.tpl with the one provided in my original download, erased cache oin BO and in my browser, tested it on another PC, nothing changes, 500 pages everywhere ! 

Pease help, it's very urgent !! Thank you guys

Share this post


Link to post
Share on other sites

Hello ! 

while panicking a little because all the website was gone, I wrote also to my theme's developper, and he said to set :  "Advanced Parameters - Performance - Disable all overrides, set to No." ... and ... it worked !

That remains a mystery, cause this option had been activated all along and the bug appeard only today, but anyway I'll mark this topic as solved, hopind the solution may help somebody else ...

Thank you Tuk66 for helping :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More