Jump to content
qvm

Qvm Módulos - Frete Correios Carrier Para PS 1.6. - Grátis

Recommended Posts

QVM Módulos -  Frete Correios Carrier para Prestashop - GRÁTIS

O módulo oferece recursos básicos para os donos de loja Prestashop que desejam um módulo desta categoria, e sem pagar nada por isso, ou seja gratuitamente.
 

Caso necessite de ajuda, dúvida ou oferecer sugestão, poderá postar aqui mesmo no fórum.

 

Requisito: SOAP habilitado no servidor PHP 

Bugs corrigidos:

 

1 - Corrigido o erro quando se tentava transferir licença.

2 - Corrigido o erro de "transportadora inexistente" no cálculo do frete com os serviços dos Correios.

3 - Corrigido o erro de "transportadora inexistente" no cálculo do frete com os serviços dos Correios com o CEP de destino dos estados de SP, GO, DF e AM.

4 - Erro com o valor declarado corrigido.

5 - Erro de incompatibilidade com PHP 5.2 corrigido.

6 - Módulo modificado para permitir o funcionamento em servidores que bloqueiam o acesso externo com  HTTPS(SSL)

7 - Corrido o erro que quando editava o módulo através na página "Transportadora".

8 - Atualização para o módulo funcionar com os novos códigos de tarifação(PAC e SEDEX) dos Correios.

Obs.: é necessário desinstalar o módulo antigo(caso exista) para instalar a nova versão.

 

 

Baixar o módulo:

MANUAL - INSTALAÇÃO DO MODULO(QVM Carrier Frete Correios_v_1.x.x.zip

qvmcarriercorreiosfree_v_1.9.x.zip

Edited by qvm

Share this post


Link to post
Share on other sites

De acordo com as regras do fórum vc. deve anexar o download diretamente ao seu tópico. Por favor retrabalhar o tópico o mais rápido possível para que este nao seja deletado.

 

Regras do fórum: https://www.prestashop.com/forums/topic/394104-regras-do-f%C3%B3rum-prestashop/

Edited by selectshop.at

Share this post


Link to post
Share on other sites

Antes de instalar ativei o modo debug. Tentei instalar em PS 1.6.0.14, infelizmente nao deu certo. Com qual versao o módulo foi testado ?

 

[PrestaShopDatabaseException]

Unknown column 'is_transfer_license' in 'field list'
 

SELECT is_transfer_license FROM `ps_qvm_correios_config` WHERE  id_shop=1 LIMIT 1

at line 646 in file classes/db/Db.php

641. 			WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);642. 		}643. 		elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))644. 		{645. 			if ($sql)646. 				throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');647. 			throw new PrestaShopDatabaseException($this->getMsgError());648. 		}649. 	}650. 651. 	/**

 

 

Também na versao PS 1.6.1. beta nao está funcionando e com o mesmo problema. Em abas versoes apesar dos erros apresentados o módulo se instala e é possivel configurar, no entanto nao mais é possível desinstalar deixando entao restos (inúteis) no banco de dados e back-office

 

PS, esqueci de mencionar que a minha loja de testes está configurada para multilojas.

Edited by selectshop.at

Share this post


Link to post
Share on other sites

Pessoal, já está disponível para download, a versão v.1.0.2 com a correção do erro apontado por selectshop.at.

Edited by qvm

Share this post


Link to post
Share on other sites

Bom. como tinha desinstalado a versao anterior (que acabou deixando remanescentes no banco de dados). Eu simplesmente deletei do FTP. Subindo a versao nova, o módulo reconheceu que já estava instalado uma vez, o que é correto.

 

Desinstalei entao o módulo antigo com a versao mais recente e deu certo. Instalei novamente e recebi duas mensagens:

 

- módulo instalado com successo

- Você não tem permissão para configurar este módulo e o mesmo nao foi instalado, apesar de "sucesso". Nao mais tenho acesso à configuracao do módulo (chmod é 0755). Provavelmente deletando também as tabelas no banco de dado é que dê certo. Por favor verifique se o módulo deleta mesmo tudo no banco de dados se já estava instalado uma vez em um versao inferior que no pode ser desinstalada.

Share this post


Link to post
Share on other sites

Sim, o módulo, desinstala todas as tabelas. Fiz todo o processo e não percebi as falhas citadas.

 

Situações possíveis: 

1 - Acesso à URL de configuração do módulo, sem que o mesmo esteja instalado.

 

2 - O arquivos config.xml é utilizado para identificar as informações do módulo mais rapidamente. É aconselhado que todos o processo de instalação, remoção ou configuração seja feito na própria plataforma.

 

Tente desinstalar e deletar o módulo(pela plataforma), e instale a nova versão novamente, por favor.
 

Edited by qvm

Share this post


Link to post
Share on other sites

Fizemos todo o processo novamente em dois ambientes(local e num domínio) e tudo ocorreu como deveria.

 

Se alguém está com o mesmo problema que o selectshop citou, poderia compartilhá-lo, informando a versão do PS utilizada, por gentileza.

 

Edited by qvm

Share this post


Link to post
Share on other sites

Finalmente consegui instalar. O módulo necessita de uma licenca ? Sei porque deu problemas com a outra versao. Vc. usa algum método de conexao ao módulo (sniff). Por ter instalado em minha outra máquina local com poderosa firewall pode ser que isto estava impedindo a desinstalacao completa do módulo da versao anterior...

 

Este módulo nao trabalha sem licenca ? Sem licenca nao tenho como configurar, certo ? Versao instalada do módulo: 1.0.0.3

Edited by selectshop.at

Share this post


Link to post
Share on other sites

A partir da versão v1.0.3 ,do módulo Frete Correios Carrier para Prestashop - FREE, há uma opção, na aba "Sobre", que possibilita o análise das ocorrências de erro ocorridas durante o cálculo do frete, inclusive, os retornos de erros oriundos do WebService dos Correios. 

Share this post


Link to post
Share on other sites

2) O módulo  entao nao funciona sem devida licenca a adquirir na sua página, correto ?

 

Exato. Neste caso, acredito que o post do módulo não  infringe nenhuma regra do Fórum, correto? 

Share this post


Link to post
Share on other sites

2) O módulo  entao nao funciona sem devida licenca a adquirir na sua página, correto ?

 

Exato. Neste caso, acredito que o post do módulo não  infringe nenhuma regra do Fórum, correto? 

Correto, existem muitos módulos gratuítos que necessitam de licensa para um webservice por ex. Até  para o paypal vc. necessita de licenca e esta ainda é paga, pois cobram pelos servicos web...

Edited by selectshop.at

Share this post


Link to post
Share on other sites

Nao, nao o seu.... Mas Paypal por ex. cobra pro transacao realisada. O módulo é grátis, necessita de licenca (API-key) e ainda cobra. Sendo que o seu módulo está totalmente de acordo com as regras. Grátis + licenca. Citei o Paypal somente como comparacao.

Share this post


Link to post
Share on other sites

Bug corrigido:

2 - Corrigido o erro de "transportadora inexistente" no cálculo do frete com os serviços dos Correios.

Share this post


Link to post
Share on other sites

Olá a todos, instalei o modulo porém os prazos de entrega não são visualizados. Utilizo o FK CORREIOS que também é grátis e sinceramente acredito que seja o melhor pois é mais simples configurar e funciona 100%. 

Share this post


Link to post
Share on other sites

Boa tarde, instalei este modulo baixado por aqui e consigo instalar normalmente e faço a configuração devidamente conforme informado no manual que o acompanha, porém não aparece nada, não aparece os serviços que selecionei que são PAC e SEDEX, fica sem tranportadora. Na administração, transportadoras aparece as duas opções e estão em verde, ativas, mas no front não aparece nada.

 

Alguém conseguiu instalar ? Alguém consegue utilizar este modulo ? Se sim, por favor se puderem me informem como fazer pois se o manual estiver correto realmente não há o que fazer.

 

Obrigado.

Share this post


Link to post
Share on other sites

Já estamos implementando a rotina para exibição de prazo de entrega e em breve estaremos disponibilizando aqui no fórum e sobre a configuração, acreditamos que o nosso módulo é bastante simples, pois agrupamos todas as funcionalidades num só lugar para cada aba.

Share this post


Link to post
Share on other sites

Acho que este modulo deveria ser testado antes de ser divulgado pois a principio não calcula o prazo de entrega o qual o correto seria calcular já que se propõe a ser um modulo de transporte, correios.

 

Agora fiz a instalação no 1.0.6.9 e não funciona nada, instalar normal mas não é visivel ao cliente, fora do frontoffice

Share this post


Link to post
Share on other sites

Configurações básica para que o módulo funcione:

 

1 - Baixar a versão mais recente do módulo; 

 

2 - Registrar o módulo(grátis);

 

3 - Informar o CEP de origem;

 

4 - Ativar os serviços dos Correios na aba "Serviços";

 

5 - Ativar a opção "Habilitar embalagem padrão" (recomendado);

 

6 - Configurar as embalagens para cada serviço(recomendado);

 

7 - O cliente deve está logado na loja para o módulo recuperar o CEP de destino cadastrado na loja.

 

Observação:
Se seguir estes passos, mas mesmo assim não exibir a transportadora, poderá está ocorrendo alguma inconsistência ao tentar calcular o frete, como:

a - Dimensões do produto ou da embalagem não permitidas pelos Correios,

b - Cep de destino incorreto

c - Serviço não disponível para os CEps envolvidos(Origem/Destino),

d - Erro de conexão com o Web Service dos Correios

e - Entre outros.

 

Todos este erros são registrados no arquivo de log, que poderá ser acessado na aba "Sobre" clicando em "Log de erro"

 

 

 

---

Edited by qvm

Share this post


Link to post
Share on other sites

Feira,

 

O módulo foi testado, e todos os bugs encontrados foram resolvidos. Por favor baixe a versão mais recente e siga os passos da postagem

anterior. Estamos aprimorando o módulo e uma das opções que iremos incluir no mesmo, será o prazo de entrega e em breve postaremos o aviso aqui mesmo no fórum. Queremos que tenham uma boa experiência com o módulo  e toda reclamação e sugestão são bem vindas.

Edited by qvm

Share this post


Link to post
Share on other sites

Fiz tudo isso, de forma categorica, porém nada aparece. 

Qual versão do módulo que está utilizando, não me refiro à plataforma, e sim, ao módulo instalado.

Share this post


Link to post
Share on other sites

Não funciona. E se clicar no link de erros também não aparece nada, abre uma pagina em branco.

 

Eu vou deixar vou usar o que tenho mesmo pois nunca tive problemas, é gratis e sempre calcular certinho e não da erro. 

 

Eu pensei que este a única vantagem que teria sobre o que uso é que eu poderia configurar o prazo de entrega da minha forma, sem precisar contar com o dos Correios que na maioria das vezes estão errados porque eles não entregam no prazo que informam.

 

Mas tudo bem, valeu, obrigado a todos.

Share this post


Link to post
Share on other sites

Gente este modulo é doido demais. Eu clique no link que informaram para ver o modulo funcionando e adivinha ? não tem nada para calcular o frete e ainda aparece a mensagem que não tem transportadora. Ora cadastrei o endereço de goias com cep verdadeira e não tem transportadora ? estranho né ? primeiro o modulo não funciona e quando postam um link de exemplo pior ainda.

 

manda um link de verdade pra gente ver funcionando, tem jeito ?

Share this post


Link to post
Share on other sites

Não funciona. E se clicar no link de erros também não aparece nada, abre uma pagina em branco.

 

Eu vou deixar vou usar o que tenho mesmo pois nunca tive problemas, é gratis e sempre calcular certinho e não da erro. 

 

Eu pensei que este a única vantagem que teria sobre o que uso é que eu poderia configurar o prazo de entrega da minha forma, sem precisar contar com o dos Correios que na maioria das vezes estão errados porque eles não entregam no prazo que informam.

 

Mas tudo bem, valeu, obrigado a todos.

Respeitamos a sua opinião. Conhecemos muitos módulos que não calculam corretamente o valor do frete. Já fizemos alguns testes, comparando o resultado do valor do frete destes módulos com o resultado no próprio site dos Correios e os valores não coincidem.

Edited by qvm

Share this post


Link to post
Share on other sites

Gente este modulo é doido demais. Eu clique no link que informaram para ver o modulo funcionando e adivinha ? não tem nada para calcular o frete e ainda aparece a mensagem que não tem transportadora. Ora cadastrei o endereço de goias com cep verdadeira e não tem transportadora ? estranho né ? primeiro o modulo não funciona e quando postam um link de exemplo pior ainda.

 

manda um link de verdade pra gente ver funcionando, tem jeito ?

Veja o print do módulo funcionando do link informado.

post-1019298-0-89421000-1433352857_thumb.jpg

Share this post


Link to post
Share on other sites

Amigo, porque você não instalar ele e posta o link aqui pra gente acessar e fazer o teste ? Aí pelo menos se pra gente não funciona mas pelo menos vemos que existe a possibilidade de funcionar e podemos até achar uma solução juntos e assim colaborar com o bem de todos.

 

Instala ele e teremos o maior prazer em testar.

Share this post


Link to post
Share on other sites

Gente este modulo é doido demais. Eu clique no link que informaram para ver o modulo funcionando e adivinha ? não tem nada para calcular o frete e ainda aparece a mensagem que não tem transportadora. Ora cadastrei o endereço de goias com cep verdadeira e não tem transportadora ? estranho né ? primeiro o modulo não funciona e quando postam um link de exemplo pior ainda.

 

manda um link de verdade pra gente ver funcionando, tem jeito ?

 

Print da tela do resultado do módulo em tamanho FULL.

 

Anexo logo abaixo:

 

 

 

 

 

post-1019298-0-83285100-1433353195_thumb.jpg

Edited by qvm

Share this post


Link to post
Share on other sites

Amigo, porque você não instalar ele e posta o link aqui pra gente acessar e fazer o teste ? Aí pelo menos se pra gente não funciona mas pelo menos vemos que existe a possibilidade de funcionar e podemos até achar uma solução juntos e assim colaborar com o bem de todos.

 

Instala ele e teremos o maior prazer em testar.

 

 

Amigo o link é este:  http://querovendermais.com.br/prestashop_1.6.0.14/pt/encomenda

 

Logo abaixo estas a imagem do print da tela do resultado do módulo em tamanho FULL.

post-1019298-0-62325000-1433353348_thumb.jpg

Share this post


Link to post
Share on other sites

entrei no link que ele menciona e também não tem nada, não tem transportadora cadastrada.

 

O print com certeza é falso, se alguém consegue por favor prove.

Share this post


Link to post
Share on other sites

entrei no link que ele menciona e também não tem nada, não tem transportadora cadastrada.

 

O print com certeza é falso, se alguém consegue por favor prove.

 

 

Qual o CEP de destino que você está utilizando, amigo?

Share this post


Link to post
Share on other sites

Posso usar qualquer um desde que seja verdadeiro. Ou não ? Será que o modulo só atende alguns estados ? Uso o FK CORREIOS e ele calcula qualquer cep, sem distinção.

 

Desculpe mas a pergunta que você fez é irrelevante já que o objetivo do modulo é atender todo os ceps validos.

 

Mas tudo bem, se o problema é esse eu usei o cep 78300000 que calcula normalmente pelo site dos correios e também por outros modulos.

Share this post


Link to post
Share on other sites

também já tentei instalar a versão deste modulo que está postado no forum e não funcionou em nenhuma das versões do prestashop, nem antigas nem a última.

Share this post


Link to post
Share on other sites

Os prints não são falsos, não temos motivos para tal atitude. Iremos verificar o que deve está ocorrendo e postaremos o resultado em breve aqui no fórum.

Edited by qvm

Share this post


Link to post
Share on other sites

Se alguém puder ajudar fico grato pois realmente tenho interesse no modulo pois na configuração oferece algo muito interessante que é a opção de ativar os prazos de preparação da encomenda, se funcionar o prazo visualizado pelo cliente será o prazo mais provavel e real da entrega. Percebi que no backofice apresenta as transportadoras disponíveis a este modulo e aparentemente estão corretas, mas no front realmente não é possivel visualizar e consta como sem transportadora.

 

Espero que consigam encontrar uma solução, acredito que será um modulo em destaque no futuro.

Share this post


Link to post
Share on other sites

Fizemos vários testes e não encontramos problema desse tipo. Por algum motivo o módulo não esta calculando com alguns CEps, verificaremos o que está ocorrendo e postaremos o resultado aqui no fórum.

 

Atacadao, agradecemos a sua boa intenção em ajudar, dando a sua contribuição aqui no fórum.

 

Com certeza vamos resolver o problema do módulo.

Share this post


Link to post
Share on other sites

Mas o que percebi fazendo vários testes em diversas versões do prestashop é que a questão não é fazer o calculo de alguns ceps, o problema principal é que as opções de frete não estão aparecendo no front. Me parece que as outros menbros também estão se referindo a mesma questão.

Share this post


Link to post
Share on other sites

Mas o que percebi fazendo vários testes em diversas versões do prestashop é que a questão não é fazer o calculo de alguns ceps, o problema principal é que as opções de frete não estão aparecendo no front. Me parece que as outros menbros também estão se referindo a mesma questão

 

 

Realmente, é muito estanho o que está ocorrendo. Para termos certeza, baixamos o mesmo arquivo que posta aqui, instalamos e fizemos os testes e postamos o print com o resultado sem problema, exceto o CEP 74565-200 de um dos cadastro da loja. Por isso vamos verificar o ocorrido.

Edited by qvm

Share this post


Link to post
Share on other sites

Posso usar qualquer um desde que seja verdadeiro. Ou não ? Será que o modulo só atende alguns estados ? Uso o FK CORREIOS e ele calcula qualquer cep, sem distinção.

 

Desculpe mas a pergunta que você fez é irrelevante já que o objetivo do modulo é atender todo os ceps validos.

 

Mas tudo bem, se o problema é esse eu usei o cep 78300000 que calcula normalmente pelo site dos correios e também por outros modulos.

 

Verificamos o seu cadastro na loja de demo, e vimos que utilizou o cep "74565-200", e realmente não funcionou com o mesmo, contudo, utilizamos o CEP citado acima(78300000) e o módulo retornou com o resultado de frete normalmente

Share this post


Link to post
Share on other sites

Olá pessoal!

 

 

O problema estava no Cadastro  de CEP do módulo, ou seja, sempre que calculava o frete com o CEP de destino dos estados de SP, GO, DF e AM, ocorria a inconsistência.

Foi adicionado ao módulo, o prazo de entrega, a pedido de um dos membros do fórum.

 

 

Necessário baixar a nova versão do módulo.

Edited by qvm

Share this post


Link to post
Share on other sites

Olá, resolvido.

 

O modulo está funcionando e realmente gostei.

 

Já instalei em uma loja teste e funcionou bem, vou instalar em uma loja que já está em funcionamento para avaliação alguns dias.

 

Com certeza será um modulo de destaque.

 

Abaixo listo alguns detalhes minimos que observei e que podem ser verificados e corrigidos:

 

1) Ao selecionar "valor declarado" o custo do frete tem um aumento exorbitante, fora do valor normal do frete.

2) Ao selecionar "tempo de preparação" os prazos estão sendo informados tanto para o PAC como para o SEDEX. Ou seja, o prazo do pac fica igual ao do sedex.

 

Foi só isso que verifiquei até o momento mas somente descrevo aqui para poder contribuir para a melhoria do modulo.

 

No mais fico muito agradecido por este genial trabalho, parabéns !

Share this post


Link to post
Share on other sites

Olá, resolvido.

 

O modulo está funcionando e realmente gostei.

 

Já instalei em uma loja teste e funcionou bem, vou instalar em uma loja que já está em funcionamento para avaliação alguns dias.

 

Com certeza será um modulo de destaque.

 

Abaixo listo alguns detalhes minimos que observei e que podem ser verificados e corrigidos:

 

1) Ao selecionar "valor declarado" o custo do frete tem um aumento exorbitante, fora do valor normal do frete.

2) Ao selecionar "tempo de preparação" os prazos estão sendo informados tanto para o PAC como para o SEDEX. Ou seja, o prazo do pac fica igual ao do sedex.

 

Foi só isso que verifiquei até o momento mas somente descrevo aqui para poder contribuir para a melhoria do modulo.

 

No mais fico muito agradecido por este genial trabalho, parabéns !

 

 

Agradecemos a paciência e o elogio. Aperfeiçoaremos o módulo de acordo com as necessidades postadas aqui no fórum, todavia, a proposta será analisada.

 

 

Sobre o valor declarado:

Verificaremos o problema citado.

 

 

Sobre o prazo de entrega:

Você pode definir um valor padrão, para todos serviços, ou configurá-la em cada serviço separadamente, acessando a aba "Serviços" (deverá limpar o valor padrão). 

 

Edited by qvm

Share this post


Link to post
Share on other sites

Agradecemos a paciência e o elogio. Aperfeiçoaremos o módulo de acordo com as necessidades postadas aqui no fórum, todavia, a proposta será analisada.

 

 

Sobre o valor declarado:

Verificaremos o problema citado.

 

 

Sobre o prazo de entrega:

Você pode definir um valor padrão, para todos serviços, ou configurá-la em cada serviço separadamente, acessando a aba "Serviços" .

 

 

 

Erro com o valor declarado corrigido.

Edited by qvm

Share this post


Link to post
Share on other sites

Se alguém puder ajudar fico grato pois realmente tenho interesse no modulo pois na configuração oferece algo muito interessante que é a opção de ativar os prazos de preparação da encomenda, se funcionar o prazo visualizado pelo cliente será o prazo mais provavel e real da entrega. Percebi que no backofice apresenta as transportadoras disponíveis a este modulo e aparentemente estão corretas, mas no front realmente não é possivel visualizar e consta como sem transportadora.

 

Espero que consigam encontrar uma solução, acredito que será um modulo em destaque no futuro.

 

 

O módulo já está funcionando, amigo. Os erros já foram retificados. Grato.

Share this post


Link to post
Share on other sites

estou com problema na configuração do módulo.

Aparece a mensagem: dominio incorreto

 

sabe o motivo?

 

Em qual domínio está tentando instalar o módulo, amigo?

Share this post


Link to post
Share on other sites

Porque não aparece na página do produto como na sua demo http://www.querovendermais.com.br/prestashop_1_6/ ? O módulo parece ser muito bom, mas esse recurso pesa muito, o que diferencia do módulo FK, que aparece na pagina do produto pra calcular o frete.

 

 

Olá Brenda!  

 

O módulo que está no link que se refere, é diferente do Nosso módulo FREE, ou seja, são módulos distintos. O módulo tem a sua versão completa, mas o foco do Módulo Carrier FREE, não é competir ou ser um corrente, e sim, oferecer recursos básicos de um módulo Prestashop definido como "CARRIER".

 

Contudo, agradecemos a sua opinião.

Share this post


Link to post
Share on other sites

Boa noite,

 

Fiz a instalação do modulo e o mesmo naoa parece nem na pagina do carrinho, e ao finalizar o eido informa que não ha tansportadora disponivel.

 

uma outra pergunta, o seu modulo faz frete gatis para um cep especifico, tipo para afaixa de cp de bauru seria gratis o frete?

 

post-1001025-0-24826000-1434779897_thumb.jpg

Share this post


Link to post
Share on other sites

Estou com um problema, da erro no dominio. Versao utilizada 1.6.0.9

 

Imagem a baixo. SOAP ativado no servidor. 

 

O link ta acessível. http://perfumeimportado212.com.br

o problema e na escrita do link no teu navegador.

 

 

Olá amigo!

 

Ao tentar acessar o domínio citado, ocorre um redirecionamento incorreto.

 

Redirecionando para "http://http//perfume...tado212.com.br/".

Edited by Azachow

Share this post


Link to post
Share on other sites

Boa noite,

 

Fiz a instalação do modulo e o mesmo naoa parece nem na pagina do carrinho, e ao finalizar o eido informa que não ha tansportadora disponivel.

 

uma outra pergunta, o seu modulo faz frete gatis para um cep especifico, tipo para afaixa de cp de bauru seria gratis o frete?

 

Verifique se você ativou os serviços, ou configurou equivocadamente, os intervalos de cep.

Share this post


Link to post
Share on other sites

quando coloco o codigo de ativação ele da um erro como este:
"[PrestaShop] Fatal error in module file :/home/alxdesig/public_html/loja/modules/qvmcarriercorreiosfree/qvmcarriercorreiosfree.php:

Cannot use object of type SoapFault as array"[[[

 

 

o que devo fazer? versao 

 1.7.4

Share this post


Link to post
Share on other sites

EU consigo cadastrar cep grátis para um determinado cep?

 

Frete grátis para somente um intervalo de cep? Não amigo. Você pode configurar todo o serviço como frete grátis 

Share this post


Link to post
Share on other sites

 

quando coloco o codigo de ativação ele da um erro como este:

"[PrestaShop] Fatal error in module file :/home/alxdesig/public_html/loja/modules/qvmcarriercorreiosfree/qvmcarriercorreiosfree.php:

Cannot use object of type SoapFault as array"[[[

 

 

o que devo fazer? versao 

 1.7.4

 

Você deve habilitar a dll Soap do PHP no servidor de hospedagem

Share this post


Link to post
Share on other sites

Olá, mesmo habilitando o dll SOAP no servidor de hospedagem o seguinte erro continua aparecendo:

 

[PrestaShop] Fatal error in module qvmcarriercorreiosfree:
Cannot use object of type SoapFault as array

Share this post


Link to post
Share on other sites

Olá, mesmo habilitando o dll SOAP no servidor de hospedagem o seguinte erro continua aparecendo:

 

[PrestaShop] Fatal error in module qvmcarriercorreiosfree:

Cannot use object of type SoapFault as array

Olá amigo!

 

O problema estava ocorrendo porque alguns servidores bloqueiam o acesso externo via "HTTPS", ou seja, não permite acessos externos via "SSL", por isso, é necessário baixar a nova versão com esta modificação.

 

Att,

 

 

 

Edited by qvm

Share this post


Link to post
Share on other sites

Olá, eu também estou com problema.

 

Quando tento colocar o código de ativação, dá o seguinte erro:

 

[PrestaShop] Fatal error in module file :/home2/fofices/public_html/modules/qvmcarriercorreiosfree/qvmcarriercorreiosfree.php:
Cannot use object of type SoapFault as array

 

DETALHE: O SOAP já está habilitado.

 

Por favor, preciso de ajuda.

 

Obrigado,

Simon

Share this post


Link to post
Share on other sites

Olá, eu também estou com problema.

 

Quando tento colocar o código de ativação, dá o seguinte erro:

 

[PrestaShop] Fatal error in module file :/home2/fofices/public_html/modules/qvmcarriercorreiosfree/qvmcarriercorreiosfree.php:

Cannot use object of type SoapFault as array

 

DETALHE: O SOAP já está habilitado.

 

Por favor, preciso de ajuda.

 

Obrigado,

Simon

 

 

Qual a versão do MÓDULO, vc está utilizando, amigo?  

Share this post


Link to post
Share on other sites

 

 

Qual a versão do MÓDULO, vc está utilizando, amigo?  

 

 

Olá amigo, obrigado por responder.

 

Acabei de instalar a última versão, 1.7.7.

 

O que posso fazer? O SOAP já está habilitado no Apache.

 

Obrigado,

Simon

Edited by fofices

Share this post


Link to post
Share on other sites

Olá amigo, obrigado por responder.

 

Acabei de instalar a última versão, 1.7.7.

 

O que posso fazer? O SOAP já está habilitado no Apache.

 

Obrigado,

Simon

Para qual domínio está tentando instalar o módulo?

Share this post


Link to post
Share on other sites

Para qual domínio está tentando instalar o módulo?

 

 

O domínio é: www.fofices.com.br.

 

Também estou usando a última versão do PrestaShop (1.6.1.0).

Share this post


Link to post
Share on other sites

O domínio é: www.fofices.com.br.

 

Também estou usando a última versão do PrestaShop (1.6.1.0).

 

 

 

Tentamos acessar a URL citada(www.fofices.com.br) e percebemos que a mesma sofre um redirecionamento, substituindo os "WWW".

 

Alteramos o módulo para TENTAR corrigir este comportamento. Baixe a última versão e tente novamente, seja qual for o resultado, por favor, poste aqui no forum, para tentarmos ajudar a corrigir o erro ou nos informar do resultado positivo.

 

 

Share this post


Link to post
Share on other sites

Tentamos acessar a URL citada(www.fofices.com.br) e percebemos que a mesma sofre um redirecionamento, substituindo os "WWW".

 

Alteramos o módulo para TENTAR corrigir este comportamento. Baixe a última versão e tente novamente, seja qual for o resultado, por favor, poste aqui no forum, para tentarmos ajudar a corrigir o erro ou nos informar do resultado positivo.

 

 

 

 

Não sei porque há esse redirecionamento. Vou tentar tirá-lo. O domínio principal é fofices.com.br.

 

Vou baixar e instalar novamente.

 

Obrigado.

Share this post


Link to post
Share on other sites

Não sei porque há esse redirecionamento. Vou tentar tirá-lo. O domínio principal é fofices.com.br.

 

Vou baixar e instalar novamente.

 

Obrigado.

 

 

Agora consegui validar o código de autenticação do módulo.

 

Mas continuo sem conseguir fazê-lo funcionar. Quando seleciono o produto e vou pro checkout, aparece só a opção de FRETE GRÁTIS... :(

 

Você pode me ajudar novamente, por favor? http://fofices.com.br/pedido-express

 

OBS: Qual a diferença desse módulo para os outros que são pagos?

 

Obrigado!

Share this post


Link to post
Share on other sites

O módulo necessita do cep do cliente cadastrado. Por isso, é necessário que o mesmo esteja logado.

 

 

Estou testado logado, mas não adianta. Quando coloco no carrinho, já aparece como frete grátis.

 

 

Você tem outros módulos para vender?

Share this post


Link to post
Share on other sites