Jump to content

Recommended Posts

Bonjour à tous,

 

voilà avant d'ouvrir ce billet, j'ai tt de même fait une recherche sur la totalité du forum mais je n'ai pas trouvé ma réponse (en tt cas pas pour cette version de prestashop et si j'ai mal vu alors pardon d'avance).

 

Je suis sur prestashop 1.6.1.4 et j'ai de gros soucis avec le module de traduction, j'ai acheté un template sur la boutique prestashop mais du coup mon shop est en anglais.

 

J'ai bien compris que je pouvais le traduire manuellement en passant par Localisation -> Traductions

 

puis en choisissant Traductions du front-office

Le nom de mon thème (là c'est PRSADD015

et ma langue Français

 

Je clic sur le bouton modifier.

 

Et là j'ai plein de champs je rempli je sauvegarde mais tj rien, pas d'erreur coté Prestashop et à chaque enregistrement je n'ai tj rien, pire je recommence et et recommence de remplir j'ai l'impression que rien ne s'enregistre (j'ai testé avec Chrome et firefox dernière version su r mac os x dernière version aussi).

 

 

J'ai vu ici: http://www.prestacrea.com/blog/64-5-problemes-frequents-lors-de-l-installation-d-un-template-prestashop

mais depuis le bug aurait été corrigé ...

 

Alors j'aimerais bien avoir vos retours, sur le pourquoi du comment ? et surtout comment faire pour avancer ? 

 

Merci d'avance à tous

 

  • Like 1

Share this post


Link to post
Share on other sites

Ca ma rassure que je ne suis pas le seul avec ce problème, je suis également sur la 1.6.1.4 (la dernière à ce jour) et y'a un soucis sur la traduction des module d'un thème. Sur mes 3 sites sous cette version ça me le fait donc je ne pense pas que ça soit un hasard...

 

J'ai de mon côté aussi chercher des informations mais c'est assez vide sur Google / Forum pour ce cas.

 

Je peux compléter par dire que le fichier php se créer bien sur le FTP SAUF QU'IL est VIDE.

 

De plus, je fais SAUVEGARDER et RESTER et ça ne me laisse pas sur la page. Donc y'a bien un soucis entre les deux.

 

J'ai pu regarder le Controller qui fait l'export, si je var_dump l'ensemble des données transmis, c'est bien présent mais le fichier reste vide.

  • Like 1

Share this post


Link to post
Share on other sites

Même problème, j'ai tenté de modifier le max_input_vars dans le php.ini, j'ai mis jusqu'à 100 000, rien n'y fait...

Avez-vous pu trouver une solution?

Personne pour aider apparemment, c'est pourtant un gros problème...

 

1.6.1.4

PHP 5.4 et 5.5 (j'ai testé les 2)

Hébergeur PHPNET

Edited by Olórin (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Nan je cherche toujours, je vais finir par le traduire en "dur" mais j'aimerais éviter de perdre le côté pratique du fichier langue à côté...

 

Je suis quand même déçu de voir que y'a de moins en moins (voir plus du tout) d'aide sur le forum de Prestashop avec le temps :(

  • Like 1

Share this post


Link to post
Share on other sites

Même problème, j'ai tenté de modifier le max_input_vars dans le php.ini, j'ai mis jusqu'à 100 000, rien n'y fait...

Avez-vous pu trouver une solution?

Personne pour aider apparemment, c'est pourtant un gros problème...

 

1.6.1.4

PHP 5.4 et 5.5 (j'ai testé les 2)

Hébergeur PHPNET

Oui toujours rien de notre coté aussi  :(

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

Je viens d'avoir une astuce, je trouve ça fou que je sois obligé de rajouter ça pour ce thème mais ça fonctionne (uniquement sur le début de la page, même en changeant la valeur à 5000) :

 

Il faut créer un php.ini (ou compléter si il existe) et ajouter ces deux lignes :

tonsite/prestashop/admin/php.ini

suhosin.request.max_vars = 2048
suhosin.post.max_vars = 2048
Edited by Julien_Snow (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Merci Julien! Mais en effet cela ne fonctionne que sur le début de la page.

Malheureusement j'ai des modifs à faire plus bas, mais au moins cela montre qu'il y a bien un bug, ou que nos serveurs ne sont pas bien configurés, il doit y avoir une limite quelque part... Je vais contacter mon hébergeur pour savoir s'ils ont une idée (Phpnet) car ce n'est pas sur ce forum que l'on obtient de l'aide...

 

[edit : en fait après coup j'ai testé sans le php.ini, la sauvegarde marchait déjà en début de fichier, mais merci quand même pour m'avoir fait constater que ça ne bug pas partout, l'espoir renaît ;) ]

Edited by Olórin (see edit history)

Share this post


Link to post
Share on other sites

Merci Julien! Mais en effet cela ne fonctionne que sur le début de la page.

Malheureusement j'ai des modifs à faire plus bas, mais au moins cela montre qu'il y a bien un bug, ou que nos serveurs ne sont pas bien configurés, il doit y avoir une limite quelque part... Je vais contacter mon hébergeur pour savoir s'ils ont une idée (Phpnet) car ce n'est pas sur ce forum que l'on obtient de l'aide...

 

[edit : en fait après coup j'ai testé sans le php.ini, la sauvegarde marchait déjà en début de fichier, mais merci quand même pour m'avoir fait constater que ça ne bug pas partout, l'espoir renaît ;) ]

 

Effectivement c'était une fausse piste, mais j'ai enfin réussi à trouver et résoudre le problème. Demande à Phpnet de désactivé le mod-security ;)

Share this post


Link to post
Share on other sites

Effectivement c'était une fausse piste, mais j'ai enfin réussi à trouver et résoudre le problème. Demande à Phpnet de désactivé le mod-security ;)

 

Effectivement c'était une fausse piste, mais j'ai enfin réussi à trouver et résoudre le problème. Demande à Phpnet de désactivé le mod-security ;)

 

 

bonjour,

 

j'ai moi aussi le même problème. Où peut-on désactiver le mod-security?

 

merco

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More