Jump to content

Soucis d'affichage dans IE


Recommended Posts

Hello,


J'ai un petit soucis d'affichage dans IE sur mon site www.pullipshop.be.

Voici le message d'erreur donné :
Détails de l’erreur de la page Web

Agent utilisateur : Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; .NET CLR 1.0.3705; .NET CLR 1.1.4322; Media Center PC 4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)
Horodateur : Mon, 5 Apr 2010 08:44:22 UTC


Message : Cet objet ne gère pas cette propriété ou cette méthode
Ligne : 145
Caractère : 4
Code : 0
URI : http://www.pullipshop.be/


En fait, sur Google Chrome et Firefox, les photos des objets Homefeatured sont directement en dessous du texte du titre 'A ne pas rater' (au lieu de Produits Phares).
Mais dans Internet Explorer, il y a un décalage de 4-5 cm.

Merci pour votre aide !

Share this post


Link to post
Share on other sites

Et voici le contenu du fichier homefeatured.tpl

><!-- MODULE Home Featured Products -->


{l s='featured products' mod='homefeatured'}
{if isset($products) AND $products}

    {assign var='liHeight' value=360}
    {assign var='nbItemsPerLine' value=4}
    {assign var='nbLi' value=$products|@count}
    {assign var='nbLines' value=$nbLi/$nbItemsPerLine|ceil}
    {assign var='ulHeight' value=$nbLines*$liHeight}

       {foreach from=$products item=product name=homeFeaturedProducts}
       {assign var='productLink' value=$link->getProductLink($product.id_product, $product.link_rewrite, $product.category)}








{$product.name|escape:htmlall:'UTF-8'|truncate:30}


{$product.description_short|strip_tags|truncate:100:'...'}


{displayWtPrice p=$product.price}
{l s='View' mod='homefeatured'}
{l s='Cart' mod='homefeatured'}
{if ($product.quantity > 0 OR $product.allow_oosp) AND $product.customizable != 2}

            {else}
{l s='Add to cart' mod='homefeatured'}
           {/if}


        {/foreach}


   {else}

{l s='No featured products' mod='homefeatured'}
{/if}

</pre>
<ul>



</ul>
<br><br><br><!-- /MODULE Home Featured Products --&gt



Merci d'utiliser les balises 'code' et non pas 'quote' ;) -yoya971

Share this post


Link to post
Share on other sites

Quand je regarde ton site sous IE j'ai bien le message de beug qui s'affiche, par contre je ne vois aucun décalage des images, ou peut être juste le premier panier.

As tu résolu se problème ?

Si oui ca m'interesse car j'ai le mêmes soucis sur mon site =)
Merci !

Share this post


Link to post
Share on other sites

J'utilise IE8. C'est peut-être çà la différence.
Je n'ai toujours pas trouvé la solution en tout cas...

En fait, dans le fichier .tpl, il est indiqué 4 produits par ligne, et le site affiche 6 produits par ligne. Ce qui en soit ne me gène pas, mais çà doit être dans ces lignes...! Je dois encore vérifier le global.css aussi pour voir si il n'y a pas un décalage quelque part...

Le premier qui trouve informe l'autre ok ;-) ??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More