Jump to content
Xavier Borderie

Pour En Savoir Plus Sur Prestashop 1.7

Recommended Posts

Pourquoi le js theme est il aussi lourd avec si peu de fonctionnalités ?

 

Pourquoi utiliser stylus pour le css alors que sass est en train de s'imposer sur de nombreux frameworks ?

 

Stylus sur starter

Sass sur Classic

 

 

Pour stylus, on a commencé à utiliser ca au debut parce que le CSS du startertheme n'est pas sensé rester la. Le CSS existe pour l'environnement de dev, un site sans CSS, ca devient hyper chaud à tester. Au final on va devoir le repasser en SASS (à mon avis ca devrait pas etre trop difficile), surtout aprce qu'on veut livrer l'environnement de dev avec webpack, du coup il faut sass et pas stylus.

 

Effectivement SASS est devenu le standard, c'est pour ca qu'on l'utilise pour Classic.

 

Pour le JS je vois pas trop le soucis, effectivement le JS a grossi, puisqu'on embarque tout dans un seul fichier, mais c'est à peine plus gros que sur la 1.6.

 

Apres je reconnais qu'il y a surement de l'optim à faire encore, il va falloir se plonger dedans.

Share this post


Link to post
Share on other sites

Bon ,

 

Je m'incruste sur ce topic désolé mais vu que le CM ne répond pas à mes sujets ou que les modos les suppriment ... 

 

Je voudrais savoir c'est quoi ce popup qui enregistre le path du topic et pas un / ? C'est juste insupportable quand on a les cookies qui se vide à la fermeture d'un navigateur par exemple.

 

Qui est chargé de ça franchement ça prend 50 secondes.

 

Merci d'avoir prit le temps de me lire !!

 

Okom3pom

Share this post


Link to post
Share on other sites

Bonjour,

Je m'incruste sur ce topic désolé mais vu que le CM ne répond pas à mes sujets ou que les modos les suppriment ... 

 

Je voudrais savoir c'est quoi ce popup qui enregistre le path du topic et pas un / ? C'est juste insupportable quand on a les cookies qui se vide à la fermeture d'un navigateur par exemple.

 

Qui est chargé de ça franchement ça prend 50 secondes.

 

Merci d'avoir prit le temps de me lire !!

 

Okom3pom

Problème du cookie PrestaShopDay résolu le 15/04, source. :)

Continuons la discussion sur la version 1.7.

Share this post


Link to post
Share on other sites

J'ai ajouté les liens vers de nouveaux articles Build :

Share this post


Link to post
Share on other sites

https://www.esprit-equitation.com/bottes-et-boots/4544-boots-vallery-performance.html ????????????????????

C'est à qui se site? fait par prestashop avec un SSL qui marche ? j'y crois pas ! je tombe des nus! ON FAIT COMMENT POUR AVOIR UN SITE COMME LE VOTRE ET COMBIEN SA VOUS A COUTER ????

Si prestashop arrive à faire des sites comme ça moi je comprends plus rien ! Pourquoi on ma pas aider ou proposer de faire un site comme le votre !!!???? franchement il es propre!!! 

 

Voici un autre Prestashop sur lequel j'ai beaucoup bossé https://www.naturamedicatrix.fr et qui fonctionne très bien ;)

Share this post


Link to post
Share on other sites

Bonjour AntoineWrt

 

La sémantique fait croire que vous avez travaillé sur mon site ....

 

3pom 

Share this post


Link to post
Share on other sites

A- c'est très facile a obtenir, vraiment

 

Et compte tenu du prix de ce certificat (Advanced Validation) ce serait bien de faire les choses dans les règles

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

Bonjour à toutes et à tous !

 

J'ai ajouté au premier message de ce sujet le dernier article sur devblog Build, annonçant la Beta 1 des PrestaShop 1.7.0.0 :

J'espère que vous contribuerez à faire de cette version la meilleure qui soit !
 

Share this post


Link to post
Share on other sites
Guest

J'espère de mon coté que la 1.6 sera supportée encore longtemps car la 1.7 est loin d'être exploitable et devrait plutôt s'appeler 2.0 alpha pour le moment car le virage est assez rude, ce n'est pas la même branche que la 1.6.. à mon humble avis, mais qui s'en soucie ?!?

Share this post


Link to post
Share on other sites

Si un modo pouvait passer par là et supprimer tous ces posts HS ce serait une bonne idée^^
 
Pour @ledpromoplus, si vous n'arrivez même pas à comprendre le sujet d'un post sur un forum et poser votre question au bon endroit, c'est pas gagné pour votre boutique.

Je ne pense pas que si vous allez chez le boulanger il vous vendra du poisson^^

 

Organisez-vous dans votre tête, lisez la doc et le forum, essayez de comprendre et ouvrez votre propre topic.

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour, je me permets une petite question certainement idiote mais je me la pose tout de même 

 

Actuellement je suis sur Presta 1.6 mais lorsque nous passerons sur 1.7 est ce que toute notre base de données sera conservée ??

Tous les produits, clients ( adresse, infos, ...) , commandes, cms, attributs, catégories, déclinaisons, transporteurs, ...???? 

 

Car si il y a changement d'architecture et de structure, il y aura certainement un changement et réorganisation aussi sur la BDD  non ? donc peut-être incompatibilité des BDD entre elles ? 

 

lorsqu'on passera sur la nouvelle version est ce que l'on pourras conserver les choses tel que nous les avons actuellement ?  

espérer récupérer toutes nos infos existantes ? 

 

ou devrons nous tout recommencer à zéro ? 

 

Merci 

 

ah et peut-être pour les marchands ( sans développeurs, ... ) et qui n'ont pas le temps de tout traduire mais qui tentent de comprendre, pour tenter de participer

 

Serait-ce possible de faire des FAQ en Français  ?

et également expliquer plus clairement en Français certaines choses qui pour nous semblent incompréhensible et compliquée en anglais avec des mots technique et du jargon et très difficile a suivre ( en étant quand même à l'aise avec l'anglais ) pas simple vraiment ! 

 

MERCI 

 

 

Ps nous restons inquiet sur ces changements que nous n'arrivons pas a cerner et encore moins quantifié, ni planifié

 

même si derrière les murs il y a toujours la mer 

 

  :)

 

 

Bonne journée 

Edited by Didjou (see edit history)

Share this post


Link to post
Share on other sites

dans TOUS LES CAS : il faut faire une sauvegarde (fichiers et bdd).

 

Normalement ça ne pose pas de problème de faire une mise à jour 1.6->1.7.

 

 

 

 

le vrai problème, c'est pour ceux qui font les modules, il y a de quoi devenir fou...

 

ok ppp, ddd sont remplacés par dump (mais en même temps, on peut pas remettre une fonction ppp qui renvoi la fonction dump ?)

et {debug} a été remplacé par quoi ? dans le tpl d'un module ça ne fonctionne plus correctement

ou est passé la fonction "basique" ajaxCart.add(id_product, ipa...) ?

existe t il un guide permettant de s'y retrouver dans les dizaines de milliers de lignes de js ? idem pour le thème ?

 

si vous voulez dégoûter les gens de faire des modules avec facilité, c'est gagné.

Share this post


Link to post
Share on other sites
Guest

Quoi de neuf coté marchand pour cette 1.7 ? tatatata.... RIEN !

 

par contre les devs et les intégrateurs vont s'amuser si ils veulent continuer à travailler sur Prestashop, c'est Hype presta maintenant !

Share this post


Link to post
Share on other sites

Quoi de neuf coté marchand pour cette 1.7 ? tatatata.... RIEN !

 

Un front qui marche et une page produit beaucoup plus simple et optimisé. Il ne suffit pas de rajouter feature sur feature pour faire un meilleur logiciel.

 

 

dans TOUS LES CAS : il faut faire une sauvegarde (fichiers et bdd).

 

Normalement ça ne pose pas de problème de faire une mise à jour 1.6->1.7.

 

 

 

 

le vrai problème, c'est pour ceux qui font les modules, il y a de quoi devenir fou...

 

ok ppp, ddd sont remplacés par dump (mais en même temps, on peut pas remettre une fonction ppp qui renvoi la fonction dump ?)

et {debug} a été remplacé par quoi ? dans le tpl d'un module ça ne fonctionne plus correctement

ou est passé la fonction "basique" ajaxCart.add(id_product, ipa...) ?

existe t il un guide permettant de s'y retrouver dans les dizaines de milliers de lignes de js ? idem pour le thème ?

 

si vous voulez dégoûter les gens de faire des modules avec facilité, c'est gagné.

 

Devenir fou parce qu'il n'y a plus ddd ?  :wacko:

 

Pour le js dont tu parles: https://github.com/PrestaShop/PrestaShop/blob/develop/themes/_core/js/cart.js#L28-L47

 

Concernant la doc, malheureusement on a pas encore eu le temps qu'on voudrait pour la rediger. Les premiers jets sont ici: https://github.com/PrestaShop/docs

Share this post


Link to post
Share on other sites

Bonjour, je me permets une petite question certainement idiote mais je me la pose tout de même 

 

Actuellement je suis sur Presta 1.6 mais lorsque nous passerons sur 1.7 est ce que toute notre base de données sera conservée ??

Tous les produits, clients ( adresse, infos, ...) , commandes, cms, attributs, catégories, déclinaisons, transporteurs, ...???? 

 

Car si il y a changement d'architecture et de structure, il y aura certainement un changement et réorganisation aussi sur la BDD  non ? donc peut-être incompatibilité des BDD entre elles ? 

 

lorsqu'on passera sur la nouvelle version est ce que l'on pourras conserver les choses tel que nous les avons actuellement ?  

espérer récupérer toutes nos infos existantes ? 

 

ou devrons nous tout recommencer à zéro ? 

 

Merci 

 

ah et peut-être pour les marchands ( sans développeurs, ... ) et qui n'ont pas le temps de tout traduire mais qui tentent de comprendre, pour tenter de participer

 

Serait-ce possible de faire des FAQ en Français  ?

et également expliquer plus clairement en Français certaines choses qui pour nous semblent incompréhensible et compliquée en anglais avec des mots technique et du jargon et très difficile a suivre ( en étant quand même à l'aise avec l'anglais ) pas simple vraiment ! 

 

MERCI 

 

 

Ps nous restons inquiet sur ces changements que nous n'arrivons pas a cerner et encore moins quantifié, ni planifié

 

même si derrière les murs il y a toujours la mer 

 

  :)

 

 

Bonne journée 

Ne soyez pas inquiet, la version stable ne sera pas disponible avant 2 ans comme toutes les précédentes versions. Je parle de version réellement stable à l'usage, pas de "officiellement stable"

 

Pour l'instant si votre boutique fonctionne bien en 1.6 pourquoi vouloir changer une équipe qui gagne ? La 1.7 effectivement, n'apporte rien de plus coté marchand.

Concernant l'usage de la langue anglaise, il nous a été répondu que maintenant Prestashop était international, donc apprenez à parler anglais et basta.

C'était assez drôle d'ailleurs, lors du dernier prestashopday de voir les gens partir au fur et à mesure que les présentations PowerPoint s'affichaient en anglais...

 

Comme d'habitude, vous ferez les bêta-testeurs en live, avec les ennuis que ça comporte pour votre business et vos clients mais ça, apparemment c'est le cadet de leurs soucis.

On a demandé, il y a 1 an et demi lors du défunt "dev-meeting" que les mises à jours (quelques qu'elles soient: modules, thèmes ou Core) aient un véritable changelog avec les points importants ayant été modifiés ainsi que le caractère "Sécurité" ou "Amélioration" ou "Correction de bug" soit explicitement noté.

Il n'en n'est rien.

 

La dernière mise à jour de la 1.6.1.5 a révélé 4 bugs majeurs que la communauté a tout de suite solutionné et transmis sur GitHub. Les PR ont été mergés et pourtant la 1.6.1.6 est toujours en attente de sortie. Pourquoi ? Comment font les e-commerçants qui n'y connaissent rien en code pour corriger ces bugs ?

Pourquoi y a t il toujours indiqué dans tous les dashboards de France et de Navarre "Mettez à jour vers 1.6.1.5 maintenant" ?

Pourquoi ce mépris des véritables utilisateurs ?

  • Like 4

Share this post


Link to post
Share on other sites

Julien,

Avec de telles déclaration d'event en JS, il deveint impossible à des modules de faire des surcharges.

Genre un module qui fait quelque chose avant ou après la mise en panier native.

 

Pourquoi ne pas définir une méthode standart (donc surchargeable) qui soit appelé par ce 'On()' ?

  • Like 1

Share this post


Link to post
Share on other sites

Un front qui marche et une page produit beaucoup plus simple et optimisé.

 

Où ça?

 

Vous avez réglé les 25+ boucles infinies dans getDeliveryOptionList() ? les 10+ boucles de addressFormat() ? les caches immondes du menu, blockcategory, ...

C'est tellement mieux optimisé à chaque version que les pages sont plus lente, plus lourde, et que l'on arrive avec peine à avoir des perfs dès que l'on dépasse 10 connexions/s - même avec une débauche de puissance

Share this post


Link to post
Share on other sites

1- je prend la 1.7.0.0 beta 1

2- je supprime l'intégralité du contenu du fichier cart.js qui contient :

 

import $ from 'jquery';
import prestashop from 'prestashop';

$(document).ready(() => {
  prestashop.on('cart dom updated', function(event) {
    createSpin();
  });

  $('body').on(
    'click',
    '.js-touchspin, [data-link-action="delete-from-cart"], [data-link-action="remove-voucher"]',
    function(event) {
      event.preventDefault();
      // First perform the action using AJAX
      var actionURL = null;

      if ($(event.currentTarget).hasClass('bootstrap-touchspin-up')) {
        actionURL = $(event.currentTarget).parents('.bootstrap-touchspin').find('[data-up-url]').data('up-url');
      } else if ($(event.currentTarget).hasClass('bootstrap-touchspin-down')) {
        actionURL = $(event.currentTarget).parents('.bootstrap-touchspin').find('[data-up-url]').data('down-url');
      } else{
        actionURL = $(event.currentTarget).attr('href');
      }

      $.post(actionURL, {
        ajax: '1',
        action: 'update'
      }, null, 'json').then(function() {
        // If succesful, refresh cart preview
        prestashop.emit('cart updated', {
          reason: event.currentTarget.dataset
        });
      });
    }
  );
  $('body').on(
    'click',
    '[data-button-action="add-to-cart"]',
    function(event) {
      event.preventDefault();
      var $form = $($(event.target).closest('form'));
      var query = $form.serialize() + '&add=1&action=update';
      var actionURL = $form.attr('action');

      $.post(actionURL, query, null, 'json').then(function(resp) {
        $('.quickview').modal('hide');
        prestashop.emit('cart updated', {
          reason: {
            idProduct: resp.id_product,
            idProductAttribute: resp.id_product_attribute,
            linkAction: 'add-to-cart'
          }
        });
      });
    }
  );

  $('body').on(
    'submit',
    '[data-link-action="add-voucher"]',
    function(event) {
      event.preventDefault();

      $(this).append($('<input>')
        .attr('type', 'hidden')
        .attr('name', 'ajax').val('1')
      );
      $(this).append($('<input>')
        .attr('type', 'hidden')
        .attr('name', 'action').val('update')
      );

      // First perform the action using AJAX
      var actionURL = $(this).attr('action');

      $.post(actionURL, $(this).serialize(), null, 'json').then(function() {
        // If succesful, refresh cart preview
        prestashop.emit('cart updated', {
          reason: event.target.dataset
        });
      });
    }
  );

  createSpin();
});

function createSpin()
{
  $('input[name="product-quantity-spin"]').TouchSpin({
    verticalbuttons: true,
    verticalupclass: 'material-icons touchspin-up',
    verticaldownclass: 'material-icons touchspin-down',
    buttondown_class: 'btn btn-touchspin js-touchspin',
    buttonup_class: 'btn btn-touchspin js-touchspin'
  });
}

3- je copie les fichiers et j'installe la boutique en locale

4- je vais sur une page produit

5- je choisi une taille, une couleur, une quantité,

6- je clique sur le bouton "Ajouter au panier"

7- la bonne déclinaison avec la bonne quantité est placé dans le panier

8- je vérifie, le fichier cart.js est bien entièrement vide...

Share this post


Link to post
Share on other sites

1- je prend la 1.7.0.0 beta 1

2- je supprime l'intégralité du contenu du fichier cart.js qui contient :

...

8- je vérifie, le fichier cart.js est bien entièrement vide...

 

Tout ce qui est dans themes/_core/js est compilé dans themes/core.js, donc a moins de recompiler, les changements dans _core n'ont aucun effet.

 

 

 

Où ça?

 

Vous avez réglé les 25+ boucles infinies dans getDeliveryOptionList() ? les 10+ boucles de addressFormat() ? les caches immondes du menu, blockcategory, ...

C'est tellement mieux optimisé à chaque version que les pages sont plus lente, plus lourde, et que l'on arrive avec peine à avoir des perfs dès que l'on dépasse 10 connexions/s - même avec une débauche de puissance

 

https://twitter.com/julienbourdeau/status/738693857316065280

 

 

 

Comme d'habitude, vous ferez les bêta-testeurs en live, avec les ennuis que ça comporte pour votre business et vos clients mais ça, apparemment c'est le cadet de leurs soucis.

On a demandé, il y a 1 an et demi lors du défunt "dev-meeting" que les mises à jours (quelques qu'elles soient: modules, thèmes ou Core) aient un véritable changelog avec les points importants ayant été modifiés ainsi que le caractère "Sécurité" ou "Amélioration" ou "Correction de bug" soit explicitement noté.

Il n'en n'est rien.

 

Bah teste pendant la période de Beta au lieu de troller... Tu crois qu'on fait une beta pour s'amuser ?

 

Le changelog des dernieres 1.6.1.2+ est tres clair puisqu'il n'y a que quelques PR. Mais encore une fois, tu préfères troller.

Share this post


Link to post
Share on other sites

Julien,

Avec de telles déclaration d'event en JS, il deveint impossible à des modules de faire des surcharges.

Genre un module qui fait quelque chose avant ou après la mise en panier native.

 

Pourquoi ne pas définir une méthode standart (donc surchargeable) qui soit appelé par ce 'On()' ?

 

Je pense que je comprend ce que tu veux dire. Effectivement ca pourrait etre plus simple à documenter!

 

Par contre pour l'instant tu peux overrider de la meme manière en te branchant sur 

$('body').on(

'click',

'[data-button-action=add-to-cart]', ...

 

Mais je suis d'accords que ca serait plus clair c'etait un evenement prestashop.emit. On devrait bientot faire une repasse sur le JS.

Share this post


Link to post
Share on other sites

 

Bah teste pendant la période de Beta au lieu de troller... Tu crois qu'on fait une beta pour s'amuser ?

 

Le changelog des dernieres 1.6.1.2+ est tres clair puisqu'il n'y a que quelques PR. Mais encore une fois, tu préfères troller.

 

Le changelog de la 1.6.1.5 est effectivement tellement clair qu'il manque la moitié des informations sur les réels changements.

 

Ca devient facile aussi de traiter de troll ceux qui mettent le doigt sur ce qui fait mal, ça évite de répondre aux questions ;)

A quand la mise à disposition au public de la 1.6.1.6 qui permettra enfin aux commerçants de corriger les derniers bugs créés par cette 1.6.1.5 ?

Share this post


Link to post
Share on other sites

Bah teste pendant la période de Beta au lieu de troller... Tu crois qu'on fait une beta pour s'amuser ?

Ah oui à nous (la comunauté) de tester les fonctions de bases car Travis et les régressions tests c'est pour les les gueux - real programmers never test.

 

Je constate que vous aviez un Chef Product Officer qui a tenté de vous imposer des méthodes - et depuis son départ c'est retour aux vielles méthodes qui ont prouvées leurs failles.

Share this post


Link to post
Share on other sites

Tout ce qui est dans themes/_core/js est compilé dans themes/core.js, donc a moins de recompiler, les changements dans _core n'ont aucun effet.

 

Merci pour ta réponse Julien, mais je viens de faire un autre test :

 

1- je prend la 1.7.0.0 beta 1

2- je supprime l'intégralité du contenu du fichier cart.js

3- je supprime l'intégralité du contenu du fichier themes/core.js

4- je copie les fichiers et j'installe la boutique en locale

5- dans le BO pour "Compilation des templates" je sélectionne "Recompiler les fichiers de templates s'ils ont été mis à jour", "Non" pour le cache, je clique sur "Vider le cache" en haut à droite

6- je vais sur une page produit

7- je choisi une taille, une couleur, une quantité, et je clique sur le bouton "Ajouter au panier",

8- la popup n'affiche pas les bonnes informations à chaque ajout au panier MAIS la bonne déclinaison avec la bonne quantité est placé dans le panier

9- je vérifie, les fichiers cart.js et themes/core.js sont bien entièrement vide...

Share this post


Link to post
Share on other sites

 

Merci pour ta réponse Julien, mais je viens de faire un autre test :

 

1- je prend la 1.7.0.0 beta 1

2- je supprime l'intégralité du contenu du fichier cart.js

3- je supprime l'intégralité du contenu du fichier themes/core.js

4- je copie les fichiers et j'installe la boutique en locale

5- dans le BO pour "Compilation des templates" je sélectionne "Recompiler les fichiers de templates s'ils ont été mis à jour", "Non" pour le cache, je clique sur "Vider le cache" en haut à droite

6- je vais sur une page produit

7- je choisi une taille, une couleur, une quantité, et je clique sur le bouton "Ajouter au panier",

8- la popup n'affiche pas les bonnes informations à chaque ajout au panier MAIS la bonne déclinaison avec la bonne quantité est placé dans le panier

9- je vérifie, les fichiers cart.js et themes/core.js sont bien entièrement vide...

 

As tu mis à jour le js "theme.js" quand tu fais tes tests ?

(en passant par webpack)

 

Atch

Share this post


Link to post
Share on other sites

tu parles de themes/classic/_dev/js/theme.js ?

je n'y ai pas touché, je n'ai vraiment rien fait d'autre que ce que j'ai donné

désolé (c'est lundi matin et je suis déjà fatigué), mais c'est quoi le webpack ? quand je fais une recherche dans le BO je suis encore à "Accès interdit"

Share this post


Link to post
Share on other sites

tu parles de themes/classic/_dev/js/theme.js ?

je n'y ai pas touché, je n'ai vraiment rien fait d'autre que ce que j'ai donné

désolé (c'est lundi matin et je suis déjà fatigué), mais c'est quoi le webpack ? quand je fais une recherche dans le BO je suis encore à "Accès interdit"

Tu as supprimé "cart.js" qui se trouve dans le theme rep /_dev/ ?

 

Webpack est un module bundler. Il va te compiler tous les JS et meme les css ( sass) du theme.

 

Si tu regardes ta page produit, elle n'appelle jamais cart.js mais theme.js

Si tu n'as pas reconstruit ton theme.js avec webpack après la suppression de cart.js, ce dernier est toujours dans theme.js. Ce qui explique que le cart est toujours correct :)

 

PS : Webpack est indépendant du back office. Il s'exécute en ligne de commande ( il te faut Node.js et d'autres packs)

 

V++

 

Atch

 

 

Edited by Atch (see edit history)

Share this post


Link to post
Share on other sites

Je pense que je comprend ce que tu veux dire. Effectivement ca pourrait etre plus simple à documenter!

 

Par contre pour l'instant tu peux overrider de la meme manière en te branchant sur 

$('body').on(

'click',

'[data-button-action=add-to-cart]', ...

 

Mais je suis d'accords que ca serait plus clair c'etait un evenement prestashop.emit. On devrait bientot faire une repasse sur le JS.

J'ai des modules qui font des choses sur certains événements, en complément des actions qui sont faites nativement.

Jusqu'en 1.6, je duplique par exemple le cart.addToCart() en native_addtocart(<même params) et je réécris le cart.addToCart () comme

mon compte perso suivi d'un appel native_addtocart()

 

Voire même, dans certains cas, je décide d'appeler ou pas le code natif.

Share this post


Link to post
Share on other sites

c'est bien : themes/classic/_dev/js/cart.js et themes/core.js

ils sont bien entièrement vides et themes/classic/_dev/js/theme.js ne contient quasiment que des "import" (moins de 50 lignes au total), je viens même de supprimer la ligne
import './cart';
mais ça fonctionne encore.

Share this post


Link to post
Share on other sites

Heuuu theme.js fait plus de 20 000 lignes :)  dans le theme Classic de la 1.7 car non compilé en mode "production" dans le zip de la beta.

 

c'est celui là qui est en prod : themes/classic/assets/js/theme.js et non /_dev/

post-16609-0-76931400-1465811898_thumb.jpg

Edited by Atch (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
Guest

Si quelqu'un à réussi à faire fonctionner webpack + wamp sur windows 10, merci de le dire, car après avoir passé plusieurs heures dessus, le fichier js final compilé n'est jamais correct.

Share this post


Link to post
Share on other sites

J'ai ajouté quelques articles manquants dans le premier article de cette discussion :

 

Share this post


Link to post
Share on other sites

@Julien Bourdeau :

Ca veut dire quoi cette façon de parler aux membres du forum ?

C'est uniquement grâce à des gens comme Atch, Coes.pro, Eolia, Doekia, Divine et les autres que Prestashop vit encore, pas grâce à une team dont certains comme toi ont pris tellement le melon qu'ils se prennent pour des Dieux du Dev.

Au lieu de faire n'importe quoi, car la 1.7 est effectivement un amas de n'importe quoi côté code, vous devriez peut-être d'abord corriger les centaines de bugs restants sur les versions précédentes, car j'en vois certains qui ont été signalés depuis 2009 et qui n'ont jamais été corrigés depuis, vu que vous mettez la charrue avant les boeufs en sortant des bêta versions de Prestashop depuis bientôt 8 ans.

Finalisez déjà une version, au moins vous montrerez au monde entier que vous savez terminer un travail avant d'en commencer un autre.

Perso je fais parti de ces très nombreux e-commerçants qui commencent sérieusement à penser à migrer vers une solution e-commerce digne ce nom, quitte à ce qu'elle soit payante à la base, car au moins légalement il y a obligation de résultat.

Si toutes les dév de talent cités plus haut n'étaient pas constamment derrière votre dos pour signaler et souvent corriger vos erreurs, il y a belle lurette que prestashop n'existerait plus.

Maintenant si mes propos ne te plaisent pas, c'est pareil, c'est pour moi c'est cadeau ! Et tant pis si je suis banni de ce forum pour avoir dit tout haut ce que beaucoup pensent tout bas.

Edited by N°6 (see edit history)

Share this post


Link to post
Share on other sites

payante à la base, car au moins légalement il y a obligation de résultat.

 

J'aimerai avoir des détails sur l'obligation de résultat dans la loi. À mon avis il va y avoir un peu de déception.

 

 

Et sinon pour ma façon de parler, tu remarqueras que je ne parle pas à tout le monde de la même manière!

Share this post


Link to post
Share on other sites

C'est pas les cas de jurisprudence qui manquent, en tout cas...

Share this post


Link to post
Share on other sites

On parle pas d'une SSII qui te dev un truc custom sur un contrat. On parle d'une boite de software, genre SAAS, quelles sont leurs obligations légales ?

Share this post


Link to post
Share on other sites

@Julien Bourdeau,

 

J'ai peur de comprendre tes arguments et ton raisonnement.

"On fait de la merde parce qu'on peut et qu'on en a rien a faire puisque nous n'avons aucune contrainte d'aucune sorte."

 

Belle mentalité.

Share this post


Link to post
Share on other sites

Encore une fois, t'as rien compris...

 

payante à la base, car au moins légalement il y a obligation de résultat.

 

Je suis curieux d'avoir des détails sur cette phrase parce qu'à mon avis: c'est un fantasme.

Share this post


Link to post
Share on other sites

C'est sûr qu'avec Prestashop c'est un fantasme...

Share this post


Link to post
Share on other sites
Guest

On parle pas d'une SSII qui te dev un truc custom sur un contrat. On parle d'une boite de software, genre SAAS, quelles sont leurs obligations légales ?

 

il faut lire les informations disponibles à ce sujet, il y en a assez pour comprendre que si un logiciel est vendu pour faire une tache et si le logiciel est défaillant alors les juges n'ont aucune hésitation à pénaliser l'entreprise en faute. Ce n'est pas le lieu pour débattre de ce genre de détails, par contre il serait judicieux de changer de comportement et d'attitude envers les membres de la communauté : écouter, comprendre, répondre correctement ainsi que le respect mutuels sont les bases d'une communication réussie.

Lorsque l'on prend les autres de haut, ça ne se passe que rarement bien, surtout si ces "autres" n'ont aucun obligation de lécher les godasses de celui dont l'égo à un peu trop gonflé ^^

 

Prestashop 1.7 n'est pas soutenu par la communauté active, pourquoi s'entêter à vouloir créer ce monstre à deux têtes ?? si ce n'est pas pour le FUN.. alors expliquez moi, je ne vois pas l'intérêt de perdre autant de temps à faire ce genre de bêtise, surtout quand la plupart des personnes qui vous font vivre (oui ils achètent/vendent sur addons et leurs clients aussi)

vous mettent en garde contre cette énorme bourde à ne pas commettre et recommandent plutôt de finir ENFIN la 1.6 et régler les soucis qui vous ont été remontés au fil des années.

Share this post


Link to post
Share on other sites

Franchement comme vous je félicite le travail des dev en effet comme divine atch etc.

 

Par contre, vous etes vraiment bien naif et bien francais (desolé du terme) pour croire que c'est grâce à 5 Dev freelance que prestashop existe encore.

Même sans vous cette entreprise à de l'avenir.

 

Vous n'êtes pas (plus) une communauté depuis bien longtemp, c'est finis le temps de OSCommerce, reveillez vous.

Ce qui compte c'est l'argent point final et à chaqu'un de se débrouiller pour en gagner, l'entraine n'existe plus et n'a pas d'avenir

 

Vous êtes 5 personnes à parler que la 1.7 va tuer prestashop, vous vous trompez, et pour information rappellez vous que la France n'est pas et est très très loin d'etre le centre du monde.

 

Donc vive l'évolution, et allez y, travaillez sur cette 1.7 et peut importe de quelle maniere elle va sortir car dans tout les cas elle s'adapterera aux règles de l'évolution d'internet car les enjeux financiers sont importants.

 

d'ailleurs histoire de mettre un peu le feu, une date de sortie provisionnel en vue ? qq pensé au 2 juin mais c'est passé.

Edited by Deasy-Oak (see edit history)

Share this post


Link to post
Share on other sites

Franchement comme vous je félicite le travail des dev en effet comme divine atch etc.

 

Par contre, vous etes vraiment bien naif et bien francais (desolé du terme) pour croire que c'est grâce à 5 Dev freelance que prestashop existe encore.

Même sans vous cette entreprise à de l'avenir.

 

Vous n'êtes pas (plus) une communauté depuis bien longtemp, c'est finis le temps de OSCommerce, reveillez vous.

Ce qui compte c'est l'argent point final et à chaqu'un de se débrouiller pour en gagner, l'entraine n'existe plus et n'a pas d'avenir

 

Vous êtes 5 personnes à parler que la 1.7 va tuer prestashop, vous vous trompez, et pour information rappellez vous que la France n'est pas et est très très loin d'etre le centre du monde.

 

Donc vive l'évolution, et allez y, travaillez sur cette 1.7 et peut importe de quelle maniere elle va sortir car dans tout les cas elle s'adapterera aux règles de l'évolution d'internet car les enjeux financiers sont importants.

 

d'ailleurs histoire de mettre un peu le feu, une date de sortie provisionnel en vue ? qq pensé au 2 juin mais c'est passé.

Ah ces maudits français !!!!

 

Franchement que viens tu encore chercher ici, tes précédents  bannissements du forum ne ton pas mis du plomb dans la tête ? (je prends pas trop de risque en disant cela puisque tu n'as pas changé de discours concernant des pauvre français qui ne comprenne rien ... pourtant PrestaShop est français et toujours là malgré notre attitude à te croire)

 

Je ne te connais pas, mais pour venir critique tu es champion et sinon c'est qui qui a la plus grosse, car seul ça semble te faire "jaser" dans ta vie.

 

Nous nous permettons de critiquer PrestaShop car oui, nous connaissons et nous les connaissons personnellement donc on dit les choses en face sans couverture marketing pour satisfaire le moindre égo. Lorsque c'est bien on le dit, lorsque c'est con, on le dit. et toi tu te détend à quel moment pour vomir ta haine du français ?

Share this post


Link to post
Share on other sites

C'est dingue à quel point ça peut t'énerver ?
Je n'ai jamais été bannis du forum mon cher ami pour ton information.

Ceux qui gènes ne sont pas les moins actifs crois-moi.

Tu penses encore que je suis nouveau franchement ?

À chaque MAJ 1.4 puis 1.5 puis 1.6 c'est toujours la même histoire, les DEV viennent dire qu'ils n'en peuvent plus, qu'ils vont arrêter, ne plus revenir sur le forum ben à chaque fois, même 2 ans après vous revenez.
C'est assez drôle car si on reprend le forum pour la 1.6 c'est exactement pareil.

Mais parlons maintenant financier car oui ce point vous énerve Mediacom.
Qu'en est-il de la progression financière de prestas hop depuis la 1.5 ? tout simplement une belle augmentation en matière d'effectif et de CA.
Les chiffres sont là, point.

Donc on en reparlera mi-2017 mais cette superbe 1.7 qu'elle s'appelle d'ailleurs 1.7 ou 1.8 l'évolution de prestashop n'est pas terminé et loin de la et c'est franchement par ICI que se joue l'avenir de prestashop avec vos réponses qui de toute façon n'ont aucun impact.

 

Pourtant vous devez vous en rendre compte que ca n'a aucun impact ?

Tout le monde le dis et ca depuis 2006, on monte un bug en forge mais rien pas de MAJ

Pourtant vous avez pris du temp à le faire, trouvé le bug etc.

Bla bla bla bla.. les forums et même celui-ci est uniquement construit pour discuter.. pas pour prendre des decision dans une entreprise pour laquelle vous n'avez pas de part social.

Share this post


Link to post
Share on other sites

C'est dingue à quel point ça peut t'énerver ?

Je n'ai jamais été bannis du forum mon cher ami pour ton information.

Ceux qui gènes ne sont pas les moins actifs crois-moi.

Tu penses encore que je suis nouveau franchement ?

À chaque MAJ 1.4 puis 1.5 puis 1.6 c'est toujours la même histoire, les DEV viennent dire qu'ils n'en peuvent plus, qu'ils vont arrêter, ne plus revenir sur le forum ben à chaque fois, même 2 ans après vous revenez.

C'est assez drôle car si on reprend le forum pour la 1.6 c'est exactement pareil.

Mais parlons maintenant financier car oui ce point vous énerve Mediacom.

Qu'en est-il de la progression financière de prestas hop depuis la 1.5 ? tout simplement une belle augmentation en matière d'effectif et de CA.

Les chiffres sont là, point.

Donc on en reparlera mi-2017 mais cette superbe 1.7 qu'elle s'appelle d'ailleurs 1.7 ou 1.8 l'évolution de prestashop n'est pas terminé et loin de la et c'est franchement par ICI que se joue l'avenir de prestashop avec vos réponses qui de toute façon n'ont aucun impact.

 

Pourtant vous devez vous en rendre compte que ca n'a aucun impact ?

Tout le monde le dis et ca depuis 2006, on monte un bug en forge mais rien pas de MAJ

Pourtant vous avez pris du temp à le faire, trouvé le bug etc.

Bla bla bla bla.. les forums et même celui-ci est uniquement construit pour discuter.. pas pour prendre des decision dans une entreprise pour laquelle vous n'avez pas de part social.

Ah merde en 2006 je n'étais pas sur les bancs de l'école avec BL pour commencer à imaginer le projet PrestaShop, c’est peut être là mon erreur.

 

C'est vrai, PrestaShop n'a mis que 4 ans à commencer à intégrer Synfony après en avoir discuter, ils prennent leur temps.

 

Toute les discutions sur PrestaShop sont intéressantes, mais pourquoi critiquer en permanence les français, je ne pige pas bien, c’est comme dire que tous les musulmans sont terroristes, tous les anglais des homosexuels ou tous les américains des ... américains, c'est juste débile.

 

Si vous ne souhaitez pas discuter et juste cracher un venin sur telle ou telle chose, autant ne pas venir ici, c’est pas un défouloir pour se libérer de certaines frustrations.

Share this post


Link to post
Share on other sites

@Deasy-Oak : vous êtes inscrits sur le forum depuis quelque mois, vous avez à peine 30 messages et à vous lire on pourrait croire que vous avez un "vécu" sur le forum...

 

Vous ne faites qu'enfoncer des portes ouvertes et énerver les gens avec des réflexions bateau et un comportement des plus désagréables.

 

J'ai déjà été contraint de fermer votre sujet https://www.prestashop.com/forums/topic/545015-recherche-dev-pour-qq-ligne-de-code-a-faire/ à cause de la tournure que ça prenait, si vous continuer sur cette lignée, la solution sera vite trouvée.

 

Pour info, et je ne suis pas le seul à le penser et à le dire, la 1.4 était une bonne version, la 1.5 beaucoup moins bonne, et la 1.6 est une très bonne version. Quand à la 1.7, elle est actuellement en beta et non fonctionnelle. 

Share this post


Link to post
Share on other sites

Bonjour,

Ben moi, je felicite le travaille effectué. Je suis pas du tout "pro" en ce domaine, mais chaque fois que j'ai eu besoin d'aide j'ai eu réponse.
j'etais sur la 1.4(.6) qui était extra et j'ai dû changé pour la 1.6 (cause des themes mobile) 
et j'attend la 1.7 en version opérationnelle.

Tout ca pour dire, que : la critique est facile, l'art l'est beaucoup moins . Donc au dev continuez votre travail, et faites nous une belle version, bien fonctionnelle (et encore plus simple d'utilisation)

 

Cordialement,

Share this post


Link to post
Share on other sites

Et ben qu'elle ambiance ce week-end sur ce post !!!!!!

 

Je ne peux accepter les paroles de certains, par contre une chose reste réelle, les erreurs d'arrondies et de calcul de TVA.

 

Jamais résolu depuis la 1.3, alors les nouvelles versions et betas c'est bien jolie, mais qu'elle va encore être le résultat ?

 

Et ce qui est surtout dommage, c'est que j'avais mis à disposition des DEV de Presta une copie de la boutique pour qu'il regarde ce que cela donnait, mais jamais une réponse à ma proposition. La sourde oreilles Presta fait !!! Presque du déni.

 

Un vrai gachis

Share this post


Link to post
Share on other sites

Bonjour,

 

Je me pose la question de savoir si il sera possible de créer des modules compatibles 1.6.x ET 1.7.x. Pour le moment je n'ai pas trouver de réponse.

 

Pour exemple :

 

fetch(module:modulename/views/template.tpl) ne sera à priori pas reconnu par la 1.6 ainsi que la nouvelle methode de traduction , etc.

 

Comment faire dans ce cas la ?

 

Bonne journée. Je vous souhaite le meilleur pour cette nouvelle version.

 

 

Edit : rajouter bcp de if (version_compare(_PS_VERSION_, '1.7.0.0', '>')) ? :)

Edited by billy boy (see edit history)

Share this post


Link to post
Share on other sites

 

Je me pose la question de savoir si il sera possible de créer des modules compatibles 1.6.x ET 1.7.x. Pour le moment je n'ai pas trouver de réponse.

 

Pour exemple :

 

fetch(module:modulename/views/template.tpl) ne sera à priori pas reconnu par la 1.6 ainsi que la nouvelle methode de traduction , etc.

 

 

Edit : rajouter bcp de if (version_compare(_PS_VERSION_, '1.7.0.0', '>')) ? :)

 

Oui c'est possible. Le mieux c'est vriament de maintenir 2 templates differents, 1 pour la 1.6 avec des |escape:HTML:UTF8 notamment et un template plus clean pour la 1.7.

Il suffit d'avoir 2 dossiers /views/templates/1.6/front/xx et /views/templates/1.7/front/xxx.

 

Pour le system de traduction, on a maintenu la compatibilité le $this->l() donc à mon avis, le mieux c'est de ne pas utiliser le nouveau systeme de traduction si tu veux module compatible 1.6 et 1.7.

 

Ensuite tu peux quand meme utiliser le system de widget en créant les 2 methodes requises pour faire un widget (getWidgetVariables et renderWidget) et ensuite appeler ces methods dans les methods hookDisplayXxx. Par contre, il ne faut pas implementer l'interface PHP puisqu'elle n'existe pas en 1.6

https://github.com/PrestaShop/docs/blob/master/module/widget.rst

 

 

J'ai ajouté une page todo dans la doc basé sur tes remarques. https://github.com/PrestaShop/docs/blob/master/module/module-backward-compat.rst

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour mes connaissances j'ai voulu faire un test :

 

Je clone la branch develop 

Je lance composer install 

Tout ce passe bien mes dossiers vendors, modules ... sont bons désormais, je config la db smtp ... ... ça passe

 

Par contre j'ai un FO vide et pas d'accès aux modules ( d'ailleurs aucun installé )

 

Je me loupe où ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour mes connaissances j'ai voulu faire un test :

 

Je clone la branch develop 

Je lance composer install 

Tout ce passe bien mes dossiers vendors, modules ... sont bons désormais, je config la db smtp ... ... ça passe

 

Par contre j'ai un FO vide et pas d'accès aux modules ( d'ailleurs aucun installé )

 

Je me loupe où ?

Oui mais est ce que cela fait l'installation de PrestaShop ou seulement la mise en place des fichiers ?

Share this post


Link to post
Share on other sites

L'installation est faite car les tables sont remplies, les articles de test sont là ...

 

Edit

 

Oups j'étais pas à jour ....

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

A quand la nouvelle version 1.7 ? peut-on avoir un ordre d'idée SVP environ 2 mois , 6 mois ?

 

Merci d'avance

Share this post


Link to post
Share on other sites

Bonjour,

 

A quand la nouvelle version 1.7 ? peut-on avoir un ordre d'idée SVP environ 2 mois , 6 mois ?

 

Merci d'avance

 

Pour le moment l'objectif est "Automne 2016", j'ai rien de plus précis. C'est pour démarrer un projet?

Share this post


Link to post
Share on other sites

Comme on n'a pas eu d'hiver l'an dernier et que l'été a été long à arriver .....  :)

Share this post


Link to post
Share on other sites

Bonjour Julien,

 

Merci pour ta réponse, en effet j'attends la nouvelle version pour lancer mon projet ! 

 

Au moins j'ai une petite idée ...

 

Bonne continuation

  • Like 1

Share this post


Link to post
Share on other sites

En même temps, l'automne commence dans à peine plus de 3 semaines...

Share this post


Link to post
Share on other sites

Bonjour à toutes et à tous !

 

Nous avons sorti la version RC0 de PrestaShop 1.7.0.0 lundi dernier : http://build.prestashop.com/news/prestashop-1-7-RC0/

 

Merci pour vos tests et retours, particulièrement sur la création de thème et la mise à jour de modules 1.6 !

 

Salut,

 

J'ai l'impression de régresser coté fonctionnalité  front office :( 

il est où le module "theme confirgurator" qui permettait d'uploader des images sur le front via quelques hooks et de permettre au client d'avoir plusieurs variantes de son theme ?

 

j'ai l'impression qu'il y a moins de fonctionnalités front office qu’auparavant ... Peut être qu'une impression...

 

V++

 

Atch

Share this post


Link to post
Share on other sites

j'ai l'impression qu'il y a moins de fonctionnalités front office qu’auparavant ... Peut être qu'une impression...

 

 

des fonctionnalités comme :

- mode list/grid sur la page catégorie

- achat d'un produit depuis la page catégorie en 1 clic

 

?

Share this post


Link to post
Share on other sites

Ces exemples sont des choix UX pour notre theme par default mais tout reste faisable dans votre theme.

 

Par contre on a effectivement supprimé quelques features, comme la carte google maps sur la pages stores.

 

(note: on a remis catalog et b2b que très récemment)

Edited by Julien Bourdeau
oops ^ ^ (see edit history)

Share this post


Link to post
Share on other sites

Et dire que quand je parle français sur le Forum Anglais on supprime mon post :ph34r: ... bon comme pour le module mailalert disparu de la 1.6.1.6

 

Sinon j'ai installé la version RC0 : 

 

Problème avec php 5.6.24 obligé d'ajouter le dossier dev ( open_basedir ) random_compat AdminProductController

Pas de problème avec php 7.0.9 logique

 

Sinon est ce que dans le future on trouvera de nouveau les anciennes variables smarty ou je dois remplacer :

$img_ps_dir

par 

$urls.img_ps_url

....

 

Edit : Réponse ici : https://github.com/PrestaShop/docs/blob/master/module/migrating-from-16.rst


Je n'ai pas trouvé la correspondance à : priceDisplay et ConvertPrice mais je dois pas ouvrir assez les yeux

 

Sinon module basqiue avec Model, Front Controller et Admin Controller fonctionne j'ai juste un problème de tab dans l'admin.

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Those examples were UX choices for our default theme, it's still totally doable in your themes.

 

We did drop some stuff like Google Maps on store pages tho.

 

(note: catalog and b2b have been done very recently)

 

Du coup, de base Prestashop proposera moins de modules front office et surtout aucune nouveauté à part le tunnel de commande ( toujours coté front j'entends) :(

La gestion d'images et de contenus aurait été un vrai plus dans cette version... Opencart est vraiment mieux loti de ce coté..

Je suis vraiment paumé sur les avantages de cette version 1.7 ( Faire moins avec plus ---> peut être une nouvelle formule de geek)

 

Finalement, cette version 1.7, fera le bonheur d'addons Prestashop :)

V++

 

Atch

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Finalement, cette version 1.7, fera le bonheur d'addons Prestashop :)

C'est pas moi qui le dit cette fois ...

 

Comme je l'ai déjà expliqué il y a des années, il a des façons correcte d'imposer sa marque sur tous les autres et il y a des méthodes plus sournoises. Après j'ai pas le droit de cracher dans la soupe et critiquer les pratiques douteuses de PrestaShop depuis des années puisque je gagne de l'argent avec mon expertise PrestaShop (bim 1 semaine de plus lol).

 

Mais je rassure tout le monde.

 

Tout ce que fait PrestaShop n'est que pour le bien être de ses utilisateurs.

Share this post


Link to post
Share on other sites

Class Tabs.php

    public function delete()
    {
        if (Db::getInstance()->execute('DELETE FROM '._DB_PREFIX_.'access WHERE `id_tab` = '.(int)$this->id) && parent::delete()) {
            $slug = 'ROLE_MOD_TAB_'.strtoupper($this->class_name);

            foreach (array('CREATE', 'READ', 'UPDATE', 'DELETE') as $action) {
                Db::getInstance()->execute('DELETE FROM `'._DB_PREFIX_.'authorization_role` WHERE `slug` = "'.$slug.'_'.$action.'"');
            }
            
            if (is_array(self::$_getIdFromClassName) && isset(self::$_getIdFromClassName[strtolower($this->class_name)])) {
                self::$_getIdFromClassName = null;
            }
            return $this->cleanPositions($this->id_parent);
        }
        return false;
    }

Il y a plus d'id_tab dans la table access

  • Like 1

Share this post


Link to post
Share on other sites

J'ai un module "question sur un article : "

 

Affichage d'un bouton question + formulaire (avant hookDisplayLeftColumnProduct ) 

Affichage des questions et des réponses  (avant hookDisplayFooterProduct ) 

 

Du coup maintenant dans renderWidget ont fait des conditions sur $hookName ? Ou on garde les méthodes displayHook ?

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

perso j'ai pas compris l’intérêt d'utiliser widget (exemple {widget name="socialsharing"} ) par rapport à un hook (exemple {hook h="socialsharing" id_product=$product.id_product})

Share this post


Link to post
Share on other sites

Tu le mets ou tu veux dans les tpl sans avoir à déclarer le hook et accrocher le module ensuite.

Share this post


Link to post
Share on other sites

Les widgets ça ne permet pas d'"instancier" plusieurs fois le module également ?

Share this post


Link to post
Share on other sites

Tu le mets ou tu veux dans les tpl sans avoir à déclarer le hook et accrocher le module ensuite.

 

ou je veux : comme un hook,

 

et sans avoir à le greffer : autrement dit ça évite juste de rajouter $this->registerHook('socialsharing') 

 

je trouve ça léger, d'autant plus que ce n'est pas compatible avec la 1.6, du coup si on veut un module compatible 1.6 et 1.7 il faut passer par un hook.

 

Merci okom3pom pour tes réponses, je me pencherai plus tard sur ces widgets

Share this post


Link to post
Share on other sites
Guest

en regardant le page du blog donné plus haut par Xavier, on peut lire ce commentaire :

 

 

Ahmed Abderraham • 2 days ago
=> If you didn't have 200+ open issues on github and thousands of outstanding extra open issues in the forge, I would probably bother testing 1.7. Sadly, not the way you handle it right now, sorry.

I still have an 8 month old open issue for the 1.6 version for which I also provided a PR on github. It's an eight lines change in a tpl file fixing a regression bug, and it's still there waiting. I understand 1.7 has been the priority and all that jizz, but people is actually _using_ 1.6, so they get tired of unfixed bugs and look for alternatives.

On the contrary, arround 1 month ago I sent a pull request to another WordPress-based e-commerce system and it was merged to master in 10 hours (yes, ten hours) and shipped with the following released version. That's how you do it and how you make people to give feedback and help.

And just as a side note, and I'm sorry if this sounds harsh, but whoever took the decision to only transition to Symfony/Twig for two backend pages should be instantly fired. Probably the worst technical decision I've seen in an open source project.

    Krystian Podemski Ahmed Abderraham • 2 days ago
    => Well, this comment ideally sums up everything what is going with PrestaShop in recent months.

 

 

ça veut dire quoi la passage concernant twig et symphony pour seulement 2 pages du backoffice ??? quelqu'un ayant testé cette version pourrait m'expliquer ça svp ?

Edited by Guest (see edit history)

Share this post


Link to post
Share on other sites

Sinon est ce que dans le future on trouvera de nouveau les anciennes variables smarty ou je dois remplacer :

$img_ps_dir
par 

$urls.img_ps_url
....

 

Edit : Réponse ici : https://github.com/PrestaShop/docs/blob/master/module/migrating-from-16.rst

 

Je n'ai pas trouvé la correspondance à : priceDisplay et ConvertPrice mais je dois pas ouvrir assez les yeux

 

Effectivement tout l'intérêt de pouvoir casser la compat' était de pouvoir réorganiser tout ce qui est passé à Smarty et d'éviter les globales dans tous les sens. Toutes les URLS sont maintenant dans `$urls` et si besoin il y a un helper smarty {url}.

 

Pour les fonctions sur les prix, elles ont été retiré du front (toujours dispo pour les PDF et l'Admin). Normalement les prix sont sensés arrivés dans la bonne currency et formatée.

Si tu veux ajouter des trucs dans ton module et l'assigner dans smarty, tu peux le formaté coté PHP. Je t'encourage même à créer un presenter.

 

Sinon module basqiue avec Model, Front Controller et Admin Controller fonctionne j'ai juste un problème de tab dans l'admin.

Normalement ca marche exactement de la même manière.

Share this post


Link to post
Share on other sites

J'ai un module "question sur un article : "

 

Affichage d'un bouton question + formulaire (avant hookDisplayLeftColumnProduct ) 

Affichage des questions et des réponses  (avant hookDisplayFooterProduct ) 

 

Du coup maintenant dans renderWidget ont fait des conditions sur $hookName ? Ou on garde les méthodes displayHook ?

L'interet d'utiliser render widget c'est pouvoir hooker ton module sur un autre hook, y compris un hook custom d'un theme: hookDisplayProductDescriptionAfter par exemple.

Si tu gardes la fonction hookxxx ton module ne marchera QUE sur le hook qui porte tres exactement ce nom.

Du coup je vois pas trop de bonne raison de ne pas utiliser renderWidget ^^

Share this post


Link to post
Share on other sites

ou je veux : comme un hook,

 

et sans avoir à le greffer : autrement dit ça évite juste de rajouter $this->registerHook('socialsharing') 

 

je trouve ça léger, d'autant plus que ce n'est pas compatible avec la 1.6, du coup si on veut un module compatible 1.6 et 1.7 il faut passer par un hook.

 

Merci okom3pom pour tes réponses, je me pencherai plus tard sur ces widgets

Il faut bien comprendre les differents scénarii.

 

 

Tu hook ton module sur un hook connu (genre displayLeftColumn) et tu geres le cas dans renderWidget() donc l'utilisateur final peut utiliser ton module sur n'importe quel hook.

Tu peux même faire du preg_match sur le hookname, par exemple le comportement different sur un hook qui contient "column" ou "footer". Il faut quand meme toujours un comportement par defaut.

 

Pour gerer la compat' avec un module 1.6, le mieux c'est de definir les methodes hookDisplayxxx qui fait un simple appel à renderWidget avec les bons parametres

NOTE: Du coup tu ne peux pas implémenter l'interface puisqu'elle n'existe pas en 1.6. Il faut faire les methodes mais sans le "implement".

 

 

Dans ton theme tu peux definir des hooks custom pour rajouter des features. En 1.7 c'est cool grace aux widget, en 1.6 il te faudra des modules compatibles (donc que les tiens avec une methode hookDisplayCustomxxx() )

 

 

Ensuite pour le {widget name="socialsharing"}: l'intéret c'est de pouvoir placer un module n'importe ou dans un theme.

 

Ca ne crée pas de hook, ça appelle juste le module. C'est une feature qui est destiné aux marchants qui font un peu de custom eux meme ou des agences qui font un theme pour un client.

Il vaut mieux l'éviter pour un theme Addons puisque ca n'est pas personnalisable dans la page module position, il faut forcement passer par le code.

Share this post


Link to post
Share on other sites

Du coup, de base Prestashop proposera moins de modules front office et surtout aucune nouveauté à part le tunnel de commande ( toujours coté front j'entends) :(

La gestion d'images et de contenus aurait été un vrai plus dans cette version...

Je veux bien des exemples précis stp. On a porté tous les modules les plus utiles.

 

 

On ne peut pas tout faire dans une version! Si on a viré des modules comme themeconfigurator ou blockstores c'est justement parce qu'on voudrait refaire un système beaucoup plus simple et puissant.

Par exemple blockstores, editorial et tout un tas d'autres modules similaires peuvent etre remplacer un module de contenu. Il faut aussi cette fameuse feature de hooker un module plusieurs fois sur le meme hook.

 

L'intéret de cette 1.7 c'est poser des bases pour le futur. Refaire live edit ou la gestion du contenu sera beaucoup plus simple avec ces bases saines.

Share this post


Link to post
Share on other sites

L'intéret de cette 1.7 c'est poser des bases pour le futur. Refaire live edit ou la gestion du contenu sera beaucoup plus simple avec ces bases saines.

moins complète que la 1.6 et une base pour l'avenir, c'est donc que c'est une version intermédiaire ?

  • Like 1

Share this post


Link to post
Share on other sites

Je veux bien des exemples précis stp. On a porté tous les modules les plus utiles.

- Themeconfigurator ( gestion images et textes sur 5 hooks)

- Dans la meme catégorie ( page produit)

- Crosseling ( Page produit et panier)

- Mail alert ( Page produit)

- Commentaires clients ( page produit )

- Point de fidèlité ( produit et panier)

- Produit favoris

- Wishlist

 

J'ai pas l'impression que se soient des modules inutiles...

 

Gamefication ça c'est inutile :)

 

 

L'intéret de cette 1.7 c'est poser des bases pour le futur.

Je l'entends bien coté développeur, mais coté e-commerçants ? pourquoi utiliser un Prestashop de moins en moins complet nativement...

 

je vois mal le ecommerçant en 1.6 migrer vers une 1.7 pour devoir acheter sur addons tous les modules natifs de sa 1.6...

 

V++

 

Atch

Edited by Atch (see edit history)
  • Like 3

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai vu la nouvelle version de votre site, c'est super mais ou sont mes points de fidélité ?

 

Merci de votre compréhension. 

 

Share this post


Link to post
Share on other sites

Pour les fonctions sur les prix, elles ont été retiré du front (toujours dispo pour les PDF et l'Admin). Normalement les prix sont sensés arrivés dans la bonne currency et formatée.

 

Bonjour Julien,

 

Donc en utilisant seulement la variable $product.price par exemple dans un module, le prix est supposé être affiché formaté et avec la bonne devise ?

Parce que de mon côté ce n'est pas trop le cas.

 

Au passage ça serait bien que le nouveau module newsletter affiche des alertes plus visibles en haut de la page comme l'ancien.

Les alertes directement sous le champ du module ne sont pas assez visibles, surtout que le module est greffé dans le footer.

Share this post


Link to post
Share on other sites

Tu dois le formater dans le php de ton module. La tu as la colonne price brute si tu as juste récupéré le champs dans la base.

 

Tu trouveras ton bonheur sur les prensenter dans le module ps_featuredproduct

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Je n ai pas comprit cette partie :

 

Make sure you use the new way of calling templates:fetch(module:modulename/views/template.tpl).

Share this post


Link to post
Share on other sites

Tu dois le formater dans le php de ton module. La tu as la colonne price brute si tu as juste récupéré le champs dans la base.

 

Tu trouveras ton bonheur sur les prensenter dans le module ps_featuredproduct

 

Merci je vais jeter un oeil.

Share this post


Link to post
Share on other sites

Bonjour, petit question comment on installer une version beta ? j'ai essaie d'utilise 1 click update mais je n'arrive pas. Merci de votre aide 

Share this post


Link to post
Share on other sites

Bonjour,

 

Cette version à l'air assez cool sur le papier, même si je pense pas qu'on soit tous comblés, hélas ..

Néanmoins, j'aimerais savoir pourquoi cette fonctionnalités, essentiels selon beaucoup de développeur et surtout de marchand ne sont toujours pas disponible nativement.

Je veux parler de modules comme "Meilleures ventes par fabricants" ou "Meilleures ventes par catégories" .. ces deux modules sont juste essentiels pour le business, c'est dommage de devoir mettre la main au porte-monnaie pour l'obtenir alors que nous avons pas mal de modules natif qui ne sont pas utiles ^^"

 

Merci beaucoup :)

Share this post


Link to post
Share on other sites
Bonjour,

 

J'aime beaucoup ce feed. Tout le monde s'exprime, c'est bien. De mon côté, si toutes les avancées prévues dans la 1.7 sont au rendez-vous, je dis : très bien ! Parce qu'en effet beaucoup de bogues sont issus de problèmes dans le core  / la BD et sont irréparables en l'état. Bilan, la 1.6 risque de ne pas rester dans les annales. Faites juste que la 1.7 soit un bon cru.

 

Moi je veux juste faire part d'une expérience récente. Quand on est développeur, c'est assez facile d'aller modifier un truc à droite à gauche, voire de corriger un bogue. Quand on n'est pas freelance ou intégrateur Prestashop, on n’a pas trop d'intérêt à forcément le partager avec la communauté. Il faut être honnête partager un truc avec la communauté prend plus de temps que ne pas le faire (github pull request et compagnie). Donc, en juin (si ma mémoire est bonne) je me suis dis : « tient, je vais essayer de partager ceci ou cela ». Je m'y reprends à plusieurs fois et là au bout d'un moment ma proposition est rejetée car elle n'est pas conforme PSR-2. Il y a 6 lignes de code en tout et une accolade à déplacer. Attendu, que vous avez plus la main que nous sur Git, ça vous aurait pris 2 fois moins de temps qu'à moi de le corriger. Bilan, entre-temps j'étais passé à autre chose et j'ai laissé tomber.

 

Que le code de Prestashop respecte un standard, je suis pour. Que l'équipe de dev s'y conforme ça me semble fondamental, même s’il faut être honnête, les gens ne sont pas des machines et je suppose qu'ils leur arrivent à eux aussi d'oublier une virgule (les lendemains de soirée entre autres). Par contre là, c'est un peu comme si vous disiez à un étranger qui fait une cuisine honnête qu'il ne peut pas être bénévole pour les restos du coeur sous prétexte qu'il ne parle pas parfaitement français.

 

C'est juste un témoignage, ça n'attend pas particulièrement de réponse. Et globalement : courage ! continuez !

  • Like 3

Share this post


Link to post
Share on other sites

El Pipo > franchement après un tres bon message comme le tiens, j'espère que les oreilles vont s'ouvrir mais je pense que ca ne changera pas tellement.

 

En tout cas merci, même si tu n'attends pas forcement de réponse sache que c'est très appréciable comme message, tu a touché LA corde sensible de github qui a mon sens aussi est trop fermé (et c'est peut etre voulu d'ailleurs.)

 

Bonne soirée,

Share this post


Link to post
Share on other sites