Jump to content

Recommended Posts

Hallo allemaal,

 

ik probeer SSL te implementeren voor een klant en wil daarom SSL aanzetten in de Prestashop 1.5 BO.

 

Als ik dat doe, krijg ik alle vreemde resultaten:

 

* toevoegen aan de winkelwagen werkt niet meer, omdat het formulier onveilig zou zijn (zegt Firebug)

* productpagina's raken in een loop en blijven forwarden naar de HTTP-variant van de pagina

* de PDF-aanmaak van factuur en pakbon kan de juiste plaatjes niet meer vinden

etc.

 

 

 

/classes/PaymentModule.php (meerdere regels)

/classes/Link.php (regel 99)

/classes/shop/Shop.php (regel 345)

/classes/Tools.php (regel 203)

etc.

 

Kan dit de oorzaak zijn van alle problemen? En zo ja, waarom zouden de makers deze verwijzingen hardcoded hebben geprogrammeerd (en een hoop andere verwijzingen weer niet)? Is niet handig, toch?

 

Cheers,

 

Cees

 

 

Share this post


Link to post
Share on other sites

Ik snap niet zo goed wat je bedoelt met "de webserver daarvoor niet goed aangeeft welk protocol wordt gebruikt"?

 

Je bedoelt dat Apache niet het juiste protocol doorgeeft? Dat zou niet uit moeten maken, de browser van de gebruiker doet dat wel, toch?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More