Jump to content

Modulo Partita Iva Europea Non Mostra Campo


Madsex
 Share

Recommended Posts

Salve, 

come avrete capito da titolo ho installato il modulo partita iva europea. 

Ho letto in giro però che una volta abilitato il B2B in fase di registrazione ( quindi non nell'immissione degli indirizzi ), si dovrebbe inserire il nome dell'azienda e una volta inserito il campo iva appare sotto.

 

Tutto questo a me non succede da cosa potrebbe dipendere?

 

Attendo, grazie

 

PS: non funziona neppure nel template di default quindi immagino ci sia qualche opzione da attivare o roba simile.Grazie

Share this post


Link to post
Share on other sites

Ciao scusa il ritardo ma ho avuto un po' di problemi.

 

 

Ho provato il tuo suggerimento, più volte ma continua a non apparire la partita iva in fase di registrazione. Appare solo se vado ad inserire un nuovo indirizzo o ad aggiornare quelli esistenti.

 

Anche dal codice mi pare proprio che no ci sia il campo form predisposto ad accogliere la partita iva.

 

Non è che devo inserire nel template il campo?

 

Grazie in anticipo!

Share this post


Link to post
Share on other sites

Attivando la modalità b2b ti dovrebbe comparire in fase di registrazione la possibilità per il cliente di inserire il nome azienda, siret, ape e sito web eventualmente rinominabili da Traduzioni in Partita Iva o nel campo che vuoi, che poi tu puoi visualizzare nel dettaglio clienti dal BO.

Se vuoi invece far comparire i campi azienda e p.iva nell'indirizzo modifica il layout dell'indirizzo da localizzazioni, nazioni.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Ciao grazie della risposta.

Vedo una falla in questa soluzione ma potrei non aver capito nulla.

 

Vorrei che in fase di registrazione dove viene richiesta l'azienda venga anche richiesta la partita iva.

Se rinomino Siret o Ape e poi attivo anche la partita iva nella configurazione degli indirizzi ( la p.iva può cambiare o potrebbero volerla mettere successivametne ), non mi troverei poi due campi distinti e separati ( SIRET/APE rinominato e p.iva )? Inoltre ho comunque fatto una prova e se inserisco una partita iva nel campo siret o ape quest'ultima non viene validata, perchè pare non sia riconosciuta correttamente ( probabilmente siret e ape sono numeri diversi o non so ).

 

Ma se aggiungessi un input con id vat_number come stà nel form di modifica o immissione nuovi indirizzi?

 

Qualcuno ha provato?

 

Grazie

Share this post


Link to post
Share on other sites

  • 2 months later...

Ciao grazie della risposta.

Vedo una falla in questa soluzione ma potrei non aver capito nulla.

 

Vorrei che in fase di registrazione dove viene richiesta l'azienda venga anche richiesta la partita iva.

Se rinomino Siret o Ape e poi attivo anche la partita iva nella configurazione degli indirizzi ( la p.iva può cambiare o potrebbero volerla mettere successivametne ), non mi troverei poi due campi distinti e separati ( SIRET/APE rinominato e p.iva )? Inoltre ho comunque fatto una prova e se inserisco una partita iva nel campo siret o ape quest'ultima non viene validata, perchè pare non sia riconosciuta correttamente ( probabilmente siret e ape sono numeri diversi o non so ).

 

Ma se aggiungessi un input con id vat_number come stà nel form di modifica o immissione nuovi indirizzi?

 

Qualcuno ha provato?

 

Grazie

Ciao, 

hai trovato soluzione? ho lo stesso problema...

 

Su autentication.tpl ho tolto il "display:none" da tutti i campi vat-number ma il problema persiste.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More