Jump to content

Recommended Posts

Bonsoir à tous.

A 2 doigt d'aboutir à ce projet il me reste une dernière étape pour mettre en place ma boutique... le SSL !!

Je pensais que cela allais me prendre 2 minutes mais non...

Je ne comprend rien.

J'ai pris un certificat SSL chez 1&1;mais lorsque je veut l'activer celui-ci me donne l'URL suivante :
https://ssl.1and1.fr/dressroom.fr/

Le problème est que du coup, lorsque je veux accéder a une page sécurisé sur le site, Presta ne trouve pas la page, et si je modifie le fichier init.php pour modifier la base de l'URL SSL, mes pages sécurisé s'affichent mais sans les CSS !!

Il y a également dans 1&1;un certificat GeoTrust apparemment applicable sur 1 domaine, mais lorsque je veux configurer celui-ci, aucun de mes domaines s'affichent dans la liste de choix.


Quelqu'un a-t-il réussi a configurer son SSL sur Presta et 1&1;???

Share this post


Link to post
Share on other sites

Parce que Je m'y suis mis a 19h quand le centre d'appel fermait et que j'aimerai bien regler ce problème ce soir...

Sinon oui j'allais les appeler demain mais je ne sais pas si cela est lier à eux ou si il y a une manipulation à faire sur Prestashop.

C'est pour cela que je demande si certaines personnes utilise Prestashop avec le SSL de 1&1;sur un serveur mutualisé...

Share this post


Link to post
Share on other sites

Pour utiliser u n certificat SSL il faut qu'il soit certifié par un organisme genre geotrust at qu'il soit utilisé sur un hébergement ayant une adresse ip unique.

Tu peux retrouver toutes ces informations dans la FAQ de 1and1. tu n'as qu'à taper SSL dans le moteur de recherche de la FAQ.

Share this post


Link to post
Share on other sites
  • 1 month later...

Bonsoir,

J'ai un peu le même problème tel qu'il est décrit au début avec le certificat geotrust de 1&1;:

- après l'avoir activé, le paiement avec le module paypal me dit que ma communication n'est pas cryptée

- si je mets dans le fichier .htaccess, la redirection automatique en https (je ne dais pas trop si c'est quelque chose à faire?), alors là , ma première page s'affiche sans les css... comme décrit ci-dessus

Merci pour ceux qui vont comprendre!

François Echardel

Share this post


Link to post
Share on other sites

Effectivement, merci, le SSL n'était pas activé! (désolé pour cette méconnaissance)

Par contre, maintenant, j'ai bien le https des pages sécurisé, mais lorsque je demande le paiement paypal chez qui j'ai un compte, je reçois:

Détection d'erreur

Le vendeur accepte uniquement les paiements cryptés. Vous ne pouvez pas le payer par l'intermédiaire des boutons non cryptés. Veuillez contacter votre vendeur pour plus d'informations.
Le vendeur accepte uniquement les paiements cryptés. Vous ne pouvez pas le payer par l'intermédiaire des boutons non cryptés. Veuillez contacter votre vendeur pour plus d'informations.

Share this post


Link to post
Share on other sites

Oups... en fait, ,non, avec le ssl activé, j'obtiens:

- avec IE8, en lançant le bouton commander:

Le certificat présenté par ce site a été émis pour une autre adresse de site web

- avec Firefox ou Chrome: page introuvable ou message du même type

Je pense qu'il s'agit d'un problème avec le certificat et ma config hébergeur mais si ça parle à quelqu'un...

Merci

Share this post


Link to post
Share on other sites

Suite...

en fait, je peux passer outre l'avertissement mais j'obtiens toujours le message paypal me disant que ma transmission n'est pas cryptée!

Share this post


Link to post
Share on other sites
  • 5 months later...

Bonjour

Je tombe sur votre post.

Avez vous avancé sur vos problemes car j'ai les mêmes....

ma config :
Hebergeur 1&1;mutualisé.
Activé mon certificat sur prestashop
Activé le SSL dans prestashop
J'ai un Htaccess qui permet la gestion du php5 + reecriture d'url
Tout est renseigné dans la config du module Api Paypal.
Donc probleme d'affichage des images sur la chaine du paiement (CSS)
Et probleme de connexion API dans la trasnsaction

Merci, si vous avez un tuto propre pour activer l'api, je suis interessé cordialement

Share this post


Link to post
Share on other sites

J'ai laissé tombé ce problème en désactivant le SSL sur le site ce qui n'est finalement pas très utile car seule le cryptage au niveau du prestataire de paiement est important.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More