[MODULE] jGalleryView - version 2 - Page 3 - Free Modules & Themes - PrestaShop

Jump to content

Photo

[MODULE] jGalleryView - version 2

#41

Posted 22 March 2010 - 08:34 AM

Tropical Dream

    PrestaShop Apprentice

  • Members
  • PipPip
  • 151 Active Posts
Prestashop 1.2.4 installed.

mozilla firefox, no problem. It works.

- in internet explorer 6, the slides are not changing. It gets stuck on the fading transition filter. Also, I cannot click on the thumbnails below the picture, they do not click as if there was something blocking them.

- internet explorer 8, the slides change BUT, I cannot click on the thumbnails, they simply do not activate when I click on them. Also, captions are not transitioning properly. Caption Ad2 gets written over Caption Ad2 which then gets written over by Caption Ad3. The old captions do not disappear before a new caption gets added, so it makes the text unreadable.

- In the .tpl, I tried to changed the size of the caption box "overlay_height:", but it's size does not change. If I put 3 lines of text, the third line gets chopped off by the thumbnails. I tried to make the caption box bigger but it doesn't work. Maybe I didn't know where to change it.

- in jgalleryview2.tpl, the function "pause_on_hover: false //", there is no comma after "false" is this a mistake?

Did anyone try it in internet explorer? tried to click the thumbnails? it's not working at all with me.

#42

Posted 23 March 2010 - 08:10 PM

Joël Gaujard

    PrestaShop Addict

  • Members
  • PipPipPip
  • 753 Active Posts
Hello Tropical Dream,

Thanks for your feedback !

Sorry i didn't try in internet explorer :-S
Can you help me with this ?

About the caption box size:
Change the size in jquery.galleryview/galleryview.css line 99
.panel .panel-overlay,.panel .overlay-background { height: 50px; padding: 0 0.5em; }


About javascript in jgalleryview.tpl
The property pause_on_hover: false haven't got comma because it's last one.
Previously developer at | Ancien développeur chez PrestaShop
Ingénieur/webdeveloper freelance
Visit PrestaPlayers

#43

Posted 24 March 2010 - 08:31 AM

Tropical Dream

    PrestaShop Apprentice

  • Members
  • PipPip
  • 151 Active Posts
ok! The .panel .overlay-background works. It changed my caption box correctly. thank you.

now for windows explorer, I really don't know what you should do. I'm new to CSS/PHP.
but I notice at line 84 of the CSS, there is a line that says: "/* TRANSPARENT BORDER FIX FOR IE6 */". I don't know if it has anything to do with it. Maybe you should remove the slide change fading filter that gets in the way of the buttons to click.

Internet explorer is important because it's still the most widely used browser. As it is your module is not usable in internet explorer :( What should we do?

No problem in Google Chrome, no problem in firefox, it works very well as it should.

#44

Posted 24 March 2010 - 07:58 PM

Weasel

    PrestaShop Apprentice

  • Members
  • PipPip
  • 30 Active Posts
WOW! Exactly what I was looking for!!

One little problem:

The box is cut off on the right side in the default theme, you can see the problem on the test site.

Can this be fixed? Where?

Thanks
K

#45

Posted 26 March 2010 - 08:55 AM

Joël Gaujard

    PrestaShop Addict

  • Members
  • PipPipPip
  • 753 Active Posts
Thanks Weasel for your feedback.

I correct box size on the module. The correction will be in the next release.
You just need to change width and height from JS parameter.

Regards,
Joel
Previously developer at | Ancien développeur chez PrestaShop
Ingénieur/webdeveloper freelance
Visit PrestaPlayers

#46

Posted 26 March 2010 - 10:19 AM

archproject

    PrestaShop Apprentice

  • Members
  • PipPip
  • 308 Active Posts

@ AntiKiste,
In this thread you can find how to solve your problem or wait next release.

@ ArchProject,
Open the tpl file. It's very easy to change.




Joel

I really can't find which one to change to make it just show and slide the 100x100 pictures I just want it to be looking like this

http://spaceforaname.../filmstrip.html


<!-- MODULE jGalleryview -->[removed][removed][removed][removed][removed][removed]<!--jGalleryview core stylesheet--><link rel="stylesheet" type="text/css" href="{$module_dir}assets/galleryview.css" /><!--jGalleryview template-->[removed][removed]<div id="galleryviewHolder" align="center" style="padding:0 0 10px 0;overflow: hidden; clear:both"><div id="wrap"><ul id=gallery><li><span class=panel-overlay>this is an overlay</span><img src="{$module_dir}slides/01.jpg"> <li><span class=panel-overlay>this is another overlay</span><img src="{$module_dir}slides/02.jpg"> <li><span class=panel-overlay>this is yet another overlay</span><img src="{$module_dir}slides/03.jpg"> <li><span class=panel-overlay>this is an overlay too</span><img src="{$module_dir}slides/04.jpg"> <li><span class=panel-overlay>this is an overlay</span><img src="{$module_dir}slides/05.jpg"> <li><span class=panel-overlay>this is another overlay</span><img src="{$module_dir}slides/06.jpg"> <li><span class=panel-overlay>this is yet another overlay</span><img src="{$module_dir}slides/07.jpg"> <li><span class=panel-overlay>this is an overlay too</span><img src="{$module_dir}slides/08.jpg"> </ul></div></div><!-- /MODULE jGalleryview -->

Using PS 1.5.6.2


#47

Posted 26 March 2010 - 04:39 PM

Aminou__

    PrestaShop Newbie

  • Members
  • Pip
  • 10 Active Posts
Hello,
good job! module looks good, that's exactly what I need.
I have a problem when installing the module, my slide show appears at the bottom of the page, what can I do?
Thank you

#48

Posted 26 March 2010 - 04:44 PM

Joël Gaujard

    PrestaShop Addict

  • Members
  • PipPipPip
  • 753 Active Posts
@Aminou
Thanks for your feedback.
What same problem do you have ? Tell me more about this.
If the module appear at the bottom of your homepage, you can easily change its positions in your Back office > Modules > Positions.

@archproject
I'll send you a PM.
Previously developer at | Ancien développeur chez PrestaShop
Ingénieur/webdeveloper freelance
Visit PrestaPlayers

#49

Posted 26 March 2010 - 04:58 PM

Aminou__

    PrestaShop Newbie

  • Members
  • Pip
  • 10 Active Posts
Thank you,
I did not know you could change the position of the modules,
I feel stupid:) but no problem ...
thank you again Joël

#50

Posted 28 March 2010 - 10:23 PM

benj0612

    PrestaShop Apprentice

  • Members
  • PipPip
  • 155 Active Posts
Joëlle,

I've got the problem you were talking about, I mean the cut off of the right side of a pix.

I've found a solution in firebug (in red, cf the pix attched) BUT, no information about were to find...

Thx a lot

B'

PS : i'm french

Attached Files


Bien-être de qualité en France

Massage, tatouage, relooking, soins du corps/du visage, balnéo, yoga, etc.

#51

Posted 29 March 2010 - 05:11 PM

Fabrice

    PrestaShop Fanatic

  • Moderators
  • 3274 Active Posts

Joëlle,

I've got the problem you were talking about, I mean the cut off of the right side of a pix.

I've found a solution in firebug (in red, cf the pix attched) BUT, no information about were to find...

Thx a lot

B'

PS : i'm french



Hi Benj !
You may change this information in the css (check jquery.galleryview/galleryview.css).

Fabrice - my-deco-shop.com

Le meilleur outil de gestion pour Prestashop que j'utilise - best tool I use: Store Commander

L'hébergeur de la boutique, top niveau (merci Pierre Alain, tu es trop fort !) : ooworx.com


#52

Posted 29 March 2010 - 05:14 PM

Fabrice

    PrestaShop Fanatic

  • Moderators
  • 3274 Active Posts
Hi!
Does anyone know where I can add the link to the main pictures ?

I could add the link to text (in Jgalleryview2.tpl), but impossible to find the code where to place a link to these main images displayed.

When I add the link to
{if $my_item->img}

it add's a link to the thumbnails. that's not what I need.

any suggestions ? :-)

Fabrice - my-deco-shop.com

Le meilleur outil de gestion pour Prestashop que j'utilise - best tool I use: Store Commander

L'hébergeur de la boutique, top niveau (merci Pierre Alain, tu es trop fort !) : ooworx.com


#53

Posted 29 March 2010 - 07:52 PM

Fabrice

    PrestaShop Fanatic

  • Moderators
  • 3274 Active Posts
Suggestion (also sent to Joël) :
- adding a tinyMce option would open the module to an entire different functionality : like for instance a good tool for promoting products, giving possibilities to add some colors and different sizes in the text. (and also linkable text) - is that possible ?

Fabrice - my-deco-shop.com

Le meilleur outil de gestion pour Prestashop que j'utilise - best tool I use: Store Commander

L'hébergeur de la boutique, top niveau (merci Pierre Alain, tu es trop fort !) : ooworx.com


#54

Posted 31 March 2010 - 03:29 AM

Raphael2010

    PrestaShop Apprentice

  • Members
  • PipPip
  • 56 Active Posts
very nice module and very easy to use!
I have also some issues, I want to move the arrows, i can do it under firebug, no problem, but i can t find in any css! it is inside element.style and nowhere to be found galleryview.css ( ca me rend chevre) same goes with the thumbnails i just want to remove them, no trouble with firebug BUT i can t see which line to erase in the tpl.

All i want to do is the keep the big slide with the arrow in the bottom right..... Does anyone can help me to spare the very last hair on my head, before i am completly bald?

thanks:D

#55

Posted 31 March 2010 - 11:58 PM

Raphael2010

    PrestaShop Apprentice

  • Members
  • PipPip
  • 56 Active Posts
nobody?:(

#56

Posted 01 April 2010 - 06:26 AM

Joël Gaujard

    PrestaShop Addict

  • Members
  • PipPipPip
  • 753 Active Posts
Hello everyone,

Thanks for yours interest, ideas, feedbacks...

@Raphael2010
If you want to display only panels and no filmstrips, you can easily change the javascript variable like this example : http://spaceforaname.com/panels.html

@Fabrice
Thanks for your suggestions. I'll write it in todo list.
For display main image of one of yours products, you can easily upload it in module configuration.

@benj0612
I already correct this in the project. You can have it right now on the SVN repository (browse SourceForge project space) or wait to next release.
PS: my name is JOEL and not "joelle" (it's the name for girl)


Help! I need some developers to enhance this module. Because i'm really busy at this time, so if someone can contribute to this module. It will be great.

Regards,
Joel
Previously developer at | Ancien développeur chez PrestaShop
Ingénieur/webdeveloper freelance
Visit PrestaPlayers

#57

Posted 02 April 2010 - 12:05 AM

Raphael2010

    PrestaShop Apprentice

  • Members
  • PipPip
  • 56 Active Posts
Hi, thanks for the reply and the website, i have read carefuly the website and to intend the effect desired, i must remove the following code
<ul class="filmstrip">    <li><img src="img/gallery/frame-01.jpg" alt="Effet du soleil" title="Effet du soleil"></li>    <li><img src="img/gallery/frame-02.jpg" alt="Eden" title="Eden"></li>    <li><img src="img/gallery/frame-03.jpg" alt="Snail on the Corn" title="Snail on the Corn"></li>    <li><img src="img/gallery/frame-04.jpg" alt="Flowers" title="Flowers"></li>    <li><img src="img/gallery/frame-06.jpg" alt="Alone Beach" title="Alone Beach"></li>    <li><img src="img/gallery/frame-05.jpg" alt="Sunrise Trees" title="Sunrise Trees"></li>    <li><img src="img/gallery/frame-07.jpg" alt="Waterfall" title="Waterfall"></li>    <li><img src="img/gallery/frame-08.jpg" alt="Death Valley" title="Death Valley"></li></ul>

so I must find the filmstrip class which is still nowhere to be seen:( even in the javascript jquery.easing and jquery.timers are used for smoothing the animation and the timing, and then jquery.galleryview is just a enormous file full of numbers and symbols, no way i can edit this thing by myself.

does anyone knows where to find this class to delete?

#58

Posted 02 April 2010 - 12:46 AM

Joël Gaujard

    PrestaShop Addict

  • Members
  • PipPipPip
  • 753 Active Posts
Hello Raphael,

This unordered list with class filmstrip not exists in module template. So no need to remove it ;)

I tested to display the gallery with only frames or captions but it doesn't work. I think because PrestaShop uses version 1.2.6 de jQuery instead of version 1.3.2. Sorry :(
Previously developer at | Ancien développeur chez PrestaShop
Ingénieur/webdeveloper freelance
Visit PrestaPlayers

#59

Posted 02 April 2010 - 01:07 AM

Joël Gaujard

    PrestaShop Addict

  • Members
  • PipPipPip
  • 753 Active Posts
A little message just to announce you release of version 1 (v.1.2.1). All informations and link are in first post.
Previously developer at | Ancien développeur chez PrestaShop
Ingénieur/webdeveloper freelance
Visit PrestaPlayers

#60

Posted 02 April 2010 - 02:33 AM

Raphael2010

    PrestaShop Apprentice

  • Members
  • PipPip
  • 56 Active Posts
Thanks for answering again! so it is now possible right now using that way, unless prestashop updates! wow! ok thanks a lot again!


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cookies help us deliver our services. By using our services, you agree to use our cookies.     Learn more