Jump to content
lhalda

[Solved] Customer Service Setup: "imap Is Not Installed On This Server"

Recommended Posts

I can't setup Customer Service, IMAP configuration fails to work. Once I save the config, a message "imap is not installed on this server" appears in a yellow bubble under the blue "The settings have been successfully updated." notification, and the same one whenever I click Run sync of course.

 

What should I install? Is it some Apache or PHP mod, or something else, or just a wrong configuration?

 

I'm running fresh install of PS 1.6.1.3 on Gentoo with Apache 2.4.16 and PHP 5.6.14, connecting over SSL. I can do any changes to the server, but don't know which ones :)

 

The IMAP account is a Google account in the eshop's domain; imap server is set to imap.gmail.com, user and pass correct for the account (including domain), port 993 and out of the options switches only /ssl is on.

 

Any help appreciated :)

Edited by lhalda (see edit history)

Share this post


Link to post
Share on other sites

OK, so it wants PHP to have imap extension installed. In Gentoo, you need to add 'imap' global USE flag in /etc/portage/make.conf and re-emerge php (plus restart your webserver of course).

 

After that I still couldn't connect to the google account with error "[ALERT] Please log in via your web browser: https://support.google.com/mail/acco" - for that I needed to set "Allow less secure apps: ON" in the end of https://myaccount.google.com/security?pli=1

 

Hope this helps others :)

Edited by lhalda (see edit history)

Share this post


Link to post
Share on other sites

Hello!

I have Ubuntu server behind the firewall where PS 1.6.1.4 installed.

No local smtp/imap server installed.

I set an E-Mail parameters as custom (for advanced users) to smtp.gmail.com and it works (test e-mail successfully delivered) - I can send e-mails from my server via Gmail mail relay.

 

Next I attempt to set up Customer Service to Google IMAP server (for my @gmail.com mailbox), I expect to receive all customer service e-mails from Gmail.

Access by IMAP option is turned on in my Gmail settings.

IMAP URL: imap.gmail.com

IMAP port: 993

IMAP user: my-user@gmail.com

IMAP password: **** :)

IMAP options (/ssl) : On

other options still off.

 

Then I click on "Run sync" and the message appear:

imap is not installed on this server

 

-------

 

SOLUTION:

Even you install php5-imap package, it shoudl be enabled by command

#php5enmod imap

then restart apache and click on "Run sync" again.

 

Source

http://askubuntu.com/questions/484921/php5-imap-on-ubunut-14-04-is-not-enabled

Edited by Nick Fedchik (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More