Jump to content
Sign in to follow this  
Krzysztof Romanowski

<SOLVED> Problem z uploadem obrazków do produktów i kategorii, PHP 5.2.6, 777, GD enabled, PS 1.2.5.0

Recommended Posts

Trzeba utworzyć pusty katalog "tmp" w głównym katalogu i nadać mu prawa 777.

WItajcie,


Mam problem z uploadem obrazków do produktów i kategorii. Nie ma ich nawet na FTP. Cały proces przebiega ok, kategoria lub produkt się dodaje ale nie dodają się obrazki.
Pomożecie?

PHP 5.2.6
Pliki i katalogi w /img mają prawa 777
PS 1.2.5.0
GD Support enabled
GD Version bundled (2.0.34 compatible)

Pozdrawiam
Krzysiek

Share this post


Link to post
Share on other sites

Na szczęście sklep nie jest skomplikowany, prawie wszystkie moduły są wyłączone a zamówienie idzie klientowi na maila. Ale z tego co tu czytam to masakra jest z tym homem i z PS. W sumie lekko być nie może bo oczywiście oni mają swój sklep i go chcą wspierać a wszystkim innym pod górkę ;)

Share this post


Link to post
Share on other sites

nie wiem czy ci pomoże ale może być problem w funkcji php FILEINFO a dokładnie w pliku:

images.inc.php w funkcji isPicture($file) jest coś takiego :

$finfo = finfo_open( ....

aby działało na nowszych wersjach php zmień to na :

$finfo = finfo_open(FILEINFO_MIME_TYPE);

ps. na pewno dotyczy to Presty wersji 1.1

Share this post


Link to post
Share on other sites

Chłopaki!!! Dzięki za rozwiązanie tego problemu!
Dwa dni siedziałem z PS 1.4 w serwerze Home.pl i nie mogłem rozwiązać tego problemu.
Miałem dokładnie taki sam problem jak Krzysztof.
Próbowałem zmienić chmod na 777 w folderach, szukałem w kodzie php, zainstalowałem parę razy PS 1.4.3.
I nic. Nie funkcjonowało. Mogłem dodać produkt, ale fotografię nie wrzucało, pomimo tego że odpowiedz była że wszystko przebiegało pomyślnie!

W końcu zobaczyłem ten post i dodałem folder /tmp z chmod 777.

TERAZ FUKCJONUJE.

DZIĘKUJĘ. Chociaż chciałbym wiedzieć dlaczego potrzebny jest ten folder w Home.pl.

Poza tym Paweł coś wspomina o problemach PS w Home.pl. Ktoś może opisać jakie są te problemy? Coś trzeba ustawić na serwerze?
Na przykład mi nie funkcjonuje API PayPal w modułach w wersji 2.4. Musiałem wrzucić wersję 2.0 i na dodatek poprawić kod, ponieważ nie przechwycał odpowiednio sentencję __FILE__ .

Share this post


Link to post
Share on other sites

na home.pl pojawią się jeszcze problemy ;/ z tego co pamiętam to był problem z logowaniem się do zaplecza sklepu (rozwiązanie dostępne na forach), dodawania przedmiotu do koszyka i ... . Pamiętajcie, że administratorzy na home.pl bardzo chętnie udziela pomocy przy ewentualnych problemach - więc pytajcie.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More