Jump to content

Recommended Posts

Hallo allemaal,

 

We hebben een webshop overgekocht en deze draait op versie 1.2.4.0

Naast dat het qua beheer niet bepaald gebruiksvriendelijk is, hebben we ook issues met modules, want de meeste partijen ondersteunen deze oude versie niet meer.

 

Natuurlijk willen we de history, producten en gebruikersaccounts behouden.

 

Ter test heb ik -met redelijk wat moeite- de site gekopieerd naar een andere locatie en heb ik deze in 1 slag geupgrade naar 1.6.1.3.

Ik had de folders config, img en templates laten staan. In de templates folder alleen de folder van de gebruikte template laten staan.

 

Na de upgrade ziet de site er niet meer uit. Te verwachten met een 1.2 template.

Echter krijg ik met geen mogelijkheid de standaard template actief. Ik blijf de volgende error behouden:

"INSERT INTO `ps_hook_module` (`id_module`, `id_shop`, `id_hook`, `position`) VALUES (2, 1, 0, 1)"

De site doet toch een insert, dus simpelweg deze record verwijderd uit de database, maar bij het activeren van de default-bootstrap blijft ik dezelfde error krijgen. De record is inderdaad terug, dus volgens mij wordt dezelfde insert 2x uitgevoerd.

 

Verder mis ik een deel van de opties in de backoffice en zie ik opties waarbij geen modules meer bestaan. Dus ik ben bang dat het een beetje een rommeltje wordt.

 

Mijn voorkeur is een schone installatie en alleen de tabellen kopiëren die ik nodig heb (uit een geupgrade database), maar ik las in een andere post dat dat niet zo makkelijk is. Cart-2-cart ondersteund helaas geen versie 1.2.

 

Zijn er handige tips die ik kan volgen?

Wat is in grote lijnen een goede weg om te bewandelen?

 
Ik ben niet bang om te lezen en heb voldoende kennis van php, xml, sql. Maar na 2 volle dagen stoeien en vloeken begin ik een beetje moed te verliezen.
 
Alvast bedankt,

Share this post


Link to post
Share on other sites

Zekers.... dat is de procedure wat ik gebruikt heb om van 1.2.4.0 naar 1.6.1.3 te gaan.

Plus de debug functie om weer wat op het scherm te krijgen ;-)

 

Ik zit er aan te denken om de kopie opnieuw te doen, dan alle modules uitschakelen en verwijderen, dan opnieuw de upgrade. Ik ben bang dat de oude modules me in de weg zitten..... 

 

Ik heb de default-bootstrap template kunnen activeren door bij "Select the theme's modules you wish to enable" alle 40 modules uit te vinken.  Alleen het ziet er nu niet uit  :-D

Edited by maurice.vantloo (see edit history)

Share this post


Link to post
Share on other sites

Helaas is "Manual update" bij lange na niet compleet. Maar het was goed om het door te lezen.

Ondertussen ben ik toch opnieuw een end opgeschoten.

 

 

WinSCP laat standaard geen .htaccess zien, dus die heb ik in eerste instantie niet meegenomen vanaf de source locatie. Dat is wel een oplettertje. Er moesten ook aardig wat handmatig toegevoegde regels verwijderd worden.

 

Verder heb ik na eerst de 1.2 gekloond te hebben, alle modules deinstalleerd. Dat heeft zeker geholpen. Daarna ook de standaard theme prestashop geselecteerd, vanwege custom rommel van de vorige eigenaar. SSL uit, User-Friendly URL's uit.

 

Nu kon ik de upgrade nagenoeg foutloos uitvoeren. 2 items konden niet gedropped worden omdat de upgradetool ze niet konden vinden, maar och, als het weg moest....

 

Tenslotte de plaatjes laten verplaatsen naar de nieuwe storage en thumbnails hergenereren.

 

Site ziet er niet uit vanwege instellingen in de thema, maar ik ben zomaar ineens een heel end opgeschoten.

 

 

2 dagen knoeien, maar als je een vraag zet op een forum, ga je vaak toch zelf je eigen vragen beantwoorden :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More