Jump to content

Recommended Posts

Bonjour,

Je suis en cours d'installation de Prestashop.
Arrivé à l'étape 4, j'ai entré les informations demandées.
J'ai donc cliqué sur "suivant" pour accéder à l'étape 5.
Mais là, rien n'y fait, je reste à l'étape 4 et il n'y a aucun message d'erreur.
Je suis donc sorti de la procédure d'installation et de wamp (installation de Prestashop en local).
Lorsque je relance la boutique avec wamp, j'arrive directement à ce qui semble être la page d'accueil
de la boutique Prestashop, le modèle par défaut (Ipod,...).
Cela signifie-t-il que l'installation de Prestashop s'est bien effectuée (même si je n'ai pas eu accès à l'étape5)?
Si oui, à partir de la page d'accueil, comment accède-t-on à l'interface d'administration ?

Merci de votre aide !

Share this post


Link to post
Share on other sites

Maintenant tu connais le principe, faut juste que tu recommence l'installation, tu notes les paramètres pour les logins et normalement c'est bon.

Par contre, tu utilise quel client PHP en local?

Share this post


Link to post
Share on other sites

que veux tu dire par recommencer l'installation ? il faut que je remette install dans le répertoire Prestashop ?
Et après, je relance comment?
J'utilise Wamp.

Merci Alhambra

Share this post


Link to post
Share on other sites

Tu vide l'ancien ou mieux encore tu crée un nouveau dossier dans wamp et t'installe Prestashop pour pouvoir récuperer tes logins.

Ou bien tu peux aussi regarder simplement dans le fichier settings.inc du dossier /config les logins pour la base de données sont la dedans.
En tout cas le login du panneau administratif est composé de l'adresse mail que tu as renseigné et le mot de passe associé à la boutique.

Share this post


Link to post
Share on other sites

Salut,

J'ai suivi tes recommandations.
J'ai recommencé l'installation de Prestashop après avoir tout viré.
J'ai à priori suivi la procédure (nouvelle BDD,....).
Tout va bien pour les étapes 1,2 et 3.
Mais je reste bloqué à l'étape 4.
Après avoir indiqué les identifiants de la boutique (nom, logo, mot de passe), je clique sur "suivant" pour passer
à l'étape 5.
Mais il ne se passe rien. Je reste à l'étape 4.
Je rencontre le même problème que lors de la première installation....Je sors donc de l'étape 4.
J'arrive néanmoins sur la page d'accueil de la boutique.
J'ai bien sûr renommé l'admin et viré install.
Lorsque je souhaite accéder à l'interface d'administration, il ne reconnait pas mes identifiants (ni l'email, ni le mot de passe).
Je pense que c'est parce que je n'ai pas pu aller à l'étape 5.
Voilà, je suis donc resté au même niveau.
Là, je ne sais pas trop quoi faire !
Si t'as une idée...
Merci !

Share this post


Link to post
Share on other sites

Tu as deux cases email lors de l'installation, tu dois renseigner deux fois le même.
Surtout n'essaies pas de t'envoyer un mail avec les infos.

Attache une image à ton prochain post avec l'écran de l'étape que tu est bloqué.

Share this post


Link to post
Share on other sites

ça y est, ça marche !
j'ai trouvé le problème.
En fait, dans la procédure d'installation des 5 étapes, il faut éviter
d'indiquer une adresse email test demandée à la fin de l'étape 3.
Voilà, apparemment c'était le bug, en ce qui me concerne.
Je ne sais pas si d'autres ont eu le même problème.
Y'a plus qu'à maintenant !

Encore merci de ton aide !

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Bon, bien que n'ayant plus indiqué d'email dans la phase 3, j'en reste toujours à ma phase 4, et.. rien.

Je reviens en accueil, je vire l'install, je renomme l'admin, je l'ouvre, je passe mon mail et mon login, et.. il ne me connait toujours pas...

Ha ha ha, ça ne fait finalement que 4 mois que j'essaie d'installer ma malheureuse boutique ! :D

Share this post


Link to post
Share on other sites

Bonjour vous deux,

ne pas confondre email de test (étape 2) et le login de la Base de données.
Quand vous installez la base de données mabase.sql par exemple, il faut affecter un nom d'administrateur et un login (mot de passe)
C'est alors l'accès à la base de données qui est définie pour la suite des opérations.

Il faut tout de même renseigner (étape 3) le mail administratif auquel les clients vont vous envoyer leur questions (Formulaire de Contact dans Prestashop) ET un mot de passe sans SIGNE comme @ ou €. C'est au même endroit ou vous nommez la Boutique et cherchez le LOGO sur le PC.

Ce sont ces deux infos qui vous permettent de rentrer dans Prestashop Front et Backofffice.

NE PAS OUBLIER de RENOMMER le dossier ADMIN en ADMIN*** (quelque chose) sur le serveur local ou distant et de SUPPRIMER ou renommer le dossier INSTALL avant de vouloir se logger dans quoi que se soit!!!!!

Car une fois que Prestashop commence a recevoir des mauvaises informations il bogge.

ET NE JAMAIS SUPPRIMER LE MOT DE PASSE ADMINISTRATIF DE LA DATABASE§
Sinon non seulement vous perdez tout accès, mais il faut tout recommencer.

Dernière chose pour une éventuelle restauration complète plus tard.
Sauvegardez toute la base de données SAUF LA TABLE ps_employee. (C'est elle qui contient le(s) mot(s) de passe admin)

Et lors vous devez réinstaller Prestashop, SAUVEGARDEZ TOUT SAUF LE DOSSIER CONFIG !

A) La restauration va plus vite
B) La restauration fonctionnera, car
C) Vaut mieux réinstaller Prestashop et de remplacer les dossiers/infos manquants par la suite que d'essayer de restaurer l'ancien mot de passe etc.

et la TOUTE DERNIERE CHOSE = L'INSTALLATION DE PRESTASHOP BASIC OPERATIONELLE NE PRENDS PAS PLUS QUE 5 MINUTES

C'est plus long si vous installez plein d'autres modules supplémentaires.

Faites savoir si vous avez réussi enfin d'installer Prestashop :)

Share this post


Link to post
Share on other sites

Bonjour

Bonjour vous deux,

ne pas confondre email de test (étape 2) et le login de la Base de données.
Quand vous installez la base de données mabase.sql par exemple, il faut affecter un nom d'administrateur et un login (mot de passe)


Ah mais voilà... C'est là que moi je suis fautif : je ne renseignais pas ces champ, car, habitué à d'autres CMS en local, ils demandaient de les laisser vierges ! Bref, je repars sur cette piste... :) Merci

Share this post


Link to post
Share on other sites
Bonjour
Ah mais voilà... C'est là que moi je suis fautif : je ne renseignais pas ces champ, car, habitué à d'autres CMS en local, ils demandaient de les laisser vierges ! Bref, je repars sur cette piste... :) Merci


Oui mais justement, si on remplit les champs "identifiant" et "mot de passe" pour la BDD, en tapant ensuite "tester la connexion SQL", ca ne fonctionne pas. Il faut bien garder "root" et un mot de passe vide (pour le local)

Quand vous installez la base de données mabase.sql par exemple, il faut affecter un nom d'administrateur et un login (mot de passe)


Où ça exactement ?...

?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More