Jump to content

'controller Not Found' For Cms

Recommended Posts

Hi guys,


I'm working on Prestashop All was going well, until I want to customize CMS pages. You can see the french error in the screen I joined, but the translation is 'Controller not found'.


I have checked : the 3 controllers exist in controllers/admin :





For example, in the URL, one of the controllers called is AdminCmsContent :




I have also tried to replace the folder 'controllers' from a new Prestashop archive, but the problem is the same.


Any idea ?

Thank's a lot !


Link to comment
Share on other sites

  • 2 months later...

I have the same error but i didn't find the solution yet.

I developped new module in prestashop 1.6 in my local server, everything was nice.But when i installed it into my hosting server i get controller not found error when i click into module tab.

I can enter to configure the module via prestashop configurer link, i get the configuration page and it works nice.

I thought it comes from capitals letters, i check if all files names are identicals but i found everything are in good format.

Really, a strong problem this one, i must to deliver the product today to the client i don't know what to do.

Please, i need your help, everything can help, an idea , a link to tutorial, ....

Link to comment
Share on other sites

  • 3 months later...
  • 5 months later...

Hi guys. I have another one situation.


When i login as a Super Admin - CMS page work, but if i login as a employee with low access rights - than i see "controller not found" error.


What that can mean? Some module depend on admin page access or employee should have access to some different admin pages...


Whqt you think about that?


Thanks for NemoPS - "add new menu item" method works for me. After create new item, problem page work, and link on old item too. New menu item not need anymore.

Edited by Cvalya (see edit history)
Link to comment
Share on other sites

  • 2 years later...


it will fix this issue

"the controller admin cms content is missing or invalid "  in all prestashop version after upgrade 

For the cms, you need to see with the module provider of homesliderpro.

SELECT * FROM `ps_tab` WHERE `class_name` LIKE 'AdminCmsContent'

is giving two results. You need to delete one of them.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...