en Jump to content
  • 0
Crezzur

[Solution] Slow Back-Office? Forever Spinning Save Icon? - Final Solution 28/12/15

Question

Hey all,

After updating my web-shop from V1.6.0.9 to V1.6.1.1.
I had to wait up to 45 second to save or edit a product.

Of course when you need to add and or edit allot on your web-shop you just cant sit and wait 45 seconds every time you hit the save button!
After allot of searching i founded the solution which turned out i only had to wait 3-4 seconds!

So i am going to share the solution(s) i found, so you guys can solve the issue on your prestashop.

Make sure to hit the follow button if your in need for a solution

 

First solution (not server related): (Works 100% if your issue is NOT server related)

  • Upgrade your webshop using Prestashop One-Click-Upgrade
  • Select Advanced options and select Channel "* Release candidate"
  • Upgrade your webshop to Prestashop V1.6.1.3 RC1
  • Your issue should be solved, other while take a look at solution 2

 

Second Solution (Server related): PHP server issue please upgrade/downgrade to 5.3.30

 

Or follow the steps mentioned by Labels here

Post from Labels:

Hi to all!

 

i had the same problem with always spinning icons on the saving. With a blank installation of the 1.6.1.3!

I have solved the problem on my system. After a long time of searching and reading this forum.

 

Please look at this problem in the php.log file. At my installation on a plesk 12 virtual server was the basedir wrong.

So the system cant take the JS files.

 

For me it works with the configuration to php 5.5 and as open_basedir={DOCROOT}{/}{:}{TMP}{/}.

 

I hope this will help some peoples!

 

Many greets

 

Andreas

 

 

Did this solution work for you?
please like this post and or post a message so others can also find it.

 

Edited by Crezzur

Share this post


Link to post
Share on other sites

62 answers to this question

Recommended Posts

  • 0

My save buttons are spinning on a loop, so I can't edit the prices of my products!

 

I upgraded recently to the latest version of Prestashop after being hacked.

At first the product changes would save automatically - despite the spinning buttons, now the changes don't save and the buttons keep spinning.

 

I've tried different php servers in Cpanel, not made any difference.

 

Can somebody help?

Share this post


Link to post
Share on other sites
  • 0

Here's a solution that worked for me...

I'm developing my website on my localhost (home computer using xampp) and on my internet host (Bluehost) at the same time.

I make a change on my localhost, see what it looks like, and then make the same change to my internet host, which is in maintenance mode and cannot display my website unless I enable the shop.

 

I actually started configuring on my internet host first, copied all of my settings to my localhost, and both sites are now equal in terms of settings, products, and images.

Interestingly, my localhost is throwing errors including the spinning save buttons, tabs not loading completely, and product not being written because it's asking for at lease one in English.

 

I took someone's advice and tried to load the tabs by clicking on each tab before entering in product. That didn't work, but I did notice that SMARTY (Advanced Parameters > Performance) was the module reporting the error on each of the tabs that didn't load. On my internet host, I changed the SMARTY setting from 'Never compile template files' to 'Force compilation' because I had made a change to a template and it was it wasn't displaying not matter how many times I uploaded the file. When I changed the SMARTY setting to 'Force compilation', my template loaded as I wanted.

 

While the 'Force compilation' setting on my internet host doesn't cause any errors, that setting causes multiple errors on my localhost.

On my localhost, I changed the SMARTY setting back to 'Never compile template files', and all of the errors and spinning save buttons went away.  

 

 

https://www.facebook.com/henry1media

Share this post


Link to post
Share on other sites
  • 0

I found out what was causing this issue on my site..... Rocket Loader.

 

I use CloudFlare and had enabled Rocket Loader in the "Speed" tab of my CloudFlare control panel.

I had enable it because it is supposed to Improve load time for pages that include JavaScript.

I have pasted the expanded explanation below, and the last line tells the story of what happened to my site.

 

I know Rocket Loader is also available as an add on in cPanel.

Perhaps this is causing the same issue for other Prestashop users subscribing to this thread?

 

 

---------------------------------------------------------------------------------

What does Rocket Loader do?

 

Rocket Loader can improve load times for pages that include JavaScript. Your search engine ranking may be improved by reducing page load time.

 

Rocket Loader improves page load times by:

 

    Decreasing the number of network requests by bundling JavaScript files, even third party resources, to avoid slowing down page rendering

    Asynchronously loading scripts, including third party scripts, so that they do not block the content of your page from loading immediately

    Caching scripts locally (using LocalStorage, available on most browsers and smart phones) so they aren't refetched unless necessary

 

What Rocket Loader setting should I use?

 

    Automatic: Optimize all JavaScript resources on your website. No configuration required

    Manual: Selectively enable Rocket Loader for individual scripts. Add the following attribute to the script tag for each script where you want to enable Rocket Loader:

        data-cfasync="true"

 

Note: The 'data-cfasync' attribute must be added to the HTML script tag before the 'src' attribute (adding the attribute via JavaScript is not sufficient).

 

Rocket Loader is considered Beta because it’s an experimental feature that modifies the loading and execution flow of Javascript. While efforts are taken to increase Rocket Loader’s compatibility with third-party Javascripts, not all scripts work with this feature. Issues with Rocket Loader affect only a small percentage of customers.

Worked like a charm ! How did you noticed that ?

Edited by 4saleusa

Share this post


Link to post
Share on other sites
  • 0

Hi, I had the same spinning save buttons issue, unable to edit, save or create any new products (my Prestashop 1.6.1.1). Back office extremely slow over the last month or so, put it down to slow browser/computer. Product tabs in back-office wouldn't load at all, and would eventually time out with Check your server message popping up. Deleted modules and disabled stats, but no joy.

 

As probably many of you have done I searched the forums, read Top man Nemo's posts, tried all sorts of fixes but no joy. Couldn't upgrade to latest 1.6.1.x version as have made too many mod's to site & template, which would vanish on upgrading (learn't that lesson the hard way!). Best solution seemed the Official Prestashop release of 1.6.1.9 and to manually update the patch files (http://build.prestas...enance-release/). Did that and cleared cache in Prestashop & browser, but no fix for me (left altered files - 9 of them).

 

Continued searching web for another fix (or else I would have to as a last resort replace all js, admin, class directories with the ones from 1.6.1.9) and found this discussion on a similar issue back in April 2015 : http://stackoverflow...ing-very-slowly

 

See link to Github patch file: https://github.com/P...d674189abc19493

 

Uploaded the complete version of the file classes/controller/AdminController as shown on github. Cleared cache on Prestashop (Advanced Parameters/Performance) and in browser. DING DANG DO... unbelievable, spinning wheels gone, couldn't believe my eyes! Back Office the quickest it's ever been. RESULT!

 

Hope this is the solution you've been looking for?

 

Recap: Manually update the 9 patch files from Prestahop release - http://build.prestas...enance-release/

github: https://github.com/P...aShop/pull/6749

 

Replace: classes/controller/AdminController file with the one below:

Github patch file: https://github.com/P...d674189abc19493

 

CLEAR Prestashop cache & browser cache. 

Share this post


Link to post
Share on other sites
  • 0

I have upgraded to 1.6.1.11.

 

Issue persists, this is very frustrating.

 

PHP Version is 5.5.38. I have tried various PHP versions.

 

Save and "Save and Stay" spinning forever on the Products Page.

Edited by sjas

Share this post


Link to post
Share on other sites
  • 0

I have upgraded to 1.6.1.11.

 

Issue persists, this is very frustrating.

 

PHP Version is 5.5.38. I have tried various PHP versions.

 

Save and "Save and Stay" spinning forever on the Products Page.

me too.

I tried to chance some web browrsers like google chrome 53.0.x, firefox, IE but didn't work (sometime it did but sometime not,) but on Android it's seem good

My hosting information:

Server information: Linux #1 SMP Mon Mar 14 17:49:20 EDT 2016 x86_64

Server software version: Apache

PHP version: 5.5.38

Memory limit: 128M

Max execution time: 100

MySQL version: 5.5.52-cll-lve

I tried to install a new prestashop but the problem is still there (on the same hosting with the older).

I think the problem from my hosting , ajax or js.

I don't know what should I do right now.

:(  :(

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

I had same problem.

For me worked this solution:

 

I increased in php memory_limit from:

 

Memory limit: 128M

to

Memory limit: 256M

 

and worked instantly.

Share this post


Link to post
Share on other sites
  • 0

and I found another solution:

 

 

Using FTP go to "admin > themes > default > template > controllers > products" and in all .tpl files find:

<button type="submit" name="submitAddproduct" class="btn btn-default pull-right" disabled="disabled"> {l s='Save'}</button>

<button type="submit" name="submitAddproductAndStay" class="btn btn-default pull-right" disabled="disabled"> {l s='Save and stay'}</button>

1. Remove " disabled="disabled "

2. Replace "process-icon-loading" with "process-icon-save"

 

 

https://disqus.com/home/discussion/nemops/troubleshooting_the_spinning_save_button_in_prestashop_16011_and_above/

Share this post


Link to post
Share on other sites
  • 0

Hello friends!
I solved the problem with the infinitely twisting save icon.
On the part of requests for the script of the product saving page, the server responded with a 503 response.
It turned out that this restriction on the part of the hoster.
After switching to a more expensive tariff plan, the whole problem was solved.

Share this post


Link to post
Share on other sites
  • 0

Hi to everyone.

I had admin save button spinning and drop down menus not working on 1.6.1.20 version after unlucky upgrade to version 1.7.

Searched and implemented many solutions but did't helped. 

Finally by overwriting root/js folder contents with version 1.6.1.20 files sorted my issue. As I understood issue was changed /js folder contents by upgrade.

Hope this helps someone.

All the best. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More