Jump to content
Sign in to follow this  
Fabrice

[Résolu] TTC-HT : un gros bogue dans le système ?

Recommended Posts

Créez un produit.
indiquez une TVA à 19,6%
indiquez le prix TTC.
le prix HT est automatiquement calculé. (super)



MAIS :
dans la page produit, là ou l'on s'attend à voir un prix TTC on visualise le prix HT calculé.
attention, ce n'est PAS simplement un problème de champs.
le problème ne vient pas d'une erreur d'affichage, mais d'une erreur de "liaison" avec la BDD.
LE PROBLEME EST bien plus grave en fait.

donc l'appli choisi d'afficher le prix HT, MAIS considère ce prix comme un prix TTC !!!
voir copies écrans ci-jointe.

pour résumer en chiffres :
PRIX TTC : 39
Prix HT calculé : 32,608696
Prix HT affiché : 32,61 considéré comme TTC
Prix HT tiré du prix TTC affiché (32,61) : 27,26 HT

Il y a donc bien un problème non ?
EDIT :
j'ai mis en gras ce qui reste un problème.
le soft ne devrait pas calculer le HT (2 fois) - il recalcul un HT sur un prix qui est déjà HT.

un avis la-dessus avant que je lance un rapport de bogue ?
je ne dois pas être le seul à avoir constaté ce problème... ou bien ?

Merci.
Fabrice

EDIT - petite précision pour situer le moment ou le bogue opère :
l'erreur semble provenir de l'import du montant lorsque l'on affiche le produit.
en effet, lorsque l'on rafraichit la page produit, et que l'on activé l'affichage du prix HT sous le prix TTC, on voit apparaître en premier lieu le vrai prix ht, et tout de suite après il est recalculé. faites l'expérience. c'est donc bien un problème situé sur l'import du prix TTC (dans lequel le prix HT est importé) et non un problème de base de données.

Ceci doit être facile à corriger.
Ou puis-je trouver le code qui importe cette information ? en sachant que le problème est présent sur tout type de page (accueil, ainsi que pages produits)

1740_iEEUAxEd6Uvkv77cdiEi_t

1741_0pe5eyc9HdV6Xkd4oavB_t

Share this post


Link to post
Share on other sites

Je viens de lire ton message qui m'a fait très peur dans un premier temps.
Car il y a un moment il y a des problèmes du même genre... et j'ai pensé que la malédiction du HT/TTC etait revenue.
Pour ma part j'ai donc vérifié avec plusieurs produits et je ne constate pas l'erreur.
Quelle version utilises-tu ?

Cependant en vérifiant je viens de constater un gros bug dans le même style.
Le bon prix s'affiche une fraction de seconde puis un prix erroné au final.
Il s'agit uniquement d'article en promotion... dans le prix est multiplié par deux (un comble pour une réduction) !
voir image ci-dessous.

Merci de vérifier de votre coté (et re-vérifier celui que décris Fabrice)

1742_t9Nsx7As1aym3Yyizb2E_t

Share this post


Link to post
Share on other sites

tu m'étonnes !!

le double pour une réduction, c'est pas mal ça...

sinon, si je regarde tes copies écran, le prix "EN SOLDE" n'est pas censé être TTC ?

en fait, si on regarde de plus près :

le prix TTC = 148

le prix EN SOLDE est juste : c'est bien 296 - 20% = 236,80

ce qui est faux c'est le calcul du prix TTC affiché (148 x 2).
on a un point commun pour les 2 problèmes : le prix ttc est faux.

en ce qui te concerne, ça peut venir d'un prix d'achat nul non ? ça, le soft il doit pas aimer.

sinon, en ce qui concerne mon problème, je confirme qu'il est systématique. et j'utilise la version 1 officielle.

mais, si ce problème ne se produit que chez moi,
il est possible que lors de la mise à jour, un champs de la base de données ait été soit dupliqué soit renommé (ou nom) et le soft s'y perd un peu.
un coup de main les développeurs ?

Share this post


Link to post
Share on other sites

Bonjour,

@Fabrice : je n'ai pas bien compris votre configuration.

Déjà, comment sont appliquées vos taxes ? (zones, pays, etc)
Utilisez-vous l'affichage des prix HT ?
Auriez-vous un accès à votre BO (url, email, password) afin de tester la procédure ?

@ludo : êtes-vous sûr que votre produit n'a pas d'attribut qui viendrait rajouter un surplus sur le prix ?

Share this post


Link to post
Share on other sites

Bonjour Philippe !

qu'entendez-vous par BO ?

pour les taxes, seule la première zone était cochée. la France n'était pas cochée.
ça doit donc venir de là, car cela a résolu le problème. (désolé, je découvre encore l'appli :-)
merci !! :-))

sinon, j'ai une question concernant cette procédure.
il y a quand même un problème d'application de TVA n'est-ce pas ?
comment est-il possible que d'un prix TTC la taxe soit retranchée 2 fois ?

et oui, j'avais affiché le montant ttc et ht pour comprendre le comportement du calcul.
et le montant HT est calculé, alors que dans ce cas précis il ne devrait pas n'est-ce pas ?
pour résumer, le montant HT devrait être égal à TTC, vu que la taxe n'est pas applicable.

merci pour vos lumières. :-)

Share this post


Link to post
Share on other sites
@ludo : êtes-vous sûr que votre produit n'a pas d'attribut qui viendrait rajouter un surplus sur le prix ?


Bonsoir Philippe,

Effectivement j'ai des attributs de taille (52,53 et 54) mais le prix n'a pas été modifié.
A ce propos, je viens de remarquer que si je passe en taille 54 le prix est toujours faux mais différemment !!!
taille 52 : 236,80 €
taille 53 : 236,80 €
taille 54 : 238,40 €
Alors qu'à réalité on devrait avoir 118,40€ pour les 3 tailles !!!

http://my.jshop.biz/2-1-2-jonc-leger-z.html

La c'est franchement n'importe quoi !

Share this post


Link to post
Share on other sites

rien du tout !
j'espere que la Prestateam a pris note de ce topic !!!

Share this post


Link to post
Share on other sites

@Ludo : pourriez-vous m'envoyer un accès à votre BO ? (url, email, passwd).

Merci :)

Share this post


Link to post
Share on other sites

@Ludo : vous dites que les attributs n'ont pas d'impact sur le prix de votre produit, pourtant dans votre back-office :

- prix de base : 148€ - 20% réduction
- attribut "taille 52" : + 148€ => 148 + 148 = 296 - 20% de réduction = 236,80€
- attribut "taille 53" : + 148€ => 148 + 148 = 296 - 20% de réduction = 236,80€
- attribut "taille 54" : + 150€ => 148 + 150 = 298 - 20% de réduction = 238,40€



Tous les calculs sont justes, et les prix affichés corrects.
N'oubliez pas que le prix de l'attribut impacte sur le prix de base du produit, il ne le remplace pas.
Si vous mettez 148€ dans l'attribut, cela rajoute 148 au prix de base (148 lui aussi), le prix final avant réduction étant 296€.

@Fabrice : pourrais-je avoir un accès à votre back-office ? (url, email, passwd). Merci :)

Share this post


Link to post
Share on other sites

Rhaaa la vache j'étais a des années lumières !
Maintenant je comprend mieux...

Vivement la doc utilisateur !!!
Kisikol ?

Share this post


Link to post
Share on other sites

Bonjour,

Je suis nouveau et en train d'ouvrir ma boutique avec Prestashop.
Je ne sais si c'est exactement la même chose mais je rencontre un pb similaire :
- je choisis un produit, affiché 15 € TTC
- il apparaît dans le panier à 12,54 € HT
- je clique, depuis le panier, sur le même produit, la fiche produit réapparaît, avec le prix HT affiché, au lieu du TTC, mais avec écrit TTC (ici, 12,54 € TTC est affiché, donc)
- et, comme une conséquence, quand je clique sur d'autres produits, sans passer par le panier dans ces cas-là, là aussi, les prix HT sont affichés, avec l'indication TTC !

Je suis sous Prestashop 1.0.0.3
Quelqu'un peut m'aider ? C'est un vrai gros pb !

Merci
Olivier

Share this post


Link to post
Share on other sites

@olivierB : vos taxes ne doivent pas s'appliquer sur vos produits en raison de vos paramètres taxes/régions dans le back-office.
Merci de tout bien vérifier :)

Share this post


Link to post
Share on other sites

Bonjour,

A priori, tout est bien rentré.
Surtout, comme je l'expliquais, le problème est le suivant :
- le prix TTc s'affiche bien avant la mise dans le panie
- quand, ensuite et soit depuis le panier (pour revenir à la fiche d'un produit ajouté), soit directement depuis mes pages Catalogues, je clique sur un produit, il apparaît avec un prix HT marqué TTC (12,54 € TTC au lieu de, soit 12,54 € HT soit 15 € TTC).

C'est donc un réel problème car, dans ce cas et légalement, c'est le prix affiché comme TTC qui a valeur légale...

Suis-je plus clair ? Est-ce un pb connu qui peut se résoudre facilement ?

Merci !

Share this post


Link to post
Share on other sites

Puis-je avoir accès à votre back-office ? (url, email, password).

Merci d'avance :)

Share this post


Link to post
Share on other sites

Hello Philippe,

Je vous ai envoyé hier matin un MP avec les infos de B.O.
Vous avez eu le temps de regarder quel pouvait être le pb ?
Vous pensez avoir le temps de le faire ?

Merci d'avance !

Olivier

Share this post


Link to post
Share on other sites

Un grand merci à Philippe pour avoir résolu le problème avant tant de rapidité et de gentillesse !!

Share this post


Link to post
Share on other sites

Bonjour !
Olivier, pouvez-vous poster ici en résumé la solution à ce problème ?
ça peut servir à d'autres le cas échéant...
merci ! :-)

Share this post


Link to post
Share on other sites

Bonjour,

Je dois avouer que j'en serai bien en peine.
En fait, Philippe Sang, de Prestashop, a pris la main sur l'admin et a trouvé un bug, et l'a donc réglé.
Par contre, de quelle façon, je ne saurais le dire...

Mais encore merci à lui, et à toute l'équipe Prestashop !

Share this post


Link to post
Share on other sites

Il s'agit d'un petit bug des anciennes versions, corrigé depuis.

Cela forçait l'affichage en HT dans certains cas (l'algorithme d'application des taxes contenait une petite "faille").

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More