Jump to content
Sign in to follow this  
Fab6657

Ecrasement du pack anglais

Recommended Posts

Bonjour,

vous savez comment c'est, on découvre un outils, Prestashop, on joue un peu avec,
et paff, je viens d'écraser le pack anglais par le pack français en ne faisant pas attention.

Ma boutique étant déjà prête, je ne souhaite pas réinstaller la version.
Je croyais pouvoir charger la version langue (comme je viens de le faire pour l'allemand)
mais il n'y a pas de fichier gzip pour la langue anglaise en téléchargement sur le site.

Avez-vous une solution ?

d'avance merci,

Fabrice

Share this post


Link to post
Share on other sites

Bonjour

Il y a pas de pack anglais, prestashop est écris en anglais, donc tous les mots anglais sont dedans d'origine, il y a juste des pack de traduction, c'est à dire des fichier avec un mot anglais et la correspondance en français ou allemand etc...

Vérifier si le dossier translation/en/ si les fichiers existent encore ou si pas vide, dans ce cas reprendre le dossier /en/ dans prestashop.zip et le remplacer.

Share this post


Link to post
Share on other sites

Bonsoir,

merci pour l'aide, je viens de faire la manip (arrêté et redémarré le site web pour vider les caches)
mais malheureusement cela n'a pas fonctionné.

Le site en anglais reste en français.

Je regarde si je n'ai pas fais d'erreur encore.

Fabrice

Share this post


Link to post
Share on other sites

Bonjour

Merci de bien vouloir vérifier les dossiers ou il y a un dossier lang et translation/en/ si les fichiers sont vide ou inexistant !!

Share this post


Link to post
Share on other sites

Bonsoir,

merci pour les conseils jusque ici. Je n'ai pas eu trop le temps cette semaine.
Je m'y remets ce week-end, pour l'instant je n'ai pas encore trouvé la solution.

A bientot, ici

Fabrice

Share this post


Link to post
Share on other sites
Guest

et bon alors ta resolu ton probleme ou pas??

Share this post


Link to post
Share on other sites

Salut,

pas vraiment, j'ai trouvé l'endroit ou l'on peut traduire les textes.
Je peux traduire individuellement chaque élément, mais c'est trop long.
Mais pour l'instant, je laisse de coté pris par d'autres tâches.

Je passerais en version 1.3 lors de sa sortie, et referais certainement le
site (il n'est qu'en phase de préparation).

Merci à ceux qui m'ont conseillés.

@+

Fabrice

Share this post


Link to post
Share on other sites

Bonjour

Si les langues disparaissent ou quand vous voulez faire une traduction manuelle dans onglet Outils >> Traduction et que après enregistrement ça disparait : 1 vérifier la taille d'hébergement ou l'espace occuper. (je vous le conseil parce que cela m'est arrivé)

2 dézipper les packs de langues et remettez les à leur place : dossier Translation vous avez un dossier en = anglais,
fr = français et es = espagnol à partir de la 1.3

C'est vite fait 3 minutes, puis vérifiez par acquis de conscience dans plusieurs dossiers y a des fichier en.php fr.php es.php
s'il existe et qu'il ne sont pas vide.

Pas la peine de vouloir tout faire à la main.

Share this post


Link to post
Share on other sites
Guest

Il y a beaucoup de place sur mon hebergeur.

Quand j'installe d'autres langues tout marche bien.
J'ai supprimer la langue anglais a partir du back office, dans la partie Outils >> Langues

Maintenant quand j'essaie de l'installer en mettant tout simplement :

English (English)
en
le petit drapeau
la petite image

je valide et il me marque un warning a la place du V vert "activé".

Mon fichier en.php dans /themes/prestashop/lang fait 4ko ce qui est normal, je l'ai aussi remplacer pour essayer et pareil.
Mes fichiers dans /translations/en on aussi été remplacer par ceux d'origine et ca n'a rien changer.

Quelque chose d'autre a faire?

Share this post


Link to post
Share on other sites
Guest

Peut etre trouver pourquoi,

Il faudrait que l' ID de la langue Anglais soit "1" hors q chaque fois que j'essaie de l'ajouter il me le mets en ID 9, 10 etc..

Mais je sais pas comment faire.

EDIT: Je l'ai mis a 1 ca change rien..

Share this post


Link to post
Share on other sites

Re

Et le warning il dit quoi ? merci de copier coller le message complet du warning.

Pour l'ID en 1 c'est dans la base de donnée, tant que l'ID est enregistrer dans la base de donnée et qu'on veut ajoiter le même langue il prends une ID suivante, il faut d'abord que l'ID 1 soit effacer dans la bdd.

Les fichiers principaux des langues c'est dans translation.

Share this post


Link to post
Share on other sites

bonjour
à titre d'info moi j'ai opté pour un block_gtranslate (google traduction)
il s'intègre bien et traduit tout vos mots comme le ferait les traductions PS
près de 50 langues quand on est en ".com" ça peut mettre en avant...

http://www.prestastore.fr/fonctionnalites-front-office/444-fonctionnalites-front-office-gtranslate.html



pour la compatibilité je n'ai pas eu de soucis avec le 1.2.5 peut être faudra-t-il activer dans préférence
"Compatibilité avec les thèmes v1.1"

pour ma part je l'ai adopté pour sa simplicité et ses capacitées....

Share this post


Link to post
Share on other sites
Guest
Re

Et le warning il dit quoi ? merci de copier coller le message complet du warning.

Pour l'ID en 1 c'est dans la base de donnée, tant que l'ID est enregistrer dans la base de donnée et qu'on veut ajoiter le même langue il prends une ID suivante, il faut d'abord que l'ID 1 soit effacer dans la bdd.

Les fichiers principaux des langues c'est dans translation.


Le warning indique juste warning.

23647_bgz14NjZYEioTY5USU7j_t

Share this post


Link to post
Share on other sites
Guest
bonjour
à titre d'info moi j'ai opté pour un block_gtranslate (google traduction)
il s'intègre bien et traduit tout vos mots comme le ferait les traductions PS
près de 50 langues quand on est en ".com" ça peut mettre en avant...
http://www.prestastore.fr/fonctionnalites-front-office/444-fonctionnalites-front-office-gtranslate.html



pour la compatibilité je n'ai pas eu de soucis avec le 1.2.5 peut être faudra-t-il activer dans préférence
"Compatibilité avec les thèmes v1.1"

pour ma part je l'ai adopté pour sa simplicité et ses capacitées....



J'ai le webtranslator de tomer (Presto-Changeo) qui traduit tout meme les url, balise meta.

Mais ca change tien a mon probleme.

Share this post


Link to post
Share on other sites
Guest

Probleme toujours pas resolu!

Les fichiers dans translation/en sont plein:

admin.php: 49
errors.php: 47
fields.php: 8263
index.php: 298
pdf.php: 207

Ca me fou les boules!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More