Jump to content

Erreur Smarty


jd440
 Share

Recommended Posts

Bonjour à tous,

 

J'ai une erreur plus précisement un PHP Notice qui poluue mes logs et que j'aimerai comprendre

PHP Notice:  Undefined index: static_token in /home/site3482/web/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 122, referer: http://www.mon-nom-domaine.com
PHP Notice:  Trying to get property of non-object in /home/site3482/web/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 122, referer: http://www.mon-nom-domaine.com

Quelqu'un aurait il une idée?

Share this post


Link to post
Share on other sites

Oui j'ai une idée très précise même, en fait c'est très simple :

 

Tu as un template qui utilise la variable smarty static_token qui n'est pas définie (donc qui n'existe pas pour lui) d'où le php notice.

 

Après il faudrait activer le mode debug pour voir sur quel page cela survient et potentiellement quel template est utilisé.

  • Like 1

Share this post


Link to post
Share on other sites

  • 10 months later...

Bonjour,

 

Nous sommes en train de créer notre site de personnalisation d'objet publicitaire.

 

Nous avons remarqué 4 messages d'erreur sur le site suite au mode débug. De plus, toute la présentation de la homepage à sauté : menu, slider, catégories...

 

Les messages d'erreurs sont les suivants :

Notice: Undefined index: HOOK_MAIN_EMNU in /home/fabricatyn/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 390
Notice: Trying to get property of non-object in /home/fabricatyn/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 390
Notice: Undefined index: HOOK_RIGHT_BAR in /home/fabricatyn/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 188
Notice: Trying to get property of non-object in /home/fabricatyn/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 188
 
Est-ce que quelqu'un a déjà eu ce problème? Et est-ce que quelqu'un a une solution?
 
Merci d'avance et bonne journée

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More