Jump to content

Installation Prestashop...aie!aie!aie!


Recommended Posts

Bonjour,
Je suis (très) novice et je souhaite utiliser Prestashop...mais je n'arrive pas à installer le logiciel, que ce soit en local ou non. Je précise que j'ai fait le tour des topics qui me paraissaient semblables, ce qui m'a permis de comprendre un peu mieux certaines choses mais qui ne m'a pas permis de résoudre mon problème...

J'ai "essayé" de suivre le tuto de prestashop:
1/ create a database
J'ai crée une base de donnée à l'aide de Wampserver 2.0, dans phpmyadmmin, il y a effectivement une BD crée, bien que je ne comprenne pas vraiment où elle est stockée ni ce qu'elle contient.
2/Turn on GD Library functionality
Alors là??? quézako le dossier PHP et le fichier php.ini, je ne sais pas où ils se trouvent. Dans le doute j'ai donc validé l'extension php_gd2 dans wampserver>PHP>extensions PHP
3/Download the PrestaShop e-Commerce solution software
OK
4/Unzip the PrestaShop ZIP archive anywhere on your hard drive.
OK
5/Upload the contents via FTP
OK, bien que les fichiers sont très légèrement plus petits une fois téléchargés (en tout cas il y a le même nombre de fichiers et de dossiers).
Au départ, j'ai téléchargé le dossier Prestashop directement dans le dossier / puis, j'ai cru comprendre qu'il fallait le mettre dans le dossier /www, ce que j'ai fait.
6/J'ai suivi les instructions pour modifier les droits d'écritures de certains dossiers et sous dossiers
J'ai également modifié le fichier .htaccess étant donné que j'ai souvent vu cette proposition sur les topics. mon fichier .htaccess contient désormais ça:
Order deny,allow
Deny from all
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
Je n'ai pas compris où doit se trouver ce fichier, par défaut je l'ai laissé dans le dossier prestashop, là où il se trouve au dézippage.
7/ quand je lance l'adresse http://www.monsite.com/prestashop/install, j'obtiens le message suivant:

Forbidden
You don't have permission to access /prestashop/install on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.42 Server at www.monsite.com Port 80

Voilà, j'ai essayé d'être aussi précis que ma novicitude le permet...je suis ouvert à toutes proposition et/ou essais...
Merci d'avance pour votre aide...

Share this post


Link to post
Share on other sites

Merci pour la réponse rapide,
J'ai retiré le "deny from all"
J'obtiens la même erreur...


Forbidden
You don't have permission to access /prestashop/install on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.42 Server at www.monsite.com Port 80

Mais je supprime tout de même le "deny from all" car ça ne me semblait pas bon pour l'accès de toute façon...
Ouvert à d'autres propositions.

Share this post


Link to post
Share on other sites

Salut alakazam,
Peut etre regarder du coté des permissions en ecriture / lecture (client FTP -> clique droit répertoire racine -> permission -> 705 )

A bientot,
Pierre.

Share this post


Link to post
Share on other sites

Salut Pierre,
Le répertoire racine (je suppose que c'est le répertoire /www, là où j'ai mis le répertoire Prestashop) est en CHMOD 777.
Le répértoire Prestashop est en CHMOD 777.
Les sous dossiers du répertoire Prestashop sont en CHMOD 777 ou 755
Les fichiers du répertoire Prestashop, dont le fichier .htaccess sont en CHMOD 644.
Donc à priori les droits d'utilisation sont suffisants.
J'obtiens toujours là même erreur en tapant http://www.monsite.com/prestashop/install'>http://www.monsite.com/prestashop/install
Cependant, si je tape seulement http://www.monsite.com j'obtiens le résultat suivant:

Index of /

Name Last modified Size Description

[DIR] Parent Directory 18-Mar-2010 17:11 -
[DIR] cgi-bin/ 16-Mar-2010 18:51 -
[DIR] prestashop/ 18-Mar-2010 17:11 -

Apache/1.3.42 Server at www.monsite.com Port 80

Je ne sais pas exactement ce que cela signifie, mais à priori, l'adresse est existante...
En conclusion je bloque toujours et je n'ai pas vraiment d'idée...
Julien

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Bonjour,
J'ai essayé une installation en local, qui a fonctionné dès que j'ai supprimé le fichier .htaccess.

J'ai maintenant un autre petit problème: pour accéder au back-office, j'ai donné une adresse e-mail, mais j'ai fait une erreur en la rentrant,... impossible de récupérer le mot de passe. quelqu'un sait-il comment je peux corriger ce problème???

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More