Jump to content

Errore immagini sottocategorie


skic89
 Share

Recommended Posts

Ciao a tutti,

 

premetto che giorni fa avevo già segnalato questo problema, anche sul bug tracker. Ad oggi dopo svariate prove ho notato altri problemi ancora più sconcertanti.

 

Seppure sia comparsa una nuova voce "miniatura categoria" con l'aggiornamento 1.6.1.2, le sottocategorie continuano a mostare un'immagine diversa, che non è appunta "miniatura categoria" ma bensì "immagine di copertina categoria" in miniatura.

 

Scavando più a fondo ho notato che sul front-end l'immagine di copertina della categoria e le miniature delle sottocategorie, vengono pescate ad indirizzi diversi (medium_default e category_default). medium_default altro non è che una copia in miniatura di category_default. 

 

Secondo voi rinominando l'immagine in img/c/14-medium_default.jpg e mettendo al suo posto con lo stesso nome quella giusta sono in grado di vedere l'immagine corretta nel front-end?? Assolutamente no... sembra indemoniato!!

Le ho provate tutte, svuotare la cache... rigenerare le miniature.. ma niente..

 

Qualcuno ha idea di come si possa fare per risolvere questo problema?

 

Grazie a tutti in anticipo!

post-1124028-0-49581500-1446463917_thumb.png

post-1124028-0-36946800-1446463924_thumb.jpg

Share this post


Link to post
Share on other sites

  • 1 month later...

Ciao a tutti,

 

premetto che giorni fa avevo già segnalato questo problema, anche sul bug tracker. Ad oggi dopo svariate prove ho notato altri problemi ancora più sconcertanti.

 

Seppure sia comparsa una nuova voce "miniatura categoria" con l'aggiornamento 1.6.1.2, le sottocategorie continuano a mostare un'immagine diversa, che non è appunta "miniatura categoria" ma bensì "immagine di copertina categoria" in miniatura.

 

Scavando più a fondo ho notato che sul front-end l'immagine di copertina della categoria e le miniature delle sottocategorie, vengono pescate ad indirizzi diversi (medium_default e category_default). medium_default altro non è che una copia in miniatura di category_default. 

 

Secondo voi rinominando l'immagine in img/c/14-medium_default.jpg e mettendo al suo posto con lo stesso nome quella giusta sono in grado di vedere l'immagine corretta nel front-end?? Assolutamente no... sembra indemoniato!!

Le ho provate tutte, svuotare la cache... rigenerare le miniature.. ma niente..

 

Qualcuno ha idea di come si possa fare per risolvere questo problema?

 

Grazie a tutti in anticipo!

Anche io ho lo stesso problema, addirittura non mi visualizza per niente le immagini delle miniature nelle categorie sulla 1.6.1.2, forze bisogna aspettare un'aggiornamento, se qualcuno ha una soluzione sarebbe gradita.

Share this post


Link to post
Share on other sites

  • 3 months later...

Scusate! Ripesco questo post, versione 1.6.1.4 ho lo stesso identico problema, non mi fa vedere le immagini che carico nelle categorie, mi fa sempre e solo vedere NO IMAGE AVAILABLE. Come posso risolvere?

Grazie!

Share this post


Link to post
Share on other sites

  • 3 months later...

Mi aggiungo alla lista delle persone con problemi: miniature delle sottocategorie non si vedono proprio, mentre quelle delle categorie padri si vedono, ma in posizione infelice come si vede dall'immagine:  https://drive.google.com/open?id=0B_oijrZrEaYGc0d2YXFqXzZyVWM

 

Qualcuno con una idea?

 

Grazie.

 

Versione di PrestaShop 1.6.1.4

URL del negozio http://bbhands.com/

Nome del tema utilizzato default-bootstrap

Edited by skara (see edit history)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Anche io ho lo stesso problema, le miniature delle sottocategorie si vedono solo impostando la stessa immagine come copertina della sottocategoria, il problema è che se avete messo anche una descrizione alla sottocategoria, questa si sovrappone alla miniatura e diventa un testo bianco illegibile.

Share this post


Link to post
Share on other sites

Mi aggiungo alla lista delle persone con problemi: miniature delle sottocategorie non si vedono proprio, mentre quelle delle categorie padri si vedono, ma in posizione infelice come si vede dall'immagine:  https://drive.google.com/open?id=0B_oijrZrEaYGc0d2YXFqXzZyVWM

 

Qualcuno con una idea?

 

Grazie.

 

Versione di PrestaShop 1.6.1.4

URL del negozio http://bbhands.com/

Nome del tema utilizzato default-bootstrap

Scusa , ho visto il tuo sito e mi sembra che hai risolto, come hai fatto?

Share this post


Link to post
Share on other sites

Io non ho risolto il problema ma penso di aver capito come aggirare il problema.

 

1. Inserire come copertina della sottocategoria un immagine sfondo nero o scuro tinta unita dimensioni 870x217 pixel

2. Inserire una descrizione della sottocategoria ,altrimenti comparirà solo il quadrato nero.  (inoltre è fondamentale per la SEO ;-)

3. Impostare come miniatura della sottocategoria un immagine a piacere.

4. Svuotare la cache del browser e verificare come vengono visualizzate le modifche apportate.

 

In questo modo la descrizione della sottocategoria sarà visibile in quanto scritta bianca su sfondo nero, e la miniatura della sottocategoria viene visualizzata correttamente.

 

Nel mio caso funziona, non so se è così per tutti

Edited by vanart (see edit history)

Share this post


Link to post
Share on other sites

Io non ho risolto il problema ma penso di aver capito come aggirare il problema.

 

1. Inserire come copertina della sottocategoria un immagine sfondo nero o scuro tinta unita dimensioni 870x217 pixel

2. Inserire una descrizione della sottocategoria ,altrimenti comparirà solo il quadrato nero.  (inoltre è fondamentale per la SEO ;-)

3. Impostare come miniatura della sottocategoria un immagine a piacere.

4. Svuotare la cache del browser e verificare come vengono visualizzate le modifche apportate.

 

In questo modo la descrizione della sottocategoria sarà visibile in quanto scritta bianca su sfondo nero, e la miniatura della sottocategoria viene visualizzata correttamente.

 

Nel mio caso funziona, non so se è così per tutti

 

posteresti il tuo sito per vedere il risultato per favore?

Share this post


Link to post
Share on other sites

Scusa , ho visto il tuo sito e mi sembra che hai risolto, come hai fatto?

 

Non ho proprio risolto perchè la soluzione adottata ha dei limiti in visualizzazioni da cellulare/tablet o rimpicciolendo la schermata, comunque io ho fatto così:

 

ho impostato la/le immagini delle categorie (figlie) sulla categoria padre facendo un pò di tentativi sulle dimesioni in modo da allineare le immagini ai nomi delle catogorie. Questo metodo però ha funzionato solo se le categorie figlie sono massimo 3. Per la categoria "Woman" del mio sito non saprei come fare. 

Nota: per la categoria "Man" ho dovuto inserire due immagini come vedi dalla figura in questo post, una con due bracciali e una con uno solo. Non ho trovato altre strade, ma proverò quella di vanart.

 

Fammi sapere se non sono stato chiaro

 

post-829495-0-60751200-1471941952_thumb.jpg

Edited by skara (see edit history)

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Grazie a vanart per l'aiuto, ma questo thread non è chiuso, perchè il problema rimane tale e quale. L'ho aggirato, ma capisco che quanto chiedo non è fra le funzionalità del template base di prestashop probabilmente.

Share this post


Link to post
Share on other sites

  • 2 years later...

Nonostante sia una versione vecchia, volevo dare il mio contributo, io avevo lo stesso problema, nel back-end visualizzavo l'immagine se provavo a modificare la categoria/sottocategoria ma nel front-end molte sottocategorie erano sprovviste di immagini nonostante la presenza nel back-end, io ho risolto semplicemente andando in

Impostazioni

Immagini

RIGENERA MINIATURE

Seleziona immagine impostato su TUTTO

Cancella immagini impostato su NO (in modo da evitare il fatidico errore 500)

Fatto questo ho cancellato i cookie del browser e sono diventate visibili anche nel Front-end

Share this post


Link to post
Share on other sites

  • 10 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More