Jump to content

Recommended Posts

Ik heb zeer waarschijnloijk 'het' Friendly URL probleem.

Ik draai de webshop op een webserver thuis (en niet bij een hoster)!

 

De module mod_rewrite is geladen in PHP.

 

 

Zodra er in de webshop meer dan 1 taal is ingesteld veranderd de url van:

xx.xx.xxx.xx/domeinnaam/idex.php   naar:

xx.xx.xxx.xx/domeinnaam/nl/idex.php of /en/ of /du/.

 

Vervolgens treedt de volgende fout op: 

The requested URL xx.xx.xxx.xx/domeinnaam/nl/ was not found on this server.

 

Ik heb allerlei oplossingen van internet geprobeerd zonder resultaat.

 

Versies:

Presta 1.6.1.1

Linux Mint 17.2 Cinnamon 64bit Versie / Cinnamon 2.6.13

Linuxkernel 3.16.0-38-generic

 

De rechten op het .htaccess bestand zijn -rw-r--r--

 

Heb zelfs van een cloud-shop het .htaccess bestand gekopieerd en aangepast (domein en cloudinstelling)

 

Het enige wat er mogelijk nog mee te maken zou kunnen hebben is dat in de map /var/www/html/ een index.php bestand staat dat redirect naar /var/www/html/domeinnaam.

 

Wie weet raad.

Edited by BertGr (see edit history)

Share this post


Link to post
Share on other sites

@mdekker: heb mijn laatste antwoord even aangepast ;-) 

 

waarom?

1. het zal een kleine webshop zijn met weinig gelijktijdige gebruikers.

2. om de hostingkosten te vermijden

3. in de cloud werken een aantal module (zoals mollie payment provider) niet 

en last but not least:

4. in de prestacloud, zo heb ik ergens gelezen, kan mijn domeinnaam niet gebruikt worden, enkel als verwijzing naar een pswebshop subdomein?

 

 

Edit: mijn virtualhost is identiek aan wat jij opgeeft

Edited by BertGr (see edit history)

Share this post


Link to post
Share on other sites

<?php

header("Location: http://xx.xx.xxx.xx/domeinnaam/index.php")

?>

 

waarbij 'domeinnaam' overeenkomt met de map: var/www/html/domeinnaam

 

en de index.php in DIE map is de standaard prestawebshop index.php

 

 

 

 

LET WEL: de webshop werkt(e) prima, totdat ik de setting 'Friendly URL' aan zet(te).

Edited by BertGr (see edit history)

Share this post


Link to post
Share on other sites

hielp ook al niet ;-(

 

zodra ik Friendly URL aanzet is het mis, zet ik het uit is het weer OK

 

na aanzetten redirect de browser vanaf de standaard URL xx.xx.xxx.xx/domeinnaam naar xx.xx.xxx.xx/domeinnaam/en  (zonder index.php)

na uitzetten leidt het ip-adres xx.xx.xxx.xx naar xx.xx.xxx.xx/domeinnaam/index.php

 

 

Bij uitgeschakeld 'Friendly URL's' werkt de webshop verder goed (voor zover ik heb gezien).

Alle links werken, alle plaatjes staan er.

Share this post


Link to post
Share on other sites

ik weet niet waarom

 

maar ik heb de tutorial over de .htaccess die onder het artikel over virtual-host stond gelezen

de .htaccess geopend, gesloten zonder wijziging

voor de zoveelste keer de apache2 service geherstart

de browser gerefreshed

 

 

en tot  mijn stomme verbazing werd ineens de pagina WEL geladen: xx.xx.xxx.xx/en    en xx.xx.xxx.xx/en/home/11-artikel.html 

 

 

 

Edit: voor de volledigheid

 

ik had daarvoor nog de 000-default.conf gekopieerd, aangepast en hernoemd naar domeinnaam.conf

deze geregistreerd met: sudo a2ensite mijndomein.conf

zonder resultaat

daarna de 000-default.conf gedisabled met: sudo a2dissite 000-default.conf

(n.a.v. comments onder het artikel dat je linkte)

Edited by BertGr (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More