Jump to content
Figurine Occasion

The SMTP connection failed to start [tls://smtp.gmail.com:587]

Recommended Posts

Bonjour,
 
J'essaie de configurer l'envoi de mail d'une de mes boutiques en ligne et j'ai le message d'erreur suivant:
 
Erreur : veuillez vérifier votre configuration
 
 
Pour info, voici les infos que j'ai rentre:
 
Nom de domaine des e-mails:
Serveur SMTP: smtp.gmail.com
Utilisateur SMTP: mon.email@gmail.com
Mot de passe SMTP: *******
Chiffrement: TLS
Port: 587
 
J'utilise d'autres application ou je parametre les infos de la meme maniere et je n'ai aucun soucis d'envoi d'email ...
 
Le  soucis est que si j'utilise la methode classique a savoir : "Utiliser la fonction mail() de PHP (recommandé ; fonctionne dans la majorité des cas)"
Les emails vont toujours dans les spams directement.
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour le SMTP sécurisé GMAIL, attention à l'ouverture de sports (587 OK ?) sur le serveur.

Pour les mails en spam, il faut voir du côté du serveur surtout, mutualisé, dédié ? Blackliste ?

Share this post


Link to post
Share on other sites

Le problème vient de la très vieille version de swiftmailer 3.3.2 qui date d'octobre 2007 qui ne sait pas gérer TLS.

La solution est de mettre la dernière version de swiftmailer et de modifier le fichier /classes/Mail.php pour tenir compte de la dernière version de swiftmailer.

Le fichier /classes/Mail.php modifié est la :

https://github.com/WassimAttar/PrestaShop/blob/patch-1/classes/Mail.php

Pour la dernière version de swiftmailer, c'est la :

https://github.com/swiftmailer/swiftmailer/tree/5.x/lib/

Faut supprimer /tools/swift/* et copier la dernière version.

 

Share this post


Link to post
Share on other sites

Bonsoir,

 

J'ai le même problème... et j'ai modifié le fichier Mail.php et remplacé les fichiers de swiftmailer mais l'envoie du mail "tourne en rond"....

 

Quelqu'un a déjà essayé cette solution de Strawberries ou peut être une  autre idée??

 

Merci!

Share this post


Link to post
Share on other sites

C'est normal que ça ne marche pas.

T'as récupéré la version de développement qui sera peut être intégrée dans la prochaine version de prestashop.

Pour la version actuelle de prestashop, récupère le fichier en pièce jointe.

Pour tester le bon fonctionnement faut procéder ainsi avec un compte gmail :

 

1) ssl

smtp : smtp.gmail.com

login : xxxx@gmail.com

pass : xxxx

port : 465

protocole : ssl

 

Si ça marche, tester avec tls.

 

2) tls

smtp : smtp.gmail.com

login : xxxx@gmail.com

pass : xxxx

port : 587

protocole : tls

 

Mail.php

Share this post


Link to post
Share on other sites

Ça marche nickel!!!

 

Un énorme Merci !!!  :)  :)  :)

 

J'avais passé beaucoup de temps pour monter mon serveur de mail tip-top et ne pas pouvoir l'utilisé me donnait des boutons!!!

 

 

Bonne journée!

Share this post


Link to post
Share on other sites

Euuuhh, 

 

lors d'un deuxième essai, j'ai le message d'erreur suivant

 

Erreur : veuillez vérifier votre configuration
Unable to connect with TLS encryption

 

Une idée??

Share this post


Link to post
Share on other sites

Est ce que ça marche avec gmail en ssl ?

Si non, c'est qu'il y a un problème avec l'installation de mon Mail.php

Vérifie que prestashop ne l'as pas écrasé après une mise à jour.

Note que classes/Mail.php et tools/swift/ seront effacés après chaque mise à jour de prestashop.

Share this post


Link to post
Share on other sites

Oui ça marche avec gmail en ssl et tls... donc ça doit être mon serveur mail qui pose problème...

 

Je me penche dessus...

 

Merci encore!

Share this post


Link to post
Share on other sites

Les tests de référence sont sur gmail qui accepte les 2, ssl et tls.

ça permet ensuite de valider chez d'autres fournisseurs.

Exemple de configuration chez ovh sur un compte exchange qui accepte uniquement tls :

smtp : ex.mail.ovh.net

port : 587

protocole : tls

Share this post


Link to post
Share on other sites

La version 1.6.5 inclut la dernière version de swiftmailer 5.x

Par conséquent mon fix n'est plus nécessaire.

Mettez à jour votre prestashop et le TLS marchera.

Share this post


Link to post
Share on other sites

Mise à jour de Prestashop (the 1(00000) clics update module) et tout a marché pour moi sur hébergement Infomaniak.

Merci beaucoup !

Share this post


Link to post
Share on other sites

 

Bonjour,
 
J'essaie de configurer l'envoi de mail d'une de mes boutiques en ligne et j'ai le message d'erreur suivant:
 
Erreur : veuillez vérifier votre configuration
 
 
 
Pour info, voici les infos que j'ai rentre:
 
Nom de domaine des e-mails:

Serveur SMTP: smtp.gmail.com

Utilisateur SMTP: mon.email@gmail.com

Mot de passe SMTP: *******
Chiffrement: TLS
Port: 587
 
J'utilise d'autres application ou je parametre les infos de la meme maniere et je n'ai aucun soucis d'envoi d'email ...
 
Le  soucis est que si j'utilise la methode classique a savoir : "Utiliser la fonction mail() de PHP (recommandé ; fonctionne dans la majorité des cas)"
Les emails vont toujours dans les spams directement.

 

 

Thanks,

 

Working fine for me on PrestaShop 1.7.0 

 

Regard,

Hardik

Share this post


Link to post
Share on other sites

Up ! 

 

 

Je suis sous gmail avec les config que vous avez donné..

Connection could not be established with host smtp.gmail.com [Connection timed out #110]

Edited by Martin Fabre (see edit history)

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Je suis sur la dernière version de Prestashop 1.6.1.17.

Hébergement => Serveur Dédié.

 

Impossible de faire fonctionner l'envoi de mail via SMTP Gmail SSL 465...(ou TLS 587)

 

Erreur : veuillez vérifier votre configuration
Expected response code 250 but got code "535", with message "535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials 31sm4786964wru.33 - gsmtp "

 

Pour info, j'ai autorisé les applications moins sécurisées dans les paramètres du compte Google.

D'ailleurs sur le même serveur et même config SMTP, MAIS autre CMS => Wordpress => Extension "easy smtp", l'envoi de mail fonctionne parfaitement...

 

Du coup, je me demande si la function Php d'envoi de mail via serveur SMTP, utilises bien l'option d'authentification ? (qui n'est pas proposé dans les options de paramétrage du smtp prestashop)

 
Par ailleurs, je viens de remarquer que le mot de passe du compte pour la configuration SMTP était enregistré sans encodage en base ? C'est le cas pour tout le monde ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More