Jump to content
tomerg3

[MODULE] Attribute Wizard Pro - Create unlimited attributes & combinations, choose frm 7 input types

Recommended Posts

We reply to all messages, keep in mind we are in the US, and this is holiday Friday night.

We received your message and someone will get back to you.

 

Make sure you get the auto-confirmation email after you sent the message, if you did not, then check your spam folder.

Share this post


Link to post
Share on other sites

sir...how soon can you fix my site...? i already send you all the ftp info 24hrs ago...

i don't care how ppl rate you

i also read how alot of ppl hate your service

i don't care i just need this module installed properly because i paid $150USD that i don't have.

please fix asap thank you and i hope you work on weekends because i can see monday i'm here again.

thanks in advance.

Share this post


Link to post
Share on other sites

Just to update about my issues with attributes not sorting - turns out that in the database and the BO i was referring to my shop's url differently - (www. versus no-www) and this was causing some problems. All sorted now - nothing to do with the module.

Share this post


Link to post
Share on other sites

The module doesn't create attributes, it uses the built in PS attributes.

 

The module lets you display attributes as different form elements, and they apply to all shops that use that attribute group.

 

You can create a new attribute group for different shops, and set the module to display each of them differently.

Share this post


Link to post
Share on other sites

Hi

Small feature request :)

Can You please add possibility not only copy attributes between products, but also possibility to merge attributes.

Share this post


Link to post
Share on other sites

I bought the module and when I chose a product I have this message:

 

"Warning: require_once() [function.require-once]: Unable to access /htdocs/config/../classes/8qqsqao1mm0taritpx.php in /htdocs/config/config.inc.php on line 21

 

Warning: require_once(/htdocs/config/../classes/8qqsqao1mm0taritpx.php) [function.require-once]: failed to open stream: Permission denied in /htdocs/config/config.inc.php on line 21

 

Fatal error: require_once() [function.require]: Failed opening required '/htdocs/config/../classes/8qqsqao1mm0taritpx.php' (include_path='.:/usr/share/php:/usr/share/pear') in /htdocs/config/config.inc.php on line 21"

 

Could you help me?

 

I have PS 1.3.6.0

Edited by vincebesak (see edit history)

Share this post


Link to post
Share on other sites

Spott: We'll add it to the wishlist.

 

Vince: we replied to your message on our site, please only use the contact form for technical issues.

Share this post


Link to post
Share on other sites

Hi there, this module looks like exactly what my client is after and I am really impressed by the good reviews. I wanted to try out the demo for myself, but it doesn't seem to be working as expected so I just wonder if I can clarify a few things.

 

My client is a printer (clothing, office stationery) and needs a solution for product customisation - most importantly they want the buyer to be able to upload hi-res images that come through with the order and can be easily downloaded by the shop owner, as well as custom text etc. Is this possible? In Prestashop there's a panel for Product Customization natively, but it never seems to work properly - Any images that get uploaded to it are impossible to download properly from the backend - appearing thumbnail-sized and impossible to do anything with. Is this module a good substitute for that?

 

If this project goes ahead, will be using the most recent version of 1.5 for it.

Share this post


Link to post
Share on other sites

Yes, you can us if for file upload (not requires an additional "save" button).

 

You can also assign a price impact for the file upload to increase or reduce the price if an image is uploaded.

  • Like 1

Share this post


Link to post
Share on other sites

Cool thanks for that really fast response. :)

 

Are multiple image uploads supported? From the looks of what I've read, they are. Also wondering about size and file type restrictions for images. Can you set these per file?

Share this post


Link to post
Share on other sites

For multiple file uploads, simply create multiple attributes.

 

You can set the max file size and type (as long as it's equal or lower than the max limit set in PHP)

Share this post


Link to post
Share on other sites

how can i import attributes to product ? becouse i have excel price-list , and theres about 1000 products with about 30-40 attributes per product ? maybe any mysql import or something ?

Share this post


Link to post
Share on other sites

You would have to either modify the existing combinations import tool, or create a new one that will use the same combination structure as the module requires.

Share this post


Link to post
Share on other sites

but any product have other prices for that ... :<

product1 attribute1 attribute2

100 200 300 = 600

product2 attribute1 attribute2

300 300 600 = 1200

 

etc...

and its about 1000 product - so i need to make one combination, copy it to all, and edit on every product ?

Share this post


Link to post
Share on other sites

You can either create a custom import tool, or you can use the attribute copy option in our module.

 

If you are not using many attributes for a single product, you may be able to use the regular Attribute Wizard, and not the Pro, and then you would be able to import attributes using the built in Prestashop importer.

 

If you contact us through our site we could send you the regular version.

Share this post


Link to post
Share on other sites

I had it and did not work well, and i stay at attribute wizard pro :< its 30 attribute to add in each product ;<

15 colors of body, 15 colors of front, 6 accesiories , 3 depth ... to big

Share this post


Link to post
Share on other sites

Hi

 

A simple example - If I have product Attributes such as

 

Background Colour

Text Colour

Text

 

I can see using AWP I can use the Layered Images to show the selected result of Background Colour and Text Colour

But do you know of any way I can use the Text entered by the customer and display it in the Layered Image?

(Rather than using "Your Text" for example as a fixed result)?

Share this post


Link to post
Share on other sites

That feature does not exist in the module now, you can add it yourself, or contact us about a customization.

Share this post


Link to post
Share on other sites

The module uses the built in attribute textures (images) that comes in Prestashop.

 

You can assign an image to an attribute if the attribute group is set to color group (in Catalog->attributes and values or groups), then edit each attribute and add an image.

 

The attribute images (the ones on the left side in the example site) are added from within the configuration page of the module.

Share this post


Link to post
Share on other sites

Thank you so much for the quick response. Worked great.

 

One last question. How do you center the attribute value to align with the center of the image. My is aligned to top of image.

 

Thank you.

Share this post


Link to post
Share on other sites

Look in the configuration page next to each attribute group for "Layout", change it from horizontal to vertical.

Share this post


Link to post
Share on other sites

Thanks .. but this places the attribute value below the image not to the right center of the image.

Share this post


Link to post
Share on other sites

Hmm, then I misunderstood, you can try using firebug for firefox and play with the CSS as you wish.

Share this post


Link to post
Share on other sites

Hi,

Is it possible to restrict the input of the textbox? For instance, only capitals are allowed, no numbers, no comma's. etc. Or do I need to customize it? And if so, do you think it is doable? I can imagine you need some javascript and then add it to the input.

Share this post


Link to post
Share on other sites

The module doesn't have those restrictions, they can be added, with some Javascript validation skills

Share this post


Link to post
Share on other sites

Hi, i just bought this module today. This works prefect and I created a new hook for the module. But i can't just put this hook before le form id="buy_block". If i try to do that, attribut will not go to the cart with the product. I think it's logic to put the module before the button "add to cart" because u have to personalize your product before add to cart. Any idea?

Share this post


Link to post
Share on other sites

You cannot have the hook in a <form> element.

 

The module has a built in option for an additional add to cart button at the bottom (enable from the configuration page).

Share this post


Link to post
Share on other sites

No its not in the <form>. I placed the module's hook before the <form id="buy_block">.That mean the module is placed before quantiy, description and button add to cart. But it doesn't work because the cart did not take attirbut into account. I checked the option place the button add to cart when there are more of 1 attribut's group selected but the button add to cart is always before a module.

Edited by chicco1206 (see edit history)

Share this post


Link to post
Share on other sites

Hello to All

 

Congratulations on your module "attribute wizard Pro" bought yesterday and already is working in my shop, I have a bug that is this, after configuring the product should appear in the choices the customer order, and this is not happening in my store ... I wanted to ask for your help

 

http://artstuffconcept.com/loja/consolas/400-consola-zig.html

post-416850-0-49679600-1363380068_thumb.jpg

Edited by Vitor Nogueira (see edit history)

Share this post


Link to post
Share on other sites

Hi I have installed the module correctly (1.5.3). However how do I add a new attribute type text box? I still have the standard attribute type dropdown, radio button and color..

Share this post


Link to post
Share on other sites

Hi I have installed the module correctly (1.5.3). However how do I add a new attribute type text box? I still have the standard attribute type dropdown, radio button and color..

nvm figured it out.

 

Another question, when I add a product with awp attribute to my cart I can't remove it from my cart, it seems ajax not working. Any idea what is causing this?

Share this post


Link to post
Share on other sites

Also, how/where can I re-position the box "product options"? For instance I like to have the box below "add to cart" button next to the product image.

 

Second, if I view categories, the product prices are included with the attributions thus higher than base prices. How can I show the base prices in the category view?

Share this post


Link to post
Share on other sites

Cabb: please use https://www.presto-changeo.com/en/contact_us for any technical questions.

Your theme is probably overriding the blockcart module, which is why it is not deleting from the cache.

You can use the custom hook that comes with the module to place it elsewhere on the product page (as long as it's not inside a <form> tag

Share this post


Link to post
Share on other sites

Hi,

I already submitted my question through the presto website. But I haven't received an answer yet.

 

Anyways I had a question which I experienced with the demo itself as well. I think this is related to the module itself. If you have a product which costs 10$ and an optionable attribute of 2$. The product list in the category already shows the prices including with the attribute thus 12$ instead of 10$. How can I change this that the product list view just show the price of the product itself (10$) without the increased price due to the attribute?

Share this post


Link to post
Share on other sites

Hi tomerg3,

 

I've already bought this module before for another client and the support was great, but now I have a problem and it's the third time I contact (first time, 12/03) and I received no answer about my issue. I just sended another message via your support form.

 

The problem is that the values of the combination are not shown. I only add one attribute with one value, but the select displays none. Did anyone know what could be happening? I'm using Prestashop 1.5.2.0.

 

Thanks in advance.

  • Like 1

Share this post


Link to post
Share on other sites

V1.5.4 released

* Added support for PS 1.4.10

* Fixed support for multistore.

* Added support for advanced stock management + warehouse.

* Added checkbox support for attribute layered images.

* Attribute layered images are now ordered to match the groups (z-index value).

* Added option to display attribute layered images in popup mode (adding the product image).

* Fix for cart block display when using product with and without attributes.

  • Like 1

Share this post


Link to post
Share on other sites

I am looking to see if any knows how to resolve this problem.

 

AWP is installed and working fine in the Product Page.

 

The problem is when I click on add to cart button from the Product list page (shows multiple products) it puts the product into the cart (even though it requires attributes to be filled out)

 

How can I deactivate the Add to Cart button on the product list page or change this button to go to Product Page?

 

Thanks

Share this post


Link to post
Share on other sites

Hello i used this module in prestashop 1.5.3.1 and i have 1 small problem when adding product with attributs in ajax cart. When i click the button "Add to Cart". 2 products are added in ajax cart, 1 with all attributs i have chosen before and another with no attribut . I think it have relation with ajax cart because when i check the cart page. There are just 1 product with the right price. How could it be?

Edited by chicco1206 (see edit history)

Share this post


Link to post
Share on other sites

Although we have changed almost all the code for the operation of the module is a Excellent module and recommend !

Share this post


Link to post
Share on other sites

Hi,

 

Is it possible to have something like tree options.

If u choice type A u get a list of colors with 2 prices, when u select type B u get a diff color group with there own prices

 

For example:

First option (attribute: Type):

- Type a

- Type b

 

Colors for Type a:

- color 1 2 and 3 (+10,00)

- color 4 5 and 6 (+15,00)

 

Colors for Type b:

- color 1 2 and 3 (+2,50)

- color 4 5 and 6 (+7,50)

 

(These 2 color groups can be diff attribute groups)

 

Can this be done ?

Share this post


Link to post
Share on other sites

No, the module currently does not support connected attributes.

 

You can use the regular Attribute Wizard to do that, as it does not change the default combination structure in Prestashop (which has 1 attribute from each group).

 

We plan on adding the ability to use connected attributes in the future, however, it would be a while before we get to it (it requires a pretty massive rewrite / change of approach to combinations).

Share this post


Link to post
Share on other sites

I have 1 small problem with IE. With all IE version a file css awp.css is not loading. Do you have a solution with this pb? Thanks

Share this post


Link to post
Share on other sites

Do you have CCC enabled for CSS files?

IE cannot load more than ~30 css files, if you do not use the compression option, some CSS files will be ignored.

Share this post


Link to post
Share on other sites

There is something wrong with the custom hook, because I cant add the hook where I want in the product.tpl file, I added the {hook h="awpProduct"} in product.tpl (not within form tag) right before the product description. But it wont show up there. I think the hook is not working for some reason. I removed the hook from product footer as instructed but yet its not working. I use PS 1.5.3 any idea what could be the problem?

Share this post


Link to post
Share on other sites

Hello, we are suffering with a bad issue here. After we install the Attribute Wizard Pro module, we are not able to order any product. The message we get is "You already have the maximum quantity available for this product.". I tried multiple solution, but none of them worked. The shop version is 1.5.2.0 and module version 1.5.5. Czech interface. Thanks for any ideas.

Share this post


Link to post
Share on other sites

Hello, we are suffering with a bad issue here. After we install the Attribute Wizard Pro module, we are not able to order any product. The message we get is "You already have the maximum quantity available for this product.". I tried multiple solution, but none of them worked. The shop version is 1.5.2.0 and module version 1.5.5. Czech interface. Thanks for any ideas.

 

Hi Karel, I found a solution to this problem, you should add quantity to all of your combinations then it will work.

Share this post


Link to post
Share on other sites

Yes, I already did that.. But it did not help. I also thought that it was connected with the quantities, so before i asked here I had set in db manually quantity to all products and all items in _product_attribute table. But no success.. I also forced template compilation and removed the cache, to be sure there is nothing in cache.. But still getting this message.. Some people across internet suggest to install the shop again from the scratch, but for me this would be really the last possible solution.. I would like to find the reason of this behaviour.

Share this post


Link to post
Share on other sites

V1.5.6 released

* Fix for ordering of out of stock products.

* Fix for disabled add to cart (PS 1.4.10 only)

* Fix for updating cart quantity (PS 1.5.4)

* Disable add to cart for product with attributes in homepage.

Share this post


Link to post
Share on other sites

this module dont work in 1.5.3,

 

I have folllowd the installation guide, but the atrributes wont show in de product page...

 

pleaseee help!!!

Share this post


Link to post
Share on other sites

Hi,

give an example to explain better ... I have a product (t-shirt) with 3 different attributes: attribute A (6 materials), attribute B (20 colors), attribute C (20 colors). I must set different combinations material - color B - color C, doing so, eg, that for the material x are only available colors (b and c) from 1 to 17, while for the material y colors only from 18 to 19.

Is it possible? I tried to configure the module but all colors are always available for any material.

In other words, in addiction to connected attributes, i need to use the layered images provided by AWP...so how can i do?

 

Thanks

Andrea

Share this post


Link to post
Share on other sites

Connected attributes are not supported by this module, as the structure of the combinations was changed, to allow for adding unlimited number of attributes per product.

Share this post


Link to post
Share on other sites

Connected attributes are not supported by this module, as the structure of the combinations was changed, to allow for adding unlimited number of attributes per product.

 

Plan to support connected attributes it in the future? Thanks

Share this post


Link to post
Share on other sites

Hello, i'm now using AWP for few months that's a really good module. I'm now trying to get minimalism design and I would like to know if it's possible to do like this picture I just made for the example.

 

example.jpg

Without description or without short description. Attributes pictures are on the left, main article picture is on the right.

 

So, is it possible to do ? Where shall I have to made changes (Product.tpl ???).

 

Regards

Edited by guillaumel (see edit history)

Share this post


Link to post
Share on other sites

Hi

 

We have been using this module fine for some time on our site. However - recently, things have gone very wrong.

 

We can no longer change attribute display type. Clicking reset, sets them all to dropdowns, however, if we change them from these, changes do not get saved when clicking update.

Also -> upon clicking update the last three attribute options in the list change their type from dropdown to: (Image Single-Select)

 

This is kind of matter of urgency for us as Accessories can no longer be multiselected - and some just do not appear now.

 

--UPDATE

 

Problem Solved by Tomer Thanks!

Ref: http://presto-changeo.tumblr.com/post/17589539698/understanding-php-ini-how-and-why-you-need-one

Specifically: "increase the max_input_vats value in your php.ini to 10000"

 

Much Appreciated

Edited by mrotacon (see edit history)

Share this post


Link to post
Share on other sites

Plan to support connected attributes it in the future? Thanks

 

Yes, but we do not have a date of timeline, it would likely be a few more months.

Share this post


Link to post
Share on other sites

May I know why the attributes checkbox not working in Mobile theme?

It show error: "Uncaught ReferenceError: aw_select is not defined"

Share this post


Link to post
Share on other sites

This thread if for the Pro version, not the regular Attribute Wizard.

 

It would really depend on the mobile theme, and the hooks it uses, most likely, a hook that the module uses is not being loaded, and that's why you see the Javascript error.

 

This is another example why a responsive theme is generally better than a dedicated mobile theme.

Share this post


Link to post
Share on other sites

This thread if for the Pro version, not the regular Attribute Wizard.

 

Hi,

i'm using the pro version and i've the same problem. Wizard attributes displays with the "$HOOK_PRODUCT_FOOTER" but none of the script and ccs are displaying. Is there any hook to add?

 

thanks

Share this post


Link to post
Share on other sites

I am using Prestashop 1.4.9, and recently upgraded AWP to 1.5.6. Now I am having a problem that has forced me the shut down my shop, at a very bad time.

 

Tomer, I sent you a couple of messages via Presto-Changeo contact form. In the meantime, I'm pretty desperate for suggestions.

 

What seems to be happening is that when the customer submits an item to add to cart after customizing, even through quantity shows 1, the cart in incrementing by 3. <i>This does not happen every time</i> but it happens often enough to be a huge problem.

 

I am using the Add to Bottom display option. Another problem is that the product page template's add to cart button still shows up at the top, and if used, does not catch required attribute fields and does not pass any attribute data to the cart. I "solved" this by using css (display:none;) to take the button off the page in the product page template. The AWP add to cart button does catch required fields being empty, but when used, is submitting multiple quantity (always 3) instead of 1, almost every time. (The "almost" is driving me crazy, I can't track down the variable factor.) I should add, it does this whether the product page template's add to cart button is visible or not.

 

I notice that when the AWP add to cart submit is used and a required attribute field is empty, it and pops up a prompt, but the first time, the pop up prompt does not dismiss properly - when acknowledged, a second one pops up before the field can be filled in, and a third one immediately when the second is dismissed, the third pop up offering a check box to "Prevent this from creating additional dialogs."

 

Any suggestions? Anyone have a similar issue?

 

Here is a url for a test product, if anyone wants to look, but the cart is live (products are pulled except for test product which is not linked visibly) so do not complete a transaction, you will be charged.

 

http://www.runningal...5-mile-run.html

 

My shop is down, my employer is unhappy, my customers are frustrated, and I'm at wits end.

 

bjp

Share this post


Link to post
Share on other sites

I am using Prestashop 1.4.9, and recently upgraded AWP to 1.5.6. Now I am having a problem that has forced me the shut down my shop, at a very bad time.

 

(snipped)

 

Huge thanks to Tomer and Christina and anyone else over there who looked at this and solved my weird problem.

 

I could not be more grateful or impressed by you folks over at Presto-Changeo, and not for the first time.

 

bjp

Share this post


Link to post
Share on other sites

No, the module currently does not support connected attributes.

 

You can use the regular Attribute Wizard to do that, as it does not change the default combination structure in Prestashop (which has 1 attribute from each group).

 

We plan on adding the ability to use connected attributes in the future, however, it would be a while before we get to it (it requires a pretty massive rewrite / change of approach to combinations).

 

damn.. this interests me as well :P

Share this post


Link to post
Share on other sites

Hello,

 

I have AWP 1.5.5 ... and I have many attributes and values created in it... How can I update to 1.5.6 without losing my data?

 

Thanks for quick reply :)

Share this post


Link to post
Share on other sites

Hello, I sent you a developpment request few weeks ago but I didn't get any answer, I would like a product page developpment to get something that look like that :

 

example.jpg

 

Is it possible to do it with AWP ?

 

PS. I already own AWP

 

Regards

Edited by guillaumel (see edit history)

Share this post


Link to post
Share on other sites

We replied, must have went to your spam.

You can contact us again, and ask for a direct email reply as well.

Share this post


Link to post
Share on other sites

Hi,

 

I have a problem with att wiz pro and multistore. The attributes are not shown with the products of the generated second store. Any ideas? Btw, i am using ver. 1.5.5

 

Probably has nothing to do with the module; i see in the source code the AWP code isnt loaded for the Product footer hook (or any other)

The hook is installed correctly for the modules in each shop.

 

Btw, i think it is not nice to post only positive reviews about the module on the presta-changeo website. Also negative remarks helpn people make the right choise. The support form on the website is horrible!

Edited by bannerclick (see edit history)

Share this post


Link to post
Share on other sites

Did not get any response sofar... I installed a new local testshop, and installed AWP after i created 2 multistore shops. Also here, the configurator is not showing up, so i guess the module does NOT support multistore (at least not for 1.5.4.1)

 

The website says it does support multistore.

 

Anyone a solution??

Share this post


Link to post
Share on other sites

The module works with multistore (you need to get a separate copy of the module for each store you use it on).

 

We offer a free 1 time installation for all our modules, which is why there are only good reviews on that product (that happens to be our best selling module).

 

We will be happy to help you install the module on your site.

 

We answer all customer service emails very fast, if you did not get an answer, you either did not contact us using the form on our site, or our response went to your spam folder (Did you get the automatic confirmation email after sending your message)?

 

Try contacting us again using https://www.presto-changeo.com/en/contact_us

Share this post


Link to post
Share on other sites

Hi Tomer,

do i understand right that i have to buy another copy of the module for the second store? Or do i have to change some items in the config.xml and install it next to the existing module?

 

Dont get me wrong, the module is very powerful and gives a great result, but i still think it has bugs, and setting it up correctly is impossible.

 

Support is answered in time, but i have to supply all server details before any answer is given?

Share this post


Link to post
Share on other sites

We are based in NY, if you are in Europe, and send us a message in your morning, it may seem like a long time until you get an answer, because of the 6-7 hour time difference.

 

When it comes to this module, since installation requires copying files, we do ask for access to the site to help with any technical issue, as we need to make sure the module was installed correctly, and that the combinations for products are added the way the module requires (and not the default Prestashop way).

 

Also, please do not use the forum for technical issue, as the notification system is often a bit wacky, and you could wait a few days without me noticing there was a question here...

Share this post


Link to post
Share on other sites