Jump to content
No0ki

Fehler "Das Feld id_state wird benötigt" beim anlegen neuer Adresse für UK

Recommended Posts

Nochmal nachdem ich auf die Website weitergeleitet wurde nachdem ich auf "Thema erstellen" geklickt habe -.-

 

 

Hi,

 

habe folgendes Problem:
Ein Kunde hat bemängelt das er seine Adresse nicht anlegene kann.

Wenn man eine neue Adresse für United Kingdom anlegen möchte, erscheint die Meldung "Das Feld id_state wird benötigt"

 

In den Ländereinstellungen habe ich bereits eingestellt das die Bundesländer für UK nicht vorhanden sind. Des Weiteren steht auch unter Pflichtfelder kein "id_state" dabei.

 

Das Problem tritt nur bei Adresse auf die für UK angelegt werden.

Ich hab im Forum und im Bugtracker bereits geschaut, dass soll sogar ein Feature sein welches man über die Pflichtfelder deaktivieren kann, klappt aber nicht da es dieses Pflichtfeld als Einstellungsmöglichkeit in der Liste nicht gibt.

 

Jemand Ideen? Vorschläge? Danke schon mal im Voraus

 

Gruß

No0ki

post-289266-0-59705800-1443889593_thumb.jpgpost-289266-0-85090000-1443889602_thumb.jpgpost-289266-0-18880800-1443889609_thumb.jpg

Edited by No0ki (see edit history)

Share this post


Link to post
Share on other sites

Hab das selbe Problem, Kunden können sich nicht anmelden, wissen nicht was los ist. = Absprungrate 100%!!!

 

Der ganze Pfusch im Prestashop nimmt kein Ende ..., man kann von sowas nur abraten. = Pure Zeitverschwendung und endloser Umsatzverlust!

 

Weiterhin viel Spaß damit ...

Share this post


Link to post
Share on other sites

Hallo nooki

zuerst würde ich mal die numerischen felder mit numerischen Nummern füllen

und nicht überall test reinschreiben

 

man muss gar nicht einstellen dass es bundesländer nicht gibt, das ist voreingestellt, da es in UK keine gibt

ich kann mir nur folgendes vorstellen:

dass das Lokaliesierungspaket UK manuell mit Bundesländern importiert wurde

 

vielleicht alles UK mal löschen und neu importieren (ohne Bundesländer)

 

und ich muss mich für den bösen Schlumpf entschuldigen, der ist leider immer noch nicht gesperrt....

(besser er lässt seinen Frust im Internet ab als auf der Straße (hoffentlich geht der nicht raus:-))

Share this post


Link to post
Share on other sites

Den Fehler kann ich für PrestaShop 1.6.1 nicht nachvollziehen, habe allerdings auch als Testversion 1.6.1.2RC3 eingesetzt.

 

@kulli

 

zuerst würde ich mal die numerischen felder mit numerischen Nummern füllen

und nicht überall test reinschreiben

 

Da hättest du aber bei GB Probleme, da die PLZ kein rein numerisches Feld ist. Es gibt sogar mehrere Varianten:

    LN NLL
    LNN NLL
    LNL NLL
    LLN NLL
    LLNN NLL
    LLNL NLL
    LLLL NLL

(L = Buchstabe, N = Ziffer)

 

PrestaShop lässt aber nur eine abprüfbare PLZ-Matrix zu. Daher darf man, wie das No0ki auch getan hat, keine Matrix hinterlegen.

Es liegt also nicht daran.

Ich vermute ein hartnäckiges Cache-Problem des Browsers - oder die Kunden vergessen, das standardmäßig aktivierte Land Vereinigte Staaten (mit States!) im Dropdown-Feld zugunsten von Vereinigtes Königreich (ohne States) abzuwählen. Kann man leicht übersehen!

 

Aber selbst dann würde nicht die fehlende id_state bemängelt!

 

Über welche PrestaShop-Version und welches Template reden wir denn hier eigentlich?

 

Share this post


Link to post
Share on other sites

Achherje, total den Thread vergessen :D

 

Erst einmal danke für die Antworten.

Ich habe selbst versucht im Backend einen neuen User anzulegen, gleiches gilt fürs Frontend.

 

Die Fehlermeldung wird immer ausgeworfen. Und ja, auch mehrfach explizip darauf geachtet das richtige Land ausgewählt zu haben.

 

Wir reden von Version 1.6.1.1 (starte soeben das Update auf 1.6.1.2

Es handelt sich um das Standard-Template (default-bootstrap 1.0)

 

//EDIT: Nach Update und erneutem löschen von United Kingdom + erneutem hinzufügen, gleicher Fehler.

Cach gelöscht, 2 Browser genutzt

Edited by No0ki (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More