Jump to content

Problema con loop di reindirizzamento


wiredmark
 Share

Recommended Posts

Ciao ragazzi,

 

ho un problema con il sito web del cliente e speravo che qualcuno che  magari in passato ci è gia incappato potesse darmi una mano. Questo è il mio primo post su questo forum, in quanto finora non ho mai dovuto affrontare problemi del genere.

 

Dopo aver configurato correttamente un sito web sviluppato con Prestashop per un cliente, sia in lingua italiana che in inglese, questo cliente ha effettuato l'accesso come amministratore ed ha installato un plugin che ritengo non sia troppo affidabile, chiamato Clean URLs, senza fare alcun backup. Dopo averlo rimosso, ciò che è successo è che andando sul sito web (http://russosalvatore.it/) e scegliendo la lingua inglese in homepage, si viene reindirizzati nuovamente alla versione in italiano. Tutte le altre pagine si traducono correttamente, ma se provo ad andare su un'altra pagina, impostare la lingua inglese e poi tornare in home, ottengo un loop di reindirizzamento.

 

Ciò che ho provato a fare io è stato un backup del file .htaccess, cancellando quello corrente, e provare a rigenerarlo, ma senza alcun successo. Sembra che disattivando i Friendly URLs le cose vadano un pò meglio, ma in realtà mi servirebbero attivi e so che il mod_rewrite sull'installazione di Apache è attivo.

 

Con la speranza che qualcuno sappia darmi una mano con questo caso, vi saluto cordialmente.

Marcello

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More