Jump to content

[Résolu] MAJ vers 1.0 finale : a pu de boutique !


Recommended Posts

Bonjour


BON. Je viens de refaire une MAJ de ma boutique, tout s'est bien passé, le back-office fonctionne parfaitement cette fois (j'ai pas omis de modifier les droits sur les répertoires comme pour l'install :roll: ) MAIS quand je lance ma boutique, je n'ai plus rien : page vide !!!

Que pasa ? Tout me semble OK pourtant ?

Une piste ? Un indice ?



Purée, je ne vais jamais y arriver !!!

Share this post


Link to post
Share on other sites

Up

Bon, il me semble que dans index.php, la variable __FILE__ prenne une valeur étrange, genre le chemin "serveur" du type /home/www/repertoire-de-ma-boutique/index.php (au lieu d'un logique "/index.php" non ?)


Edit : après vérif c'est effectivement "normal", mais je ne comprends pas pourquoi ça ne roule pas ? Mon ancienne boutique fonctionne toujours quand je remappe le bon répertoire...

Share this post


Link to post
Share on other sites

BON


C'est la m...


J'ai réactivé les erreurs PHP dans config.inc.php juste histoire de voir, et j'ai trouvé la cause => classe/Cart.php, une erreur ligne 738 ! (semble être un soucis de copier/coller - JE N'Y AI PAS TOUCHÉ)

Après rectif au jugé, la boutique fonctionne mais pas de produits quand je clique sur un tag (j'obtiens l'erreur suivante : Fatal error : Call to undefined method Link::goLink() in /home/www/boutique-cabane-du-chasseur/tools/smarty/compile/%

Share this post


Link to post
Share on other sites

Up


Bon, je commence à entrevoir le "problème"... Comme je l'ai lu ici même d'une version à une autre, y'a une sacré adaptation des thèmes à réaliser >:-(

M'apprendra à pas forcément noter ce que j'ai modifié :roll:


nb : j'ai résolu le warning concernant Analytics ainsi que la première erreur (dûe à mon thème, inadapté)... À suivre : n'empêche qu'il y avait bien l'erreur dans le fichier Cart.php !

Share this post


Link to post
Share on other sites

Up

Mes soucis sont en grande partie résolus, ouf !!!

Juste un léger détail : j'utilisais un script pour faire du fading sur une série d'images sur la page d'accueil (dans l'édito) et depuis la MAJ, mon script me fait n'importe quoi ;-)

Je suppose que c'est lié à la présence d'autres scripts JS et notamment de Jquery. Pourtant je ne vois pas pourquoi ça pourrait avoir cet effet car j'utilise le script en question sur nombre d'autres sites, sans aucun problème...

Vais voir pour justement utiliser Jquery, ainsi ça ne devrait plus poser de soucis !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More