Jump to content
peterle1984

Varianten - max Anzahhl?

Recommended Posts

Hallo Leute,

 

Ist es möglich mehrer Varianten zu benützen ?

Mein Shop lässt mir nur 2 Varianten zu ich würde aber 10 mit unterschiedlichen Preisen benötigen.

Share this post


Link to post
Share on other sites

 

Ist es möglich mehrer Varianten zu benützen ?

 

Klar, normalerweise kein Problem. Was pasiert denn wenn du eine weitere Variante anlegen willst?

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Whiley,

 

Mein Shop sagt mir es können maximal 3 Varianten angelegt werden.

Sobald ich eine 4 Variante anlege funktionieren die nicht mehr.

Bei der 4 ändert sich der Preis nicht mehr.

Share this post


Link to post
Share on other sites

so ganz habe ichs nicht verstanden.

Du kannst die 4. Variante anlegen (Fehlermeldun?)?

Du kannst einen weiteren Preis eingeben? und speichern? angezeigt wird aber der Standartpreis?

 

Welche Shopversion hast du denn?

 

Probier doch mal im aktuellen Demoshop

https://www.prestashop.com/forums/topic/464197-prestashop-1611-demoshop/

 

ob das was du machen willst da funktioniert.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Zusammen,

 

ich habe vom Prinzip das gleiche Problem!

 

Ich versuche mal verständlich zu erklären was passiert bzw. was ich möchte

 

Produkt Visitenkarte    -> Rechnung:  1x2x14x13x11x2 = 8008 Varianten

Format:                      1 x hoch

Farbe:                      2 veschiedene

Papier:                     14 verschiedene Sorten

Veredelung:             13 verschiedene

Auflage:                   11 verschiedene Stückzahlen

Versandländer:        2 verschiedene

 

Wenn ich den Generator verwende erhalte ich bei dieser Konfiguration einfach nur ene weiße Seite.

Die PHP Einstellung erlaubt aber 10.000.

 

Selbst wenn ich auf 800 runter gehe legt mir der Generator die Varianten nicht an.

 

Nun meine Frage liegt dies am Generator?

Kann ich irgendwo Werte erhöhen?

 

Vielen Dank für die Hilfe.

 

LG Jürgen

Share this post


Link to post
Share on other sites

 

Wenn ich den Generator verwende erhalte ich bei dieser Konfiguration einfach nur ene weiße Seite.

 

 

Hallo Jürgen,

 

Das Beste ist du aktivierst zunachst "errror reporting"

 

Über FTP die Datei

config/defines.inc.php

/* Debug only */
define('_PS_MODE_DEV_', false);

ändern in:

/* Debug only */
define('_PS_MODE_DEV_', true);

 

Generator verwenden und dann die angezeigten Fehlermeldungen bitte mal hier posten.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hi Whiley,

 

danke für die Antwort.

 

Diese Fehler Meldung kommt

 

Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/web1189/html/shopv4wpresta/classes/Product.php on line 0

 

Hier noch meine Server Einstellungen:

 

http://prntscr.com/8ubasl

 

LG
Jürgen

Edited by webmaster-v4w (see edit history)

Share this post


Link to post
Share on other sites

Also benötigt das Generator-Skript auf deinem Server zur Ausführung mehr als 30 Sekunden.

max_execution_time = 30  erhöhen (wenn du es auf 0 setzt ist die Zeit unendlich - ist aber gefährlich). Ich würde es mal mit 300 - 1000 probieren.

 

Falls es sich nicht bei den Servereinstellungen verändern läßt über php-ini oder htaccess versuchen (Forensuche).

Falls das nicht funktioniert, Varianten auf lokaler Shopkopie erzeugen und Datenbank dann auf den Server spielen.

 

Grüsse

Whiley

Edited by Whiley (see edit history)

Share this post


Link to post
Share on other sites

Hallo,

Ich habe eben ein Produkt angelegt. Ich bin dabei einen Druckshop aufzuabeuen mit Prestashop 1.7.4.3. Hier werden relativ viele verschiedene Varianten angelegt.

Nun, ich habe jetzt bei einem Produkt um die 900 Varianten. -> Erstellt wird das Ganze auch. Versuche ich aber später nochmal im Backend den Artikel aufzurufen, erhalte ich leider nur eine weiße Seite und komm nicht mehr weiter.

Ich habe den Debug Modus bereits eingeschaltet, aber leider tritt keine Fehlermeldung auf, sondern nur die weiße Seite.

MfG

Edited by GtaBK (see edit history)

Share this post


Link to post
Share on other sites

Habe nun doch mal folgende Meldungen im Debug Modus entdeckt. Mir sagt das leider nichts, aber ihr könnt damit vllt. mehr anfangen?

 

 

 

1.jpg

2.jpg

3.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More