Jump to content
styledrum

Problème page produit et déclinaisons

Recommended Posts

Bonjour,

 

Je ne trouve pas de réponse à ce problème, malgré mes recherches...

 

Je suis passé sur 1.6.1.1 et j'ai décidé d'utiliser le thème par défaut... à priori, ça devait aller sans problème...

 

Sauf que non :

 

Lorsque je veux changer la déclinaison d'un produit en front, la page se réactualise et je retombe sur la déclinaison par défaut !

 

Le problème survient sur tous les produits : les anciens, ceux pour lesquels j'ai régénéré les déclinaisons et même les nouveaux ?

 

Visiblement, je ne suis pas le seul à rencontrer ce problème, qui a trouvé une solution ?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

lorsque vous avez fait la mise à jour de PrestaShop avez vous bien mis à jour le template par défaut ?

 

Avez vous essayé de recharger par FTP tous les fichiers du template par défaut ?

 

Voyez vous des messages d'erreur dans la console de votre navigateur (ou firebug) ?

Share this post


Link to post
Share on other sites

Bonjour,

 

lorsque vous avez fait la mise à jour de PrestaShop avez vous bien mis à jour le template par défaut ?

 

Avez vous essayé de recharger par FTP tous les fichiers du template par défaut ?

 

Voyez vous des messages d'erreur dans la console de votre navigateur (ou firebug) ?

 

 

 

Bonjour,

 

Oui j'ai bien mis à jour et Prestashop et le thème par défaut.

Oui j'ai changé manuellement tous les fichiers du template par défaut depuis une nouvelle installation prestashop.

 

Rien n'a changé. J'avais des messages d'erreur pour des fichiers css.map manquants mais je crois que c'est lié à Safari

 

Et au final j'ai réussi à résoudre le problème de manière assez artisanale : je suis allé en BO dans Préférences > Produits et comme par magie, en vérifiant les onglets relatifs aux déclinaisons (simplement en cochant les cases, sans changer les attributs), le problème a disparu !

 

Etrange... A mon avis, la migration depuis une version antérieure ne se fait jamais sans mal !

Share this post


Link to post
Share on other sites

Bonjour

merci !!!! tu me sauves ! j'ai cherché partout sauf là, effectivement le simple fait de passer par préférences/produits et changer une option quitte à y revenir ensuite supprime le bug

pour ma part j'ai activé "Forcer la mise à jour des URL simplifiées"

bonne journée !

:)

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More