Jump to content
RetoFurter

In Frontend werden in der Kategorie auch Artikel aus der Unterkategorie angezeit

Recommended Posts

Werte Mitglieder

 

Ich bin ein relativ neuer Prestashopuser, bin aber mit dem Produkt und dem Ergebnis mehr als zufrieden. Ich habe jedoch noch ein kosmetisches Problem im Frontend, welches etwas unschön ist und ich nicht herausgefunden habe an was das liegt:

 

Ich habe sehr viele Kategorien und Unterkategorien. Die Artikel sind in aller Regel in nur einer Kategorie drin. Im Frontend werden mir komischerweise Artikel aus Unterkategorien angezeigt, wenn die die jeweilige Elternkategorie auswähle. Das würde mich noch nicht stören, resp. kann ja sogar gewünscht sein. Je nach dem wie viele Artikel angezeigt werden, erscheint unten die Auswahl um auf die nächste oder eine andere Seite zu springen. Und hier entsteht dann auch das Problem, denn dieser Vorgang endet mit dem Fehler "Keine Artikel in dieser Kategorie vorhanden". Siehe auch die beiden Anhänge....

 

Stand schon jemand vor diesem Problem oder weiss wie ich diese Sache lösen kann?

 

Prestashop Version 1.6.1.1, alle Module aktuell. Ich bin sehr gespannt und hoffe auf Eure Erfahrungen und Tipps!

 

Im Voraus recht herzlichen Dank!

 

Reto

post-1069838-0-04351000-1442864458_thumb.jpg

post-1069838-0-35817300-1442864465_thumb.jpg

Share this post


Link to post
Share on other sites

Willkommen,

 

hast Du dich im Forum schon ein bischen durchgelesen ?

 

template kompilieren und cache leeren probiert ?

 

welches Theme verwendest Du ?

 

vielleicht hilft das ja:

https://www.prestashop.com/forums/topic/463242-dringend-hilfe-bei-pordukt%C3%BCbersicht/?do=findComment&comment=2123839

Edited by kulli (see edit history)

Share this post


Link to post
Share on other sites

Hallo und besten Dank!

 

Das Forum und die üblichen Suchmaschinen habe ich schon bemüht, bin da aber nicht weiter gekommen. Cache ist im Augenblick noch deaktiviert (habe auch schon aktiviert und dann wieder deaktiviert), Template kompilieren ist ebenfalls ohne Effekt. Ich verwende das Theme PRS030072.

 

Den Beitrag habe ich durchgelesen. Hier habe ich ebenfalls festgestellt, dass die URL offenbar falsch ist.... statt xxxxx?p=2 wird xxx#/page-2

 

Werde dem gleich weiter nachgehen, resp. mich mal mit dem Entwickler in Verbindung setzen. Das Theme neu einspielen ist in diesem Falle nicht wirklich meine erste Wahl, da schon Anpassungen gemacht wurden (vom Entwickler)....

 

Ich lasse von mir hören! Vielen Dank!

Share this post


Link to post
Share on other sites

Hallo RetoFurter und willkommen im Forum!

 

Ich tippe in deinem Fall mal darauf dass du einen Filter bei der Facettennavigation gesetzt hast. Wenn ich mich recht erinnere werden dann alle Artikel aus den jeweiligen Unterkategorien angezeigt. Versuche mal das Modul "Facettennavigation" zu deaktivieren und guck dir dann nochmal dein Frostend an.

  • Like 2

Share this post


Link to post
Share on other sites

Hallo schibulski!

 

Dein Tipp war spitze! In der Tat ist mein Problem damit aus der Welt! Ich habe ziwschenzeitlich vom Hersteller noch ein neues Template erhalten, welches kompatibler sein soll, das hat aber keine Veränderung bewirkt. Die Facettennavigation war definitiv aber die Ursache! Herrvorragend, vielen Dank!

 

Grüsse!

 

Reto

  • Like 1

Share this post


Link to post
Share on other sites

Also liegts am Template und nicht an der Facettennavigation !

im modul facettennavigation gibt es die Einstellung: "Artikel aus Unterkategorien anzeigen - ja/nein)"

Share this post


Link to post
Share on other sites

Also liegts am Template und nicht an der Facettennavigation !

im modul facettennavigation gibt es die Einstellung: "Artikel aus Unterkategorien anzeigen - ja/nein)"

 

 

nö, eindeutig an der Moduleinstellung. Lies nochmal richtig. Hier hat ja keiner was von einem Fehler gesagt. Lediglich die Ursache wurde gesucht. Und die wurde im Modul gefunden, unabhängig davon ob man das ein- und ausschalten kann ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More