Jump to content
Sign in to follow this  
helios17

Probleme avec la base de données ( je crois)

Recommended Posts

Bonjour

j'ai prestashop en local puis sur mon serveur. Je précise qu'il y avait déjà un site que j'ai supprimé.
J'ai vidé la base de données, importer celle en local puis j'ai transféré prestashop par filezilla.
Enfin j'ai modifié le dossier settings.inc.php.
J'obtiens ça
Not Found
The requested URL / was not found on this server.

Ca fait une semaine que je bloque, quelqu'un peut m'aider?

Merci par avance

Share this post


Link to post
Share on other sites

Bonjour,

T'as une URL?

As tu pensé à l'htaccess?

V++

Atch

Share this post


Link to post
Share on other sites

modifie le

define('__PS_BASE_URI__', '/prestashop/');

de ton settings.inc.php.

Share this post


Link to post
Share on other sites

merci pour la reponse,
je le modifie comment

define(’PS_BASE_URI‘, ‘/prestashop/’);

je met quoi à la place?

Share this post


Link to post
Share on other sites

[ RESOLU ] en ce qui me concerne, trouvé tout seul ^^ comme un grand !

Tu as sans doute déjà trouvé mais... tu met le nom du dossier ftp dans lequel tu as mis ta boutique.
Je fais un petit up, j'ai un soucis du même genre:
j'ai fais une copie de ma base de donnée pour mettre en place une nouvelle boutique, j'ai le bon chemin dans le setting.inc.php mais impossible d'ouvrir une page "The requested URL /category.php was not found on this server."
et aucune image apparait (sauf BO ou tout est nikel).
Y a t-il d'autres fichier à modifier dans le setting ?
Est que la cookie_key peut poser probleme ?

Je nage depuis hier et pas d'idée en vue ! quelqu'un peut-il m'aider ?
Merci

--------------------------- Edit 11h58

J'ai essayé de désactiver le htaccess et la miracle tout est là ! donc le soucis viens de la, le probleme c'est que je voudrais bien recuperer la réecriture si importante en SEO ! voici mon htaccess.
Il fontionnait sur un hébergement de base chez phpnet et maitenant je suis sur un hébergement premium toujours chez phpnet. Le site était directement dans le dossier racine, maintenant il est dans un sous dossier, et je vais dessus avec l'adresse d'attente phpnet/monsousdossier/. Une piste ?

# URL rewriting rules
RewriteRule ^([a-z0-9]+)\-([a-z0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/p/$1-$2$3.jpg [L,E]
RewriteRule ^([0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/c/$1$2.jpg [L,E]
RewriteRule ^lang-([a-z]{2})/([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$3&isolang;=$1$5 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2&isolang;=$1$4 [L,E]
RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$2&isolang;=$1 [QSA,L,E]
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]
RewriteRule ^lang-([a-z]{2})/(.*)$ /$2?isolang=$1 [QSA,L,E]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More