Jump to content

Recommended Posts

Boa noite. Após a instalação do Prestashop 1.6.1.1 quando cliquei na opção de ir para o painel administrativo, da erro e fala que a página não existe. Ao invés de direcionar para o admin, ele busca a pagina dentro do site. Help me!

Share this post


Link to post
Share on other sites
Guest Guest

Bom dia. Comigo tambem aconteceu bug após a instalação do Prestashop 1.6.1.1

As imagens sumiram e ao clicar está abrindo uma pagina com a mensagem index.php?controller=404

 

Endereço da loja: www.voloshop.com.br

Desde já agradeço pela ajuda!

Share this post


Link to post
Share on other sites
Guest Guest

Em tempo: No Admin está tudo funcionando perfeitamente. O problema é só na loja.

Obrigado.

Jorge

Share this post


Link to post
Share on other sites

Servidor Windows ? Linux ?

Já gerou um .htaccess correspondente ? no seu back-office na aba: Preferencias -> SEO & URL's -> definir URL da loja -> salvar. Verifique após isto se existe um ficheiro .htaccess com a data recente no seu FTP, na raíz da loja.

Deletou o cache do seu browser e smarty cache - https://www.prestashop.com/forums/topic/287689-cole -  tópico#2

Share this post


Link to post
Share on other sites
Guest Guest

Ok!

A loja já está no ar a 1 anos e meio, fiz upgrad esses dias ai deu erro... 

Segui suas instruções... Fui ver a URL da loja e estava tudo certinho com antes... 

Mesmo assim cliquei e salvar só pra ver o que acontecia e os produtos apareceram. rs

Nunca que eu ia descobrir que o problema era esse... salvar o que pra mim ja estava salvo.

Muito obrigado! Valeu mesmo!!

voloshop.com.br

Share this post


Link to post
Share on other sites

Porque provavelmente o .htaccess não foi gerado. Depende da versão que vc. fez o upgrade para a atual não é gerado mesmo, se vc. não for tocar no tema. Isto depende muito da configuração que vc. fez quando fez u upgrade. Melhor mesmo é não tocar na configuração sugerida....

Share this post


Link to post
Share on other sites

acabei de instalar a ultima versão e na hora de entrar no admin da erro 404, vi que falaram sobre o htaccess, e no meu nao tem, como eu crio ou onde eu pego este arquivo?

Share this post


Link to post
Share on other sites

Crie um ficheiro vazio com o notepad++, suba o mesmo com o filezilla através do FTP para a raíz da sua loja, ou seja aonde a sua loja está no servidor, dê direitos de escrita de 0755 ao menos para este ficheiro (com o fillezilla clicar o ficheiro com mouse direita), e crie um ficheiro novo na aba "preferências" como no tópico #2 descrito.

 

Mas antes de mais nada, vc., deverá verificar se o seu filezilla mostra ficheiros escondidos/protegidos, pois capaz que vc. não ativou a opção e o ficheiro já existe.

 

Como ativar: http://www.tech-evangelist.com/2006/03/12/filezilla-display-hidden-files/

Share this post


Link to post
Share on other sites

Bom dia a todos,

 

Ao entrar agora no meu Admin Prestashop está aparecendo o seguinte erro.

 

 

[PrestaShopException]

Property Employee->lastname is not valid
at line 909 in file classes/ObjectModel.php

904. }
905.
906. $message = $this->validateField($field, $this->$field);
907. if ($message !== true) {
908. if ($die) {
909. throw new PrestaShopException($message);
910. }
911. return $error_return ? $message : false;
912. }
913. }
914.

 

 

Será que tem a ver com o Upgrade que fiz para a nova versão do Prestashop? a 1.6.1.1

Share this post


Link to post
Share on other sites

O erro diz que o usuário (nome do usuário) nao é valido. Vc, fez alguma alteracao no banco de dados ? As credenciais do login estao corretas ?

Share this post


Link to post
Share on other sites

A mais ou menos um mês renomeei meu banco de dados. Será o motivo agora do erro? As credenciais estão corretas.

Share this post


Link to post
Share on other sites

Desative o modo debug incl. erros do mysql, e veja se consegue entrar no admin. O erro vc. vê porque o modo debug está ativado.

  • Like 1

Share this post


Link to post
Share on other sites

Boa tarde.
Estou com um problema parecido.
Acabei de instalar o Prestashop v1.7.0.6, existe já o arquivo .htaccess na pasta raiz, e a pasta está com permissão 777.
Porém, ele abriu a admin uma só vez. Logou normalmente. Mas agora ele redireciona para uma página do site ( www.miacucina.com.br/admin) dizendo:

Erro 404

A página que procura não foi encontrada.
Lamentamos pelo inconveniente.
Pesquise de novo o que procura.

Se alguém puder ajudar. 

Share this post


Link to post
Share on other sites

Boa tarde.

Estou com um problema parecido.

Acabei de instalar o Prestashop v1.7.0.6, existe já o arquivo .htaccess na pasta raiz, e a pasta está com permissão 777.

Porém, ele abriu a admin uma só vez. Logou normalmente. Mas agora ele redireciona para uma página do site ( www.miacucina.com.br/admin) dizendo:

Erro 404

A página que procura não foi encontrada.

Lamentamos pelo inconveniente.

Pesquise de novo o que procura.

 

Se alguém puder ajudar. 

 

A pasta /admin normalmente é renomeada. Verifique no seu FTP qual é o nome novo da pasta.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More