Jump to content

Calcolo spese di spedizione prima della registrazione


davideporfido
 Share

Recommended Posts

Salve, ho notato che quando un utente  aggiunge dei prodotti al carrello calcola già i costi di spedizione, però, se un utente ordina da un'altra nazione dove i costi di spedizione sono maggiori a differenza dell'italia, i costi effettivi li calcola solo dopo aver inserito l'indirizzo di residenza nella registrazione. é possibile non mostrare i costi di spedizione prima della registrazione o prima del login?

Share this post


Link to post
Share on other sites

  • 6 months later...

Buonasera

anche io ho lo stesso problema.

Non è possibile far calcolare le spese di spedizione corrette quando un cliente mette un prodotto nel carrello?
Prima del login fa il calcolo sul corriere predefinito ( miglior prezzo, voto o uno scelto), quando si effettua il login calcola le spese corrette in base alle impostazioni fatte ed ovviamente in base alla nazione del cliente che sta acquistando.

MI si creano problemi sulla convesioni degli acquisti poichè molti carrelli vengono abandonati visto chele spese di spedizione non sono corrette.

 

grazie dell'aiuto

giacomo

Edited by jackozz (see edit history)

Share this post


Link to post
Share on other sites

Sicuramente il sys nn sa dove viene spedito il pacco però nn sempre l'errore è strategico.

Questo nel senso che non tutti prendono bene il fatto di vedere un certo costo di spedizione, di registrarsi e di accorgersi poi che le spese magari sono di 3/4 volte superiori ( parlo di differenze con paesi America, Australia ecc..)

Sicuramente sarebbe un vantaggio quello di non evidenziare le spese di spedizione nel carrello e di poter far calcolare al cliente una stima delle spese di spedizione con la scelta del proprio paese.

Ho innestato il modulo di stima sulla sintesi del carrello ma non mi funziona cioè cambiando la nazione continua a rimanere in ricerca senza dare risultati ( ho ovviamente settato i diversi costi per le diverse nazioni in SPEDIZIONI/MEZZI DI PEDIZIONE.

 

Sai come mai?

grazie mille

Share this post


Link to post
Share on other sites

  • 3 months later...

Interessa molto anche a me, e a mio avviso è un bug. Un cliente non è certo contento di veder cambiare il costo della spedizione una volta registrato.

Ho provato ad attivare la geolocalizzazione tramite IP sperando che automaticamente vedesse da che posto il cliente facesse le richieste, ma niente.

Tra l'altro se si selezionano più corieri disponibili non appare nemmeno la spedizione base.

 

 

N.B.

Errata corrige

Geolocalizzazione: Sembra che in questa maniera funzioni. Mi occorre però fare prove dall'estero. In caso aggiornerò il post.

 

Marco.

Edited by Marco_n (see edit history)

Share this post


Link to post
Share on other sites

Non è un bug, ma un effetto della mancanza di informazioni lato sito.

Attivando la geolocalizzazione risolvi parzialmente il problema, non risolvi per esempio se differenzi sul territorio italiano le spese di trasporto per le isole.

 

Resta il fatto che vi sono utenti (molti, più di quanto si possa immaginare) che utilizzano dei proxy, in quel caso mostrerai spese di gran lunga superiori a quelle reali se gli stessi sono poi in Italia.

 

La corretta esposizione dei prezzi è di fatto possibile esclusivamente se possiedo i dati del cliente, quindi se è loggato.

Questo non accade solo con PrestaShop, ma con qualsiasi piattaforma web.

Share this post


Link to post
Share on other sites

ieri sera ho esattamente fatto così, adesso ho un bel problema, sia non loggato che loggato non mi compaiono le spese di spedizioni, e quando arrivo alla sezione spedizioni mi dice che non ci sono corrieri diposibili per l'indirizzo. Fino a prima della modifica funzionava. Sono in un bel guaio, anche ripristinando le spunte continua a non funzionare.

 

 

#Come al solito ho passato 10 ore a risolvere il problema, poi posto sul forum e risolvo il problema. La prossima volta posterò prima!

Comunque il problema è che avevo due corrieri e uno andava in conflitto con l'altro. Mi sono accorto del problema solo dopo la modifica citata... 

Edited by Marco_n (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More