Jump to content

Problem with the menu when i change the theme

Recommended Posts

Hi everyone!


I need help with the prestashop 1.6.1 i duplicate the theme default-bootstrap to customize it and when i go to the new theme  and refresh my page i see that the logo its not a link anymore and the menu look different like if dosnt have css on it like a list.  theres anyone with the same problem?how cai i fix it i need tu customize that theme. Help!!! i attached a photo to see the problem


Link to comment
Share on other sites

Hello joesbull and everyone,


I've got the exact same problem. I updated from 1.5 to 1.6.1 and updated all modules. I then activated the new theme default-bootstrap and everything seemed fine.

I created a new Theme based on that one and started toying with it. Then, I decided to play with the CSS files by installing SASS and Compass in my computer. I re-compiled the CSS files to verify that everything was working correctly and then the problem started: The CSS files of my blocktopmenu module were not being loaded.


At first I thought I had screwed it up, so I cleaned the cache and changed back to the default theme to start over and "Oh No!", The blocktopmenu didn't have any styles either. Now, I list all actions I've performed since then:

 - Clear the cache manually (deleting /cache/smarty) and using the tool in the Admin Panel

 - Remove the theme cache files manually (/themes/default-bootstrap/cache)

 - Remove all folders under /cache/

 - Disable Smarty cache and Force compile

 - Remove the CSS files under /themes/default-bootstrap/css/modules/blocktopmenu/css/ so to load the default module CSS files

 - Copy the theme folder from a fresh installation to my store

 - Copy the /modules/blocktopmenu/ folder from a fresh installation to my store

 - Verify that the DB ps_theme* and ps_module* entries are the same in the fresh installation than in my store

 - Hours of searching on Google


I don't know in which order I did all that, but the last actions were copying the folders from the fresh installation.


Now the last hint I got was that the CSS file under /themes/default-bootstrap/cache is generated when I remove it, by using each of the CSS files under /themes/default-bootstrap/css/. When I modify, for example, the file /themes/default-bootstrap/css/modules/blockcart/blockcart.css , the new values are added to the CSS file in /themes/default-bootstrap/cache. BUT, the files /themes/default-bootstrap/css/modules/blocktopmenu/css/*.css are not added to that file.

I wanted to search how that file is generated, but I'm new to Prestashop and I don't know where to start from >_< .

Can anybody help?


Thank you very much!


****** EDIT *******

I've disabled all CCC options too. Now the files under /themes/default-bootstrap/cache/ are not being generated, but the system is taking all CSS directly from /themes/default-bootstrap/css/modules/<module>/*.css , but the files /tarecos/themes/default-bootstrap/css/modules/blocktopmenu/css/*.css are not being loaded.

Edited by Tuckson85 (see edit history)
Link to comment
Share on other sites

Hi Tuckson85!


i solved that problem yesterday and i will tell you how i didt, you need to go to the module and restart it and thats it! it works for me but each time i change my theme the module gets the same error... so i hope it was helpful! 

Link to comment
Share on other sites

  • 2 weeks later...

After much searching and trying, I found a few things out myself. What complicates it, is that currently I cannot install additional languages, so it's all in German.


I found out which module was causing trouble in Modules > Positions. I don't know an easy way to find the correct position, so I had to search for "navigation" and go through all positions. It would be handy if there were hints in the output source, but there aren't.


Then I made sure I had found the right module, I switched it off and back on: Edit module, Exceptions: index


Now, knowing the correct name, I was able to find the module in Modules > Modules. The settings dropdown has an item "Reset". I assume that's what has been referred to by "restart". Unfortunately that button does not work in my installation, so I cannot try ...


Is there another way to fix a module than this reset button?

Edited by wdburgdorf (see edit history)
Link to comment
Share on other sites

Hi wdburgdorf,


To be sure you found the right module, in "Modules > Modules", when you click on the default option ("Settings" or "Configure" option, I'm not sure of the right name as my Control Panel is in Spanish), the new page's URL contains the internal name of the module, something like this:


So, the internal name of this module is "blocktopmenu".

Having identified the module, the Restart option is the 5th option of the dropdown, with an icon similar to the Refresh icon ( https://cdn4.iconfinder.com/data/icons/ionicons/512/icon-refresh-128.png ) but backwards.


If that option doesn't work for you, try accessing the URL directly, by modifying the one you get when clicking on "Settings"/"Configure" :

If that doesn't work either, I'm afraid I won't be able to help you, I'm also kind of a newbie on PS >_<.

Good luck!

Link to comment
Share on other sites

Thanks, Tuckson85. The module name in the URL is a nice trick. I wish there was a way to display the internal names in the list of modules. Then one could easily search for them, language independent.


So indeed refresh == reset.


The reset link works, the function does not. Different issue, probably hosting settings. PS seems to want to do some fancy stuff that the security settings won't allow.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...