Jump to content
Xamar

[RESOLU] Modules de page d'accueil dupliqués et Hn

Recommended Posts

Bonjour à tous,

 

Tout d'abord, d'avance pardon si cette question a déjà été posé, puisque malgré mes recherches, je n'ai pas trouvé de réponses.

 

Sur une boutique que je gère, les modules "Block advertising", "Home Block best sellers", "Block new products" et "Block advertising" sont, entre autres, installés et figurent en page d'accueil

 

Seulement voilà, d'après ce que je vois lorsque je consulte le code source de TOUTES les autres pages, ces modules apparaissent sur TOUTES les pages (mais ne sont pas visibles à l’œil nu). 

 

Résultats,  au niveau SEO ce n'est pas terrible, puisque tous les Hn de ces modules se répètent sur toutes les pages.

 

Par ailleurs, puisque c'est toujours sur ce domaine de duplication, lorsque je suis sur une catégorie, les H1 des sous-catégories apparaissent... Lorsque je suis sur une sous-catégorie, les H1 des sous-sous-catégories apparaissent dans le code source, etc.

 

  1. Quelqu'un saurait-il comment résoudre ce problème de modules qui s'affichent sur toutes les pages ?
  2. Quelqu'un saurait-il comment résoudre ce problème de Hn des niveaux inférieurs qui apparaissent ?

Ci-joint, une illustration des deux problèmes (via l'affichage des Hn), lorsque je suis sur une sous-catégorie.

 

Espérant que quelqu'un m'apporte une solution, parce que je ne sais pas du tout comment régler ces soucis... Bonne soirée à vous ! 

Edited by Xamar (see edit history)

Share this post


Link to post
Share on other sites

AHAH, c'était sûr ! :(

 

En bref, mes modules qui sont en page d'accueil et qui contiennent des Hn apparaissent aussi sur les autres pages du site. Les modules ne sont pas visibles sur ces pages en question mais ils le sont dans le code source.

 

Bref ça c'est le premier problème, pour le second je vais attendre, je crois que je fais peur. :/

Share this post


Link to post
Share on other sites

Bon, j'ai trouvé en fait. Peut-on supprimer ou fermer le sujet, svp ? :)

Share this post


Link to post
Share on other sites

Bon, j'ai trouvé en fait. Peut-on supprimer ou fermer le sujet, svp ? :)

 

Ben non, peux t-on au moins savoir comment tu as résolu le problème avant quand même ?

Share this post


Link to post
Share on other sites

rrrhhhooo le curieux :P

apparemment ce forum ne sert, pour certain qu'a prendre... <_<

mais bon pas grave on s'en souviendra

Share this post


Link to post
Share on other sites

rrrhhhooo le curieux :P

apparemment ce forum ne sert, pour certain qu'a prendre... <_<

mais bon pas grave on s'en souviendra

Salut je suis tout a fait ok avec toi , Les petits secrets de certains , Malheureusement le partage ce n'est pas leur point fort :angry: ! Amitiés

Edited by Soyons Solidaires (see edit history)

Share this post


Link to post
Share on other sites

Ehhh du calme, hein, je croyais simplement que personne ne comprenait mon souci, et que donc, ça n'intéressait que moi.  -_-

 

Pour le souci 1/, c'était simplement une histoire de réglage de module, il fallait en gros désactiver les modules en question sur les pages autres que la page d'accueil.

Pour le souci 2/, une suppression de quelques lignes de codes du fichier "category" et c'est réglé !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More