Jump to content
WalterG

[gelöst] Log Dateien (Fehlermeldungen)

Recommended Posts

Hallo,

 

ich bekomme in meinem Shop Fehlermeldungen geschmissen.

Wenn ich auf der Suche nach näheren Informationen über die Platte schaue, dann finde ich eine error_log, in der auch das eine oder andere steht mit dem ich mich mal beschäftigen sollte. Was ich aber leider nicht finde sind Einträge mit Bezug zu den Fehlermeldungen die der Kunde gerade im Shop bekommen hat. Die Datei ist auch gar nicht angefasst worden, die letzte Änderung ist älter als der Zeitpunkt zu dem der Kunde seine Fehlermeldung bekommen hat.

 

Kann mir jemand sagen, wo ich die "echte" log-Datei finde?

 

Danke.

Share this post


Link to post
Share on other sites

Hallo Walter,

 

willkommen im Forum!

 

Im Backoffice -->Erweiterte Einstellungen -->Log-Dateien und dort die rot markierten

 

oder falls es ein Apache Server ist i.d.R.

 

/var/log/apache2/error.log 

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Whiley,

 

im backoffice finde ich gar keine echten Fehler, alle Einträge sind grau.

Und die log zB für Apache finde ich vom Pfad her nicht im Dateimanager des Providers. Also muss selbiger mir endlich mal einen ssh-Zugang oder dergleichen geben damit ich anständig arbeiten kann.

Danke.

Share this post


Link to post
Share on other sites

Naja, die Fehler müssen ja nicht von deinem Shop oder Server kommen. Es könnten ja auch Fehler des Kundenrechners (Browser, Cookies etc sein.

Sind die Fehler denn reproduzierbar, treten sie auf anderen Rechnern auch auf? Wann treten sie auf? Welche Fehlermeldungen?

Share this post


Link to post
Share on other sites

Hallo Whiley,

 

die Fehler kamen definitiv vom Shop.

Es waren dann am Ende die "beliebten" Fehler mit den Versandeinstellungen. Deutschland in Europa und nicht in Deutschland und dergleichen. Beim Anlegen von Bestellungen kamen dann sinngemäss Meldungen Versandoptionen seien nicht verfügbar.

Nach einigen unübersichtlich gewordenen Änderungen hatte ich ein älteres backup eingespielt auf dem die Einstellungen noch nicht korrekt waren. Dadurch tauchten dann meine Probleme auf. Nachdem ich mich erneut durch das Forum gearbeitet habe, habe ich alles wieder so wie es soll.

 

Die Fehlermeldungen schlugen sich leider in den Dateien an die ich im BackEnd des Shops kam nicht wieder.

Die "anderen" log-Dateien liegen ausserhalb meines Zugriffs wie sich herausgestellt hat, mein Zugriff den mir der Provider gewährt ist doch ziemlich begrenzt.

Ich bin da etwas verwöhnt, ich hab zB einen Mailserver auf einem Raspi laufen der geradezu geschwätzig ist. (auch ohne -verbose)

 

Auf alle Fälle Danke für Deine Antworten;)

Grüsse.

Share this post


Link to post
Share on other sites

 

ich hab zB einen Mailserver auf einem Raspi laufen

Das wäre doch mal ein tolles Projekt Prestashop auf einen Raspi zu packen :)

 

Danke für die Infos, ich tippe mal noch das "gelöst" vor die Überschrift.

 

Grüsse

Whiley

 

EDIT:

ich habe gerade gesehen, das Projekt gibts schon:

https://www.prestashop.com/forums/topic/402122-prestashop-on-raspberry-pi-as-testfield/

Edited by Whiley (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More