Jump to content

Mancato Invio E-Mail di conferma ordine e di registrazione


Heolo
 Share

Recommended Posts

Ciao a tutti

Ho letto vari post e pare proprio che il problema dell'invio e-mail sia abbastanza diffuso.

Ho installato PS su un server linux con php 5.2

Il problema che non riesco a risolvere è il mancato invio di e-mail al cliente quando egli
si registra e quando effettuato un ordine gli dovrebbe arrivare un e-mail con il riepilogo dell'ordine
e le modalità di per pagare ( dati banca per bonifico o ricarica postepay.

La cosa strana è che le e-mail inviate dal contact form mi arrivano correttamente mentre le altre no

LA COSA E' MOLTO GRAVE perchè chi fa l'ordine non ricevendo via e-amil le modalità di pagamneto
non sa come procede, non è sufficiente che compaiano mentre sta completando l'odine, stesso discorso vale per i dati di acesso

Spero qualcuno possa aiutarmi inizio a pensare di dover abbandonare Presta Shop anche se mi piaceva molto.

PS) Le e-mail non mi arrivavano neppore dal modulo contatti l'ho risolto leggendo alcuni post, cambiando la cartella mails/it she ho sostituito con la cartella mails/en rinominando en in it. Non vorrei che anche quanto su riportato dipenda daun bug della versione italiana di presta shop, ma in tel caso non saprei cosa sostituire.

Aiutatemi mi dipiacerebbe abbandonare Presta Shop

Grazie

Share this post


Link to post
Share on other sites

Ciao

Di sicuro non è un problema relativo alla cartella mail/it, quindi:

cosa utilizzi al funzione phpmail, o hai impostato i dati dell' smtp ?
l' hosting che utilizzi ti da la possibilità di cambiare la versione di php ?
Non è che le mail vengono considerate spam ? ( provato con un altro indirizzo mail ) ?

Facci sapere

Share this post


Link to post
Share on other sites

1) L'operazione che ho su descritto fatta sulla cartella: cartella mail/it
mi ha risolto il problema dell'invio mai html da form di contatto che ora funziona.

2) Uso la funzione phpmail

3) Ho un server virtuale linux che gestisco con plesk 9.2.3 non so se si può cambiare versione php, in tal caso cosa dovrei mettere?

4) Avevo letto dei post che parlavano della possibilità che l'e-mail finissero nello spam ho controllato ma non ci sono.

Non capisco come mai le e-mail non arrivano solo se inviate dal riepilogo ordini e info pagamenti e i dati di registrazione.

Share this post


Link to post
Share on other sites

Ciao,
non mi stanco di ripetere che PS non ha problemi di mail,
ne in versione inglese ne in versione italiana,
ho analizzato per clienti su almeno 10 hosting differenti queste problematiche,
e in TUTTI i casi erano configurazioni da parte di clienti.

Per quanto riguarda il tuo caso, se ha iniziato a funzionare dopo aver sostituito la cartella it con quella en vuol dire ch ela cartella:
o hai aperto i file con un editor che ho sballato la codifica (bisogna sempre utilizzare editor professionali -gratuiti- che ti facciano verificare che i testi siano in utf-8)
oppure avevi dei problemi di permessi su quella cartella.

Poi alcuni server non permettono l'invio mail con php o via smtp, ma non conosco server che impedisca i due.

Share this post


Link to post
Share on other sites

permettimi... ce ne sono abbastanza ? ho letto x filo e x segno ognuno di essi e nessuno da una soluzione chiara e precisa.
probabilmente xkè questo errore non è generato sempre dallo stesso problema.. ma mi pare eccessivo dire ce ne sono abbastanza... dato che nessuno segnala la soluzione.

nel link che ho segnalato, ho trovato la soluzione al mio problema x e x il mio host, è inutile aprire una nuova discussione anche xkè non posso aggiungere niente di nuovo

Share this post


Link to post
Share on other sites

Se è un problema di configurazione:
- Perchè le e-mail dal form di contatto arrivano correttamente?
- perchè solo quelle che dovrebbero essere inviate dal modulo di registrazione e quello dei pagamenti non arrivano?

io sto usando l'opzione phpmail e non SMTP

Share this post


Link to post
Share on other sites

permettimi... ce ne sono abbastanza ? ho letto x filo e x segno ognuno di essi e nessuno da una soluzione chiara e precisa.
probabilmente xkè questo errore non è generato sempre dallo stesso problema.. ma mi pare eccessivo dire ce ne sono abbastanza... dato che nessuno segnala la soluzione.

nel link che ho segnalato, ho trovato la soluzione al mio problema x e x il mio host, è inutile aprire una nuova discussione anche xkè non posso aggiungere niente di nuovo


Anche secondo me non predere atto del problema che molti segnalano non è giusto soprattutto se si vuole dare quel servizio di conoscenza comune che dovrebbe essere un forum come questo.

Ammesso che il problema delle e-mail sia legato a dei settaggi specifici da fare e non a un problema di PrestaShop
occorrerebe fare due cose:
1) Dare indicazioni chiare su cosa occorre fare per far funzionare l'invio di tutte le e-mail
2) Pensare di cambiare la procedura di settaggio/invio e-mail per rendere il tutto più facile per tutti.

Questo che dico non è una polemica sterile ma vuole essere la sintesi di varie lamentele lette sull'argomento fatte da più utenti. Spero dunque che questo feedback sia preso positivamente per cercare di migliorare questo aspetto per tutti.

Non ho letto se tale problema si presenta solo per la lingua italiana o vi sono lamentele simili anche per le altre lingue.

Share this post


Link to post
Share on other sites

usa smtp, se usi aruba segui il link che ho dato prima


Non sto usando aruba ma un servervirtuale di un altro hosting

ho provato a configurare SMTP con gmail

server posta in uscita (SMTP) - richiede TLS: smtp.gmail.com (utilizza autenticazione)
Usa autenticazione: Sì
Usa STARTTLS: Sì (alcuni client lo chiamano SSL)
Porta: 465 o 587

ma non funziona

Avete altri suggerimenti?

Share this post


Link to post
Share on other sites

Nessuno mi può aiutare????


Devo proprio abbandonare prestashop .... mi dispiacerebbe :-(

ma non si può fare a meno dell'invio dell'e-mail con i dati per il pagamento!!


Aiutatemi a risolvere il problema del mancato invio

Grazie

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Capisco che tu voglia farti pubblicità,
però sarebbe un bene per tutti che
se conosci quali sono i problemi
di configurazione del server
per far funzionare le e-mail,
tu li postassi qui per tutti.

Grazie LucaX3

Non penso che dirlo o meno possa giovare per i tuoi servizi offerti
anzi aiutando gli altri chissa se avrai più clienti.

Share this post


Link to post
Share on other sites

我不卖任何东西 ( l ho scritto in cinese)

Io non vendo nulla (tradotto in Italiano)

Ho già ripetuto mille volte che anche io avevo il vostro stesso problema dell' invio delle mail e non solo quello e nessuno è stato in grado di risolverlo; parliamo di business quindi le mail e tutte le funzioni dell' ecommerce devo essere funzionanti al 100%. Il giorno che ho letto il post di readyshop ho provato a contattarli e mi hanno attivato uno spazio di prova per testare il loro server. Dal momento che il mio e commerce sul loro server funzionava perfettamente e le prestazioni di velocità erano triplicate ho deciso di comprare uno spazio presso di loro. Io non sono in grado di risolvere il tuo problema e ripeto (solo in Italiano) non vendo nulla. Personalmente essendo un commerciante preferisco vendere (pagando 5 euro al mese un affitto.... del mio negozio de pago 2000) ed evitare problemi con il mio ecommerce.
ciao
luca

Share this post


Link to post
Share on other sites

  • 6 years later...

Ciao a tutti

 

Ho letto vari post e pare proprio che il problema dell'invio e-mail sia abbastanza diffuso.

 

Ho installato PS su un server linux con php 5.2

 

Il problema che non riesco a risolvere è il mancato invio di e-mail al cliente quando egli

si registra e quando effettuato un ordine gli dovrebbe arrivare un e-mail con il riepilogo dell'ordine

e le modalità di per pagare ( dati banca per bonifico o ricarica postepay.

 

La cosa strana è che le e-mail inviate dal contact form mi arrivano correttamente mentre le altre no

 

LA COSA E' MOLTO GRAVE perchè chi fa l'ordine non ricevendo via e-amil le modalità di pagamneto

non sa come procede, non è sufficiente che compaiano mentre sta completando l'odine, stesso discorso vale per i dati di acesso

 

Spero qualcuno possa aiutarmi inizio a pensare di dover abbandonare Presta Shop anche se mi piaceva molto.

 

PS) Le e-mail non mi arrivavano neppore dal modulo contatti l'ho risolto leggendo alcuni post, cambiando la cartella mails/it she ho sostituito con la cartella mails/en rinominando en in it. Non vorrei che anche quanto su riportato dipenda daun bug della versione italiana di presta shop, ma in tel caso non saprei cosa sostituire.

 

Aiutatemi mi dipiacerebbe abbandonare Presta Shop

 

Grazie

Ciao

Ho avuto lo stesso problema e sovrascrivendo la cartella mails di una'altra versione di prestashop, ho risolto...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More