Jump to content

[Solucionado] err_too_many_redirects


Recommended Posts

Buenas compañeros he subido mi tienda online al servidor, he seguido los pasos recomendados en diferentes post:

He subido mi carpeta de prestashop al servidor, y tambien he importado la base de datos.

 

Cambios en la base de datos:

 

Tabla: ps_shop_url

- Campo: domain --> www.mitienda.es

- Campo: domain_ssl --> www.mitienda.es

- Campo: physical_uri --> /localhost/ 

 

Tabla: ps_configuration

- Campo: name -> PS_SHOP_DOMAIN value -> www.mitienda.es

- Campo: name -> PS_SHOP_DOMAIN_SSL value -> www.mitienda.es

 

Fichero config.inc.php --> He puesto el nombre de la bbdd, usuario y contraseña.

 

El problema inicial cuando cargaba mi panel de admin, eran 2: El primero es que sale la pagina sin estilos css, y el segundo era que al intentar loguearme me daba errores de permisos, esto ultimo lo he solucionado dando permisos desde Filezilla con el codigo 777 aplicando los cambios a carpetas y subcarpetas. Esto lo he aplicado a la carpeta Config.

 

Ahora la pagina del administrador sigue sin estilos y no me deja loguearme, pero no da ningun error...

 

Si accedo a www.mitienda.es desde Chrome de da el error del titulo err_too_many_redirects, desde internet explorer tampoco funciona.

 

He probado a eliminar el fichero .htaccess y sigue sin funcionar.

 

¿Alguno ve que es lo que estoy haciendo mal?

 

Un saludo a todos.

 

 

 

 

 

Edited by nachfrem (see edit history)

Share this post


Link to post
Share on other sites

Hola

¿Que version es este prestashop?

¿puedes poner el link de la tienda?

 

 

Tabla: ps_shop_url

- Campo: domain --> www.mitienda.es

- Campo: domain_ssl --> www.mitienda.es

- Campo: physical_uri --> /localhost/   <======= ¿tienes una carpeta que se llama asi?........

 

 

Fichero config.inc.php --> He puesto el nombre de la bbdd, usuario y contraseña.  [NO TOCAR ESTE]

 

Fichero settings.inc.php --->  Este es el correcto

define('_DB_SERVER_', 'localhost');define('_DB_NAME_', 'nombre_basedatos');define('_DB_USER_', 'usuario_basedatos');define('_DB_PASSWD_', 'contraseña base de datos');
Edited by aixos (see edit history)

Share this post


Link to post
Share on other sites

Hola aixos, gracias por contestar:

 

Perdona el fichero que modifique fue el que indicas settings.inc.php 

 

La version es: 1.6.0.14

La web es: www.eroticcos.es

Toda la tienda esta en la carpeta localhost, subí la carpeta entera...

 

Ahora que mencionas lo de localhost he probado a poner www.eroticcos.es/prestashop pero me da un error 500...

 

Un saludo, mañana intentaré de nuevo ver el problema, comentaré cualquier avance, muchas gracias.

Share this post


Link to post
Share on other sites

Pues  quita las WWW , porque lo tienes sin ellas  tienes esto :  eroticcos.es/localhost/

 

Tabla: ps_shop_url

- Campo: domain --> eroticcos.es

- Campo: domain_ssl --> eroticcos.es

- Campo: physical_uri --> /localhost/   .

 

 

 

 

Fichero settings.inc.php --->  Este es el correcto

define('_DB_SERVER_', 'localhost');define('_DB_NAME_', 'nombre_basedatos');define('_DB_USER_', 'usuario_basedatos');define('_DB_PASSWD_', 'contraseña base de datos');

tendria que funcionar

 

Tambien se supone que has subido la carpeta en .ZIP  y la descomprimes en el servidor para instalar

Edited by aixos (see edit history)

Share this post


Link to post
Share on other sites

Hola Aixos, quite los WWW que  comentas y ya no me da el error de redireccionamiento, ahora me da un Internal error 500.

 

¿A que te refieres con subir un zip?

 

Yo subí la carpeta prestashop con la que estaba trabajando en local desde Filezilla.

Share this post


Link to post
Share on other sites

No sé porque no lo tienes en la raiz de tu hosting y lo pones en un subdirectorio o carpeta

 

Sobre la pregunta, me refiero a que la comprimes en tu PC en formato .zip la carpeta es para que no haya errores de subida por FTP.

 

luego una vez subida la descomprimes.

 

Luego tendras que arreglar las base de datos como te he puesto. etc...

 

Vacias la cache   etc...

 

conectas la base de datos en  Fichero settings.inc.php --->  Este es el correcto

 

supongo que todo esta correcto los DNS  etc...

 

Revisa todo

Edited by aixos (see edit history)

Share this post


Link to post
Share on other sites

Vale Aixos perdona por esta perdida de tiempo, el problema ha sido mio. No tengo el fichero dentro de prestahsop sino en la raiz, como me has comentado, lo he cambiado en la tabla ps_shop_url, el campo physical_uri ahora ya me deja entrar en el panel de administracion.

 

Gracias Aixos y disculpa este error tan estupido. Seguire buscando el resto de errores, pero este lo doy como solucionado.

Share this post


Link to post
Share on other sites

  • nadie locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More