Jump to content
willx

Disable Caching/ Mod_Pagespeed

Recommended Posts

Hi there, 

 

I've searched on Google and the this forum and couldn't find a solution to disable caching completely. 

 

I'm using 1.6.14 and having annoying caching both frontend and backend.

 

I can confirm that I've followed the instructions here 100% http://www.templatemonster.com/help/prestashop-1-6-x-how-to-clear-smarty-cache.html 

 

I disabled Smarty, CCC, and Caching (the option at the very bottom of the Performance setting) and deleted cache files in /cache/smarty/cache and compile. Also deleted cache in themes/my-theme/cache.

 

I cleared browser cache, load website in Private/ Incognito modes. Tried with IE, Chrome, FF, Opera.

 

Sadly, none of the solutions above helped.

 

My code does not reflect changes immediately and usually takes 30 minutes to see my changes.

 


 

After hours of Googling I found out that this seems to be caused by Apache Mod_Pagespeed. I have full control of VPS account. Can you tell me how to disable Mod_Pagespeed and re-enable it when my site goes live?

 

Thanks,  

 

 

Share this post


Link to post
Share on other sites

Hi..I had the same problem try disabling "Varnish"

 

Share this post


Link to post
Share on other sites

Well, this is old thread, I stumbled on it from google but I think your issue is releated with file expiration headers in htaccess. Try to change the expiration dates of certain files in htaccess file.

Before You blame mod_pagespeed check if You are using it https://ismodpagespeedworking.com

If this is the issue and you have Ubuntu/Debian VPS then in console go to
 

sudo apt-get remove --purge mod-pagespeed-stable

and after that restart apache
 

service apache2 restart

 

Share this post


Link to post
Share on other sites

Hi everyone,

I faced the same problem today, and people usually say: "disable it!"  It should be last option. ;)

I solved like this:

  • Be sure about img folder permission. (In my case, the owner of img folder was root),
    • BTW, If there is an error about permissions, Prestashop says this you on Advanced Parameters > Info page.
    • If you see incorrect permission, you can re-set your file / folder permission. If you can't do this, you have to tell your hosting provider.
       
  • Then flush the cache and restart Apache:
    • # sudo touch /opt/bitnami/apache2/var/cache/mod_pagespeed/cache.flush
    • # sudo /opt/bitnami/ctlscript.sh restart apache

About permission: Usually directories have: 755 and files: 644, but for this issue you can need to set img folder permission as 777.

Good works!

  • Thanks 1

Share this post


Link to post
Share on other sites
On 1/8/2020 at 3:57 PM, SahinSOLMAZ said:

Hi everyone,

I faced the same problem today, and people usually say: "disable it!"  It should be last option. ;)

I solved like this:

  • Be sure about img folder permission. (In my case, the owner of img folder was root),
    • BTW, If there is an error about permissions, Prestashop says this you on Advanced Parameters > Info page.
    • If you see incorrect permission, you can re-set your file / folder permission. If you can't do this, you have to tell your hosting provider.
       
  • Then flush the cache and restart Apache:
    • # sudo touch /opt/bitnami/apache2/var/cache/mod_pagespeed/cache.flush
    • # sudo /opt/bitnami/ctlscript.sh restart apache

About permission: Usually directories have: 755 and files: 644, but for this issue you can need to set img folder permission as 777.

Good works!

mod_pagespeed new directory in apache 2.2  

/var/mod_pagespeed/cache/cache.flush

thanks Sahin it worked for me with no need to change img directory's permission (if I would get any error, I could try to edit permission)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More