Jump to content

Salvataggio dati fatturazione non corretto


freuxbang
 Share

Recommended Posts

Salve, non riesco a capire come mai, quando gli utenti si registrano sul sito e salvano i dati di fatturazione o spedizione per procedere con l'ordine, la provincia "id_state" non sempre viene salvato correttamente all'interno della tabella ps_address.

 

Il valore che viene inserito al posto dell'id_state è 0. 

E quando genero una fattura o vado a vedere i dati di fattura del cliente, come provincia mi spunta Agrigento, anche se il cliente è di Milano. Questo perchè il programma, trovando il valore 0 imposta la prima provincia che si trova in elenco.

 

Ho fatto diverse simulazioni di registrazione in diversi computer con diversi browser, e personalmente non riscontro questo problema. Mi salva correttamente l'id_state.

 

Come posso fare per individuare questo errore e capire come viene generato? 

 

Grazie

 

 

 

 

Share this post


Link to post
Share on other sites

  • 2 months later...

Non sono ancora riuscito a risolvere il problema, ho fatto un debug i dati vengono salvati correttamente all'interno della tabella id_state quando provo a salvare un nuovo indirizzo. Fin quando non riuscirò io a visualizzare l'errore non potrò mai sistemarlo.

 

Una media di 1 indirizzo con id_state = 0 ogni 7 indirizzi inseriti.

 

jh8204.jpg

 

Avete qualche consiglio da darmi?

Che file mi consigliate di andare a controllare? 

E' qualcosa che dipende dal tipo di browser? 

 

Qualsiasi consiglio

 

Grazie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More