Jump to content
wagood

[Free Module] Image Optimization Via Resmush.it Service

Recommended Posts

smushit module that online and on the fly optimize picture size via webservice reSmush.it right after upload.

More info about reSmush.it algorithms on the site xxx

 

Module use watermark hook, so images will be safe even if reSmush.it service will unavilable.

 

Just install module and try upload new product pictures.

 

Tested on version 1.6.1.4

 

21 Apr 2016 Change resmush.it API url accordingly API Endpoint has changed

29 Feb 2016 Fix Deprecated error 

13 Dec 2016 Add 1.7 version

smushit.1.5.zip

smushit.1.6.zip

smushit.1.7.zip

Edited by wagood (see edit history)
  • Like 10

Share this post


Link to post
Share on other sites

Can we smush the images that are already on the host?

 

 

You can start "Regenerate thumbnails" from BO.

Share this post


Link to post
Share on other sites

Hi , has anybody test this for the images that are already on the host? If I install this module and I Regenerate thumbnails from BO will all my images optimized?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi , has anybody test this for the images that are already on the host? If I install this module and I Regenerate thumbnails from BO will all my images optimized?

 

Thanks!

Hi,

 

just read the previous message to get your answer.

Share this post


Link to post
Share on other sites

Update module with some improvements according to the new version of resmush.it api

  • Like 2

Share this post


Link to post
Share on other sites

So this module sends our uploaded image's link to resumush.it for compression, which compresses the image & sends link back to us for download to our server & stores the compressed image on our server only, right?

 

& also does it compress other images than just product images, like slider images, homepage images which usually slows down the loading of index page?

Share this post


Link to post
Share on other sites

So this module sends our uploaded image's link to resumush.it for compression, which compresses the image & sends link back to us for download to our server & stores the compressed image on our server only, right?

 

& also does it compress other images than just product images, like slider images, homepage images which usually slows down the loading of index page?

 

Yes, you are right. It send images to resmush.it server and replace files only if they are can be compressed.

 

Module can compress only product images.

Share this post


Link to post
Share on other sites

Hi!

regarding the image, could someone help to show me how to remove the white background of the thickbox image on product page (when product image zoomed)! Can this thickbox image be shown like it is, not be regenerated and put in the middle of the background?

 

It creates white range around the image which looks not fine for a photo/painting webshop

Following are examples: The first is to show how it is and the second is what I wish

 

Please advise!

 

Thanks

post-849939-0-55780100-1445123523_thumb.jpg

post-849939-0-96459500-1445123536_thumb.jpg

Share this post


Link to post
Share on other sites

You can start "Regenerate thumbnails" from BO.

after "Regenerate thumbnails" from BO where i can see how much bytes reduced ?

because after regenerate, in resmush module settings  total bytes saved was 0 .

Share this post


Link to post
Share on other sites

after "Regenerate thumbnails" from BO where i can see how much bytes reduced ?

because after regenerate, in resmush module settings  total bytes saved was 0 .

 

Maybe they are already optimized

Share this post


Link to post
Share on other sites

Hello, brilliant module! Just wondering that after regenerating thumbnails, I got redirected to a 404 not found page.  I guess the server timed out, however, how do I know if all the image has been regenerated?  Do I just click regen again to let it resume or do I increase the server time-out limit?

 

Thanks again!  26000 bytes saved so far  :wub:

Share this post


Link to post
Share on other sites

Yes, you are right. It send images to resmush.it server and replace files only if they are can be compressed.

 

Module can compress only product images.

 

Thanks for your contributions, I am yet to try and use this module but I am looking for someway to compress all images such as image slider banners etc. is there a way this can be introduced?

Share this post


Link to post
Share on other sites

Hey wagood, thanks for the free module.

 

However, for PS 1.6.1.1 i only get a settings section with a Light mode choice of Yes or No. How do I get it to optimize?

 

Thanks.

 

ps: i think i got it wrong, i thought it can optimize existing pictures as well.

Edited by octb (see edit history)

Share this post


Link to post
Share on other sites

Hey wagood, thanks for the free module.

 

However, for PS 1.6.1.1 i only get a settings section with a Light mode choice of Yes or No. How do I get it to optimize?

 

Thanks.

 

ps: i think i got it wrong, i thought it can optimize existing pictures as well.

 

Existing pictures can be optimizied when you regenerate product pictures from Preference->Images menu

Share this post


Link to post
Share on other sites

after "Regenerate thumbnails" from BO where i can see how much bytes reduced ?

because after regenerate, in resmush module settings  total bytes saved was 0 .

 

Hi, i have the same thing. I have regenerate thumbnails but in the resmush module it says bytes saved was 0 .

Share this post


Link to post
Share on other sites

In the error log I get these messages for each picture when trying to regenerate pictures with the module enabled on PS 1.6.1.4:


 


PHP Deprecated:  curl_setopt_array(): The usage of the @filename API for file uploading is deprecated. Please use the CURLFile class instead in /modules/smushit/libs/RollingCurl/RollingCurl.php on line 307


 


Guess this is the latest thread for this module :-) 


  • Like 1

Share this post


Link to post
Share on other sites

 

In the error log I get these messages for each picture when trying to regenerate pictures with the module enabled on PS 1.6.1.4:

 

PHP Deprecated:  curl_setopt_array(): The usage of the @filename API for file uploading is deprecated. Please use the CURLFile class instead in /modules/smushit/libs/RollingCurl/RollingCurl.php on line 307

 

Guess this is the latest thread for this module :-) 

 

 

Upload fixed version of files. You can replace just smushit.php file.

Share this post


Link to post
Share on other sites

I too have this problem, I regenerated all my images several times, but still 0 bytes saved. And I'm sure the images need to be optimized because in gtmetrix and webpagetest show they can be optimized. Error.log shows nothing, I don't know what I am doing wrong. Light mode is set to NO. I have PS v1.6.1.1 Can you help me? Thanks

Edited by zanpo (see edit history)

Share this post


Link to post
Share on other sites

I  Have the same problem Light mode always set back to NO  no matter if set Yes and save .Any advice ?? 

 

 

P.s 1.6.1.2

Share this post


Link to post
Share on other sites

Hi

 

It is awesome! 

 

What is the difference among smuch.it, Kraken.io and your service in regards to the compression performance? 

 

Thank you so much~

Share this post


Link to post
Share on other sites

Hi 

 

Will this work with the photos on the product description? Thanks.

Share this post


Link to post
Share on other sites

Hi

 

It is awesome! 

 

What is the difference among smuch.it, Kraken.io and your service in regards to the compression performance? 

 

Thank you so much~

 

It is not my service, the service resmush.it is alternative for closed smuch.it

Share this post


Link to post
Share on other sites

I've just downloaded the 1.6 version and tried install but Nothing happens.

 

So I've looked the zip file and there is no smushit folder.

 

I've just made my own and now it's all good but you might want replace the zip file.

 

BTW: very good module.

Share this post


Link to post
Share on other sites

Had the same problem as riras. Fixed with his solution.

The module itself doesn't seem te be working though.. :( No bytes were saved, even when I regenerated the images. Any thoughts?

Share this post


Link to post
Share on other sites

Had the same problem as riras. Fixed with his solution.

 

The module itself doesn't seem te be working though.. :( No bytes were saved, even when I regenerated the images. Any thoughts?

It's working for me.

 

Maybe you already had opt images.

 

Try create a new product with some randon picture and see what happens.

 

Glad to know I was able to help you.

Share this post


Link to post
Share on other sites

I think the problem is that we import/update products, categories, attributes etc.. from a different backoffice system.

Share this post


Link to post
Share on other sites

Good morning,

I would like install your module on PS 1.4.9, but i can't configure it, because all menu disappears...

Do you no if similar module run  with ps 1.4?

Thank you very much

Share this post


Link to post
Share on other sites

I have tried installing this module, but can't find it anywhere in the modules list. BO states that install is succesfull.

 

What name should I look for, or is there some else to fix?

 

Share this post


Link to post
Share on other sites

I have searched everything, but there is nothing called Smushit. In the FTP file manager i can see a file called smushit.php in the /module/ directory but there is no folder with Smushit.

Share this post


Link to post
Share on other sites

Sorry, I don't add module files to smushit folder. Create it manually /modules/smushit and move all files inside or download archive again.

Share this post


Link to post
Share on other sites

Ps 1.6.1.6 regenerate all images Total saved: 0 bytes not working  ...for any fix update please advice 

Share this post


Link to post
Share on other sites

please, if you can solve the problem with the module to work properly again ... Do not optimize images. We will be very grateful. regards

Share this post


Link to post
Share on other sites

hello,

 

your module it's not compatible with prestashop 1.6.1.10, because i regenere all picture product but in module Total saved: 0 bytes, why

 

Thanks

Share this post


Link to post
Share on other sites

I installed this module on a 1.7.0.5
I went to 'Design > Image Settings' and then hit the "Regenerate thumbnails"-button.
Then I go to
'Modules > resmushit > Configure'
And the module says "Total saved: 8646 bytes"

But when I check the image folders the images size are the same as before I did this procedure.

What could be wrong?

Share this post


Link to post
Share on other sites

Hi , I tried to downbload Resmush.it from drop.me and my computer says the file may be corrupted. Is the link from page 1 works for 1.6.1.2 and 3 ? I have noticed may disagreement from users on that topic. WHat can be the risk if it doesn't work ? The shop would still running ?

Share this post


Link to post
Share on other sites

Hi , I tried to downbload Resmush.it from drop.me and my computer says the file may be corrupted. Is the link from page 1 works for 1.6.1.2 and 3 ? I have noticed may disagreement from users on that topic. WHat can be the risk if it doesn't work ? The shop would still running ?

Work for 1.6.1.3

 

Try it link:

https://wetransfer.com/downloads/bbb888b84fd891689ca8dad9a9342edf20170526133328/982cd45e6a489f04ae2c5a73847a6ad520170526133328/e0637c

Share this post


Link to post
Share on other sites

Hi. In Prestashop 1.7.1.1, by installing it as a module it doesn't work properly, takes FOREVER just to load one image and totally disrupts the page (nobody can load homepage or anything).

When I manage to load an image, when testing in front office, the image size is reduced for jpg but not for png images.

 

Any solution to the time it takes to load? And to do without totally disrupting the page?

  • Like 1

Share this post


Link to post
Share on other sites

I installed this addon, and I tried to regenerate miniatures, but it takes lots of time and does not complete. For categories, it completes successfully. For products, it doesn't.

 

I have about 200 products.

 

Here are my server specifics:

 

PrestaShop version: 1.7.1.1
Server information: Linux #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64
Server software version: Apache/2.4.10 (Debian)
PHP version: 7.0.20-1~dotdeb+8.2
Memory limit: 1000M
Max execution time: 1000
Upload Max File size: 10M
 
I think execution time is long enough.
 
Any suggestions?
 
Thanks in advance.
 
Best regards.
Edited by ebbre (see edit history)

Share this post


Link to post
Share on other sites

Thank you so much for this module. Is there any way you can add the ability to resmush CMS (logo, product page description images, etc) and module images?

Thanks again!

Share this post


Link to post
Share on other sites

I donwload the last version for 1.6 (oct 20  2017) and unfortunaltly it doens't work for my shop. I click in Yes and after No and the same result

Total saved: 0 bytes :(

 

Share this post


Link to post
Share on other sites
On 7/2/2018 at 12:40 AM, roberto said:

I donwload the last version for 1.6 (oct 20  2017) and unfortunaltly it doens't work for my shop. I click in Yes and after No and the same result

Total saved: 0 bytes :(

 

 

 

You need to regenerate your images  in Settings -> Images in order to process existing pictures too. Read the posts here for info...

Share this post


Link to post
Share on other sites
On 8-2-2018 at 9:26 AM, kmorgen said:

Did you set smarty performance as in picture?

 

You need to regenerate your images  in Settings -> Images in order to process existing pictures too. Read the posts here for info...

 

Knipsel.JPG

Share this post


Link to post
Share on other sites
On 6/10/2015 at 2:03 AM, wagood said:

smushit.1.7.zip

I uploaded this on my Prestashop version 1.5.6 & the modul page disappeared.

I have not installed the module & just uploading it causes problems. Very strange indeed.

How can I restore the module page?

 

Share this post


Link to post
Share on other sites
4 minutes ago, slashdev said:

I think you have to remove folder modules/smushit

I did but still getting the same result most of time. It seems the module folder has something that attaches to the page & causes problems. i do not know but this problem happened since I uploaded the module.

 

Share this post


Link to post
Share on other sites

¿Cómo afecta al SEO al mandar las imágenes a resmush.it? ¿Posicionan igual las imágenes desde mi web?

Gracias.

-----

 

How does it affect SEO by sending images to resmush.it? Do they position the images the same from my website? Thank you.

Share this post


Link to post
Share on other sites
Le 09/05/2019 à 10:58 AM, MariaMM a dit :

¿Cómo afecta al SEO al mandar las imágenes a resmush.it? ¿Posicionan igual las imágenes desde mi web?

Gracias.

-----

 

How does it affect SEO by sending images to resmush.it? Do they position the images the same from my website? Thank you.

Knowing that nothing changes on your site except the fact that the images are lighter, no need to worry about SEO other than by speeding up the display of the site.

Share this post


Link to post
Share on other sites

The module didn't work for me though. It reduces the size of the images significantly but on the other hand, messed up my site.

My site performance in GTmetrix :

PageScore: 94

Yslow: 78

But after regenerating thumbnails it decreases to 68 and 59 respectively. 

Please make sure to have a backup before using this module, you'll never know what might happen using a third party module. Just a friendly advice :)

 

Share this post


Link to post
Share on other sites
Il y a 2 heures, Himanshubishtt a dit :

The module didn't work for me though. It reduces the size of the images significantly but on the other hand, messed up my site.

My site performance in GTmetrix :

PageScore: 94

Yslow: 78

But after regenerating thumbnails it decreases to 68 and 59 respectively. 

Please make sure to have a backup before using this module, you'll never know what might happen using a third party module. Just a friendly advice :)

 

You accuse a module that just compresses the weight of the images of not working because your GTmetrix score does not improve????????
Has the weight of the images already changed? Have you taken the time to control this point which is the primary function of this module?
Afterwards, concerning the GTmetrix score, have fun taking it several times a day and look at it without changing anything to your site if it is different or stable.
And also check what changes in value between each note to identify the source of this change in result.

Share this post


Link to post
Share on other sites

Hello,

Is it compatible with PS 1.7.5.2? I can't upload product images after install it. I receive a n/a status code.

Best regards,

Screenshot from 2019-08-05 11-35-16.png

Screenshot from 2019-08-05 11-29-36.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More