Jump to content

Can a module which requires PHP 5.4 be accepted on the addon store


Andréas
 Share

Recommended Posts

Hi everyone,

 

I'm making a very special module which will help PrestaShop module development by bringing Laravel's API to prestashop.

 

I know it's a crazy idea but I like it :).

 

So my question is : is there a way my module get accepted even if it requires PHP 5.4 and does not have the right folder organization ?

 

Thank you,

Andréas

Share this post


Link to post
Share on other sites

My first thought is no, as Prestashop still uses PHP 5.2 as their minimum requirements.  Since most merchants will have no clue about this, they will purchase your module and then realize it will not work, and either request a refund or dispute/chargeback the purchase.

 

PS validator team will likely reject the module out right if it does not conform to their standards (ie folder organization).

 

Also, you might want to repost/move this to the Addons section on the forums, in order to get the correct visibility from the addons team

Share this post


Link to post
Share on other sites

Thank you for your responses, that's what I thought.

 

Did you have any plans to update the PHP version requirement to 5.4 any time soon ?

 

So my module will stay unofficial for now... anyway it's a big hack so I doubt PrestaShop gurus will like it.

 

Bye,

Andréas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More