Jump to content

Prestashop Newsletter Popup [FREE MODULE]


Recommended Posts

  • Replies 340
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Prestashop Newsletter Popup FREE MODULE   Prestashop Newsletter Popup module is a free prestashop module that lets the user to create a wonderful newsletter popup where you can put your own texts, i

First, caveats;   My setup - PS V1.6.10 - Blocknewsletter V2.3.2 - Prestapopup V1.0 (from top of this thread)   I've been using Prestashop for less than a week so I'm on the lower slope of the lea

Hello, thank you for sharing    People who downloaded without saying thank you is not nice of you   Les gens qui telecharge sans dire merci c'est pas sympa de votre part

Posted Images

Downloaded from here and from Den's page. Not working in vs 1.5.5.0. There's no buttom to show only at home page and there's no way to change the default picture(even via FTP). In front office does not popup in any browser (seven tested) even clearing server or browsers cache and cookies. Good module, but it has to work.

Share this post


Link to post
Share on other sites

Hello,

thanks for the module. Its easy to use. But I have problem with background picture. I cannot change it. If I change it, the default picture remain in pop up and when i go back to admin, the default picture is again uploaded as background picture? Could you help me with this issue?

Thanks

Tomas

Share this post


Link to post
Share on other sites
  • 5 weeks later...
  • 2 weeks later...

 

salut

 

Am aceeas  problema ca cea descrisa de professionisr mai jos .Totul e ok pana apas pe submit ,nu se intampla nimic.

Am cautat adresele in ps_newsletter database  si exista ,dar nu apar in lista de abonati si ca atare nu pot retrimite automat mesaje catre abonati...

 

Multumesc anticipat

 

 

 

Hello!  Thank you for this amazing free module!

 

i installed it, configured and translated to italian language.

But it seem it doesn't works...

 

The popup appear correctly... i insert an address and then click on submit...   No actions...

If i try adding the same email address, popup says me that the address is already registered.

 

My questions are:

- When i click on submit, what i have to wait for? A confirm? the popup close automatically?

- When it works correctly, where i see email addresses registered?

 

Can you help me? 

- i don't have problem with fancybox

- Everything work without problems...

 

Hello,

 

have the same problem like some others too. But I don't see any answer. Strangely!

 

desta

1.6.0.9, default bootstrap

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Hello, first of all I would like to thank the creator of this module. You sir, have a generous and kind heart.

 

However, I have a problem with email registration. As I try to put several email address for registration, the system keep on saying the email already taken.

 

Second, may I know where the database will go?

 

If you would like to check direct to my website, have a look at www(dot)superheroescloset(dot)com

 

Looking forward for your help sir.

 

Regards.

Share this post


Link to post
Share on other sites
Thanks for the module works very well.

There is only a small problem, I insert the email then click on the submit button and the popup does not close, it seems nothing happened.

 

But if I go to check in the db ps_newsletter there is the email I entered.

 

The problem is: I do not get the confirmation email and that the popup does not close.

 

Does anyone know how to fix? many thanks in advance

Share this post


Link to post
Share on other sites

Gracias por el módulo, en mi caso no encontraba las funciones del .fancybox y he tenido que añadir lo siguiente en el prestapopup.php en la funcion hookDisplayHeader y ya funciona bien! PsVersion 1.6.1.1

public function hookDisplayHeader()
	{
		$this->context->controller->addCSS(($this->_path).'css/prestapopup.css', 'all');
                $this->context->controller->addJqueryPlugin('fancybox');		
			
	}
Edited by goodluck11 (see edit history)

Share this post


Link to post
Share on other sites

 

Gracias por el módulo, en mi caso no encontraba las funciones del .fancybox y he tenido que añadir lo siguiente en el prestapopup.php en la funcion hookDisplayHeader y ya funciona bien! PsVersion 1.6.1.1

public function hookDisplayHeader()
	{
		$this->context->controller->addCSS(($this->_path).'css/prestapopup.css', 'all');
                $this->context->controller->addJqueryPlugin('fancybox');		
			
	}

Ni siquiera puedo resolver el problema de esta solución. Después de eso escribo el correo electrónico y hacer click en enviar, se cierra el pop-up. También utilizo la versión 1.6.1.1. ¿Alguna idea?

Share this post


Link to post
Share on other sites

Thank you for this great module!

However i have some problems, first i cannot find the email adresses that have been entered and when i click on the submit button it doesnt close the box.

 

Thanks

Share this post


Link to post
Share on other sites

i found that the problem is due to that it dont send a confirmation message to the person who register that is why they dont appear in newsletter table. How can i fix that please.

Thanks

Share this post


Link to post
Share on other sites

Ho installato il modulo e configurato come da guida ma non si visualizza nè nella home page e neppure nelle pagine interne.
Nel codice vedo che ci sono i riferimenti agli scripti e ai css ma sul sito, lato utente, nessuna traccia...

Chi riesce a darmi un aiuto?

 

Grazie

Share this post


Link to post
Share on other sites

Hi Sir,

 

Nice module 

But when I install this model after putting my information when I save it it will go to error 404 page on my website 

 

Please write a solution

 

 

Thanks

Bilal Ahmad

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Ho installato il modulo e configurato come da guida ma non si visualizza nè nella home page e neppure nelle pagine interne.

Nel codice vedo che ci sono i riferimenti agli scripti e ai css ma sul sito, lato utente, nessuna traccia...

Chi riesce a darmi un aiuto?

 

Grazie

Non so aiutarti, però avrai notato che sei nel forum inglese.. nessuno in 12 pagine ha scritto in italiano.

Prova a tradurre la tua richiesta per ricevere un aiuto.

Share this post


Link to post
Share on other sites

hi

I have a problem with the module. When entering the email in the subscription box , pop -up will not close and not save the mail in the newsletter block....

 

Can help me please??

 

my web is... www.vaffanculoshop.es

 

thanks you!

  • Like 1

Share this post


Link to post
Share on other sites

 

hi

I have a problem with the module. When entering the email in the subscription box , pop -up will not close and not save the mail in the newsletter block....

 

Can help me please??

 

my web is... www.vaffanculoshop.es

 

thanks you!

We all have the same problem, this module does not work.

 

...Complimenti per il nome del sito ahahah

Share this post


Link to post
Share on other sites

 

 

We all have the same problem, this module does not work.

 

hi

I have a problem with the module. When entering the email in the subscription box , pop -up will not close and not save the mail in the newsletter block....

 

Can help me please??

 

my web is... www.vaffanculoshop.es

 

thanks you!

 

I have a module newsletter popup that it works, you send me a message for inbox 

Share this post


Link to post
Share on other sites
  • 3 weeks later...

It works well, except that it breaks my owl carousels on the homepage (they use timeout) and they dont work anymore...

No error in console.

Any ideas ?

Share this post


Link to post
Share on other sites

Do you have any idea why it doesnt send any voucher emails? I have tryed change some php functions but still it doesnt work. If anyone know how to fix it, plz help :) Anyway this is very good mod :)

Share this post


Link to post
Share on other sites
Hello From Moscow! Thx you for module!

 

So I have one problem with this module.  For example I'm client and I'm going to my website then I see popup and just click Close it, when I reload my homepage its show again!(( How can I fix it? I'd like just close popup newsletter I don't want to subscribe just browse, and I want it doesn't annoy me every time when I reload my homepage or comeback to homepage. Thx you!

Share this post


Link to post
Share on other sites

 

Hello From Moscow! Thx you for module!
 
So I have one problem with this module.  For example I'm client and I'm going to my website then I see popup and just click Close it, when I reload my homepage its show again!(( How can I fix it? I'd like just close popup newsletter I don't want to subscribe just browse, and I want it doesn't annoy me every time when I reload my homepage or comeback to homepage. Thx you!

 

Start reading - you have answer in this topic few posts before

Share this post


Link to post
Share on other sites

Start reading - you have answer in this topic few posts before

I have read and didn't find answer.. Can you copy past it please or write it here? Thx.

Share this post


Link to post
Share on other sites

Thank you for the cool pop up.

Is there a way to stop the pop up from keep coming back even if the customer do not subscribe?

 

Thanks

 

Hello sir,

 

You just have to add 'coockieSession_popup()' in the file 'yoursite/modules/prestapopup/views/prestapopup.tpl' at line 130 as seen in this screen ->http://screencast.com/t/x4XG7yRrqk

 

This will create a cookie on your client's computer and it will not show the Popup for 3 months.

If you want to show it after one month, search for coockieSession_popup() and instead of 

expire_date.setMonth(expire_date.getMonth()+3);

Put the following :

expire_date.setMonth(expire_date.getMonth()+1);

Hope this helped.

 

 

First page ;) still i need help with voucher code auto send after subscription. 

Share this post


Link to post
Share on other sites

First page ;) still i need help with voucher code auto send after subscription. 

thx for help buy when I put this code my some images disappeared.. Here is the screenshot take a look please and tell me what I did wrong? Thx. 

 

P.s- Btw I cannot open the screenshoot which in post it gives an error..

post-1241832-0-57512600-1464103980_thumb.png

Share this post


Link to post
Share on other sites
images disappeared.

 

What does it mean? 

 

Try to add after the

'coockieSession_popup()' 

 

This:

 

 

expire_date.setMonth(expire_date.getMonth()+3);

Share this post


Link to post
Share on other sites

What does it mean? 

 

Try to add after the

This:

Can you please take a screenshot of your code how should i do it?

 

It means when I add this code in code some of my images has disappeared .. I mean ( They don't display my some of images correctly) 

Share this post


Link to post
Share on other sites

Hi!

 

The confirmation Email isn't send in Prestashop 1.6.0.11, any solution?

 

Thanks

i have the same problem.

I think bug is in file subscribe.php between line from 49 to 78 but i dont'know how to fix it.

Share this post


Link to post
Share on other sites

Hi Patri,

i had a problem with the module. I've installed it in local and it's all work fine, just what i want. 
So, i've installed on the web, i go to configure, but clicking on "save" at the end of the page became a Forbidden message From Apache Server.

 
Enabling the error log, does't appear nothing.
By FTP e saw for permission, all folders are 0755 and the other file 644.. so i don't know how it's broken! 
 
What can i do to make it work?
 
Thanks!
post-782640-0-80391600-1465316962_thumb.png 
Edited by Andrea_Firenze (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

hello

i use prestashop 1.6 and today i install you free modules but if i reflesh my website then noting happens :(

my website adress www.raptown.pl

please reply me

best regards

  • Like 1

Share this post


Link to post
Share on other sites

i have the same problem.

I think bug is in file subscribe.php between line from 49 to 78 but i dont'know how to fix it.

 

Hello , same problem, have you find a solution ? please

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Thanks for the module.

 

I have installed it and have the following issues:

 

1. When I enter the email address and click SUBMIT, there is nothing to tell me that it has accepted my email address and the popup remains.

2. if i enter the same email address again, it says "he mail address is already registered"

 

I have checked the Newsletter table and it contains the test email addresses that I have entered but how do I export these via the Back Office??

 

cheers

Greg

Share this post


Link to post
Share on other sites

Hello, has anyone find out how to make the module send confirmation emails to people who have subscribed to the newsletter???

 

 

i found that the problem is due to that it dont send a confirmation message to the person who register that is why they dont appear in newsletter table. How can i fix that please.

Thanks

 

 

it works good on your webiste?

 

The problem is: I do not get the confirmation email and that the popup does not close.

 

 

 

Thanks for the module works very well.
There is only a small problem, I insert the email then click on the submit button and the popup does not close, it seems nothing happened.
 
But if I go to check in the db ps_newsletter there is the email I entered.
 
The problem is: I do not get the confirmation email and that the popup does not close.
 
Does anyone know how to fix? many thanks in advance

 

 

 

Hello , my question is that does not send the newsletter popup confirmation e- mail that income , if I can help I would appreciate , thanks

Share this post


Link to post
Share on other sites

Okay, I'm sorry, the problem is that your developer or who built your website deleted the displayHome hook from your homepage i believe, you should ask them what they've modified.

Or search in all of your folders(in your themes/yourtheme/) search for $HOOK_HOME , see if you have it installed somewhere.

This solved my problem. Thanks!

Share this post


Link to post
Share on other sites

Hi, thank very much for this great module!

 

I installed it in my site, but when I try to save the changes in the backoffice, the 404 page appears and I can't save it.

 

Any idea what i'm doing wrong?

 

Thank you!

Share this post


Link to post
Share on other sites
  • 2 weeks later...

When I press the submit button, nothing happens. When I press it for the second time, it says"The mail address is alreadt registered"

 

What should I do?

I have the same problem. Did you solve it somehow? Thank you

Share this post


Link to post
Share on other sites

Same problem here! 

Still recieving error 500 (both "old" and "fixed" version) in console. When I press Submit button, nothing there. Press it again - "This email address is already registered" and error 500. No matter what is permission - 777, 755, 666, 775 ... it's the same error 500 or 404. 

Please, it's a good module, but obviously is not a server issue.

Edited by triplehorn (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Thanks for this module.

 

I have and odd problem. No image shows whatsoever. I've chmoded folder to 777, but no image appears at all.

 

Any idea on what can be wrong? I couldn't find answer in this thread to my problem.

 

Thanks in advance.

 

Cheers.

Share this post


Link to post
Share on other sites

I thank you for this module but impossible to charge a picture. I delete the red picture i put one of me but it does not want . How to solve this problem . I use prestashop 1.6.0.11 Thank you. Regards. Anne

Share this post


Link to post
Share on other sites

There is a problem with the token IF in the subscribe.php file.

 

If you don't want to sent confirmation email to new subscribes (subscribe it in only one step) you can remove this lines (108 to 127) from subscribe.php and it will work:

 

{

// create an unactive entry in the newsletter database
if ($register_status == $this->GUEST_NOT_REGISTERED)
$this->registerGuest($email, false);
if (!$token = $this->getToken($email, $register_status))
return json_encode(array("message" => $this->error = $this->l('An error occurred during the subscription process.'),"code" => 0));
$this->sendVerificationEmail($email, $token);
echo json_encode(array("message" => $this->error = $this->l('A verification email has been sent. Please check your inbox.'),"code" => 0));
}
else
Edited by nuclimedia (see edit history)

Share this post


Link to post
Share on other sites

Buenas estoy teniendo problemas con el error 500. Viendo el fichero error_log me ha salido esto:

 

[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(/home/huertosr/public_html/pruebas/tools/swift/Swift.php): failed to open stream: No such file or directory in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 18
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(): Failed opening '/home/huertosr/public_html/pruebas/tools/swift/Swift.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 18
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(/home/huertosr/public_html/pruebas/tools/swift/Swift/Connection/SMTP.php): failed to open stream: No such file or directory in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 19
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(): Failed opening '/home/huertosr/public_html/pruebas/tools/swift/Swift/Connection/SMTP.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 19
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(/home/huertosr/public_html/pruebas/tools/swift/Swift/Connection/NativeMail.php): failed to open stream: No such file or directory in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 20
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(): Failed opening '/home/huertosr/public_html/pruebas/tools/swift/Swift/Connection/NativeMail.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 20
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(/home/huertosr/public_html/pruebas/tools/swift/Swift/Plugin/Decorator.php): failed to open stream: No such file or directory in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 21
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Warning:  include_once(): Failed opening '/home/huertosr/public_html/pruebas/tools/swift/Swift/Plugin/Decorator.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 21
[26-Sep-2016 13:57:49 Europe/Madrid] PHP Fatal error:  Class 'Swift_RecipientList' not found in /home/huertosr/public_html/pruebas/override/classes/Mail.php on line 107
 
Alguna idea de cómo solucionar esto? Gracias!

Share this post


Link to post
Share on other sites

I thank you for this module but impossible to charge a picture. I delete the red picture i put one of me but it does not want . How to solve this problem . I use prestashop 1.6.0.11 Thank you. Regards. Anne

I had the same problem and i solve it doing simple step. Maybe is not good for u but u can try. Just erase the photo. Save without photo. Delete cookies and cache of your browser and then try to upload and save the photo u want. I hope it works for you.

Share this post


Link to post
Share on other sites

Good Morning!

 

  1. I need some help. Did u finally know how to fix the problem: "the email is already registered" that appears wich every email u use for subscribe?
  2. In the other side, how i can make that the popup appears in the homepage? no just appears in the other pages of the site.
  3. Is it possible to avoid the popup inside the site afte u close the window even if u dont subscribe?

 

Thanks for all!!

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi, 

 

I am getting below error. i am using prestashop 1.6.1.7

 

Fatal error:  Call to undefined method prestapopup::getToken() in /demo/modules/prestapopup/subscribe.php on line 57

 

Please help.

Share this post


Link to post
Share on other sites

Edit: post #269 fix error
------------------
i have error:

 

Call to undefined method prestapopup::getToken() in /..../subscribe.php on line 57

 

chrome console:

 

jquery-1.11.0.min.js:4 POST /subscribe.php 500 (Internal Server Error)

Edited by selljus.pl (see edit history)

Share this post


Link to post
Share on other sites

Good Morning!

 

  1. I need some help. Did u finally know how to fix the problem: "the email is already registered" that appears wich every email u use for subscribe?
  2. In the other side, how i can make that the popup appears in the homepage? no just appears in the other pages of the site.
  3. Is it possible to avoid the popup inside the site afte u close the window even if u dont subscribe?

 

Thanks for all!!

if u enable this one, Show The Newsletter PopUp only on Homepage

the popup just show in your home page

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hello, 

 

I have been using this module for some time now and everything was ok. Yesterday I tried to change picture but it doesn't work. I used all advices from previous posts here (including 777 etc), but when I upload picture I have no preview on it (looks like it's not found-broken url). 

Pop-up works, text as well but no picture. 

So I deleted module (also from FTP) and installed it once again from zip file and now even original fashion photo is not working! 

I have this error in console: Failed to load resource: the server responded with a status of 404 (Not Found) - but picture is on FTP, has original name. 

So I have no idea what has happened. 

My presta version: 1.6.1.4

 

Has anyone had similar problem?

I will be gratful for any advice. 

Share this post


Link to post
Share on other sites

hi all,

I've implemented the module on my side, but:

1) when user enters his/her mail and click on submit (zapisz) there's no reaction - neither the user mail gets recorded not the window is closed.

 

question - what;s the popup behaviour and how to fix it?

Share this post


Link to post
Share on other sites

hi all,

I've implemented the module on my side, but:

1) when user enters his/her mail and click on submit (zapisz) there's no reaction - neither the user mail gets recorded not the window is closed.

 

question - what;s the popup behaviour and how to fix it?

I have the same problem. Did you solve the problem?

  • Like 1

Share this post


Link to post
Share on other sites

Hi all,

 

thank you patri_rapty for the module.

 

I've installed the module but it is shown only on mobile. I've checked positions in BO and the module is in the displayHome hook. 

 

I'm using Prestashop 1.6.1.1.

 

Can you help me?

 

Thank you

Edited by The_Snowblind (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
  • 4 weeks later...

So the author is MIA and the module does not send a confirmation email. That's very sad!
It's good that we have a solution to the popup reappearing on all pages, but it's not enough!!!
Without a confirmation email (with the voucher code in it!!!) this module is useless :(
It's sad because a free NL popup module is a great initiative.

I was expecting for some fix from another programmer, giving the fact that the module in open-sourced.
I guess the source of the problem evades them.

If we get a hold of the author or a fix, we will all celebrate, but until then this module will be deactivated in my current shops.

Share this post


Link to post
Share on other sites

Hello everybody, can anyone help me in how to active fancybox? I have installare the module, popup is ok but if i submit an email address, i don't see the registered customer in back office.Thanks very much!

 

P.s. great module!

Share this post


Link to post
Share on other sites

Thank you for the module but is installed but in the site don't show anything.

 

A mysterious. Thanks anyway!

 

Try www.ohmyicons.com and tell me if you see any popup. See ya!

Hi DArnaez,

 

I do see the popup working.

Share this post


Link to post
Share on other sites